Hdoj 1159.Common Subsequence 题解

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003



思路

  • \(X=(x_1,x_2,x_3,..)\)和\(Y = (y_1,y_2,y_3,...)\)的最长公共子序列\(LCS(X,Y)\)
  • 最优子结构证明
    • 如果\(x_n==y_n\)那么\(LCS(X_{n-1},Y_{n-1})\)就是一个子问题
    • 否则就是$,,LCS = max(LCS(X_{n-1},Y_m),LCS(X_n,Y_{m-1})) $

证明完成之后,显然可以容易得到状态转移式,用\(f[i][j]\)表示长度为i的s1和长度为j的s2的最长公共子序列的长度,详见注释:

#include<bits/stdc++.h>
using namespace std;
int f[1001][1001];
int main()
{
    string s1;
    string s2;
    while(cin>>s1>>s2)
    {
        int len1 = s1.size();
        int len2 = s2.size();
        memset(f,0,sizeof(f));//初始归0
        for(int i=1;i<=len1;i++)
            for(int j=1;j<=len2;j++)
                if(s1[i-1] == s2[j-1])
                    f[i][j] = max(f[i][j],f[i-1][j-1] + 1);//如果末尾相等,就是比较前n-1长度的LCS+1和自己的
                else
                    f[i][j] = max(f[i][j-1], f[i-1][j]);//如果末尾元素不相等就划分到子问题里
        cout << f[len1][len2] << endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/MartinLwx/p/9822825.html

时间: 2024-11-09 05:58:37

Hdoj 1159.Common Subsequence 题解的相关文章

hdoj 1159 Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequ

hdoj 1159 Common Subsequence【LCS】【DP】

Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 28494    Accepted Submission(s): 12735 Problem Description A subsequence of a given sequence is the given sequence with some e

hdu 1159 Common Subsequence(最长公共子序列 DP)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1159 Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25416    Accepted Submission(s): 11276 Problem Description A subsequence of

POJ 1159 Palindrome &amp;&amp; HDU 1159 Common Subsequence

1.先说说杭电的1159吧! 这道题是基础动规,比较简单! 就是要你求最长的公共子序列(不要优化) 动态转移方程: dp[i+1][j+1]=(a[i]=b[i])?dp[i][j]+1:max(dp[i+1][j],dp[i][j+1]) AC代码: #include<stdio.h> #include<string.h> #include<algorithm> using namespace std; #define N 520 char a[N],b[N]; in

hdu 1159 Common Subsequence(最长公共子序列)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1159 Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 37551    Accepted Submission(s): 17206 Problem Description A subsequence of

HDU 1159——Common Subsequence(DP)

Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23279    Accepted Submission(s): 10242 Problem Description A subsequence of a given sequence is the given sequence with some e

HDU 1159 Common Subsequence(裸LCS)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1159 Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 47676    Accepted Submission(s): 21890 Problem Description A subsequence of

HDOJ 题目1159 Common Subsequence(LCS)

Common Subsequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25791    Accepted Submission(s): 11432 Problem Description A subsequence of a given sequence is the given sequence with some e

hdu 1159 Common Subsequence(dp 最长公共子序列问题LCS)

最长公共子序列问题(LCS,Longerst Common Subsequence). s1s2……si+1和t1t2……tj+1的公共子序列可能是: ①当si+1=tj+1时,在s1s2……si+1和t1t2……tj+1的公共子序列末尾追加一个. ②s1s2……si+1和t1t2……tj的公共子序列 ③s1s2……si和t1t2……tj+1的公共子序列 所以易得到递推关系dp[i+1][j+1]=  max{ dp[i][j]+1 , dp[i][j+1] , dp[i+1][j]) }