PAT Advanced 1078 Hashing (25) [Hash ?次?探查法]

题目

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions. Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize(<=10^4) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line areseparated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one
line. All the numbers in a line are separated by a space, and there must be no extra space at the end of
the line. In case it is impossible to insert the number, print “-” instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 –

题意

  1. 输入一系列数字存入哈希表,二次探测解决hash冲突,哈希函数为H(key)=(key+step*step)%size,输出key存放在哈希表的下标,如果不能存入输出"-"
  2. the size of hash table必须为质数,如果不是质数,取比不小于size最小质数作为size的值

题目分析

  1. 用数组作为hash table,存放输入的数字。
  2. 二次探测解决hash冲突,第一次(key+0)%size,第二次key(key+11)%size,第三次key(key+22)%size....,step取值范围为[0,size-1](step取值范围晴神笔记P217有证明)。注意是H(key)=(key+stepstep)%size,而不是H(key)=key%size+stepstep(会越界)

知识点

  1. 判断质数
bool isPrime(int num) {
    if(num==1)return false; //易错点
    for(int i=2; i*i<=num; i++) {
        if(num%i==0)return false;
    }
    return true;
}

易错点

  1. 1不是质数(若将1视为质数,测试点1不通过)

Code

Code 01

#include <iostream>
using namespace std;
bool isPrime(int num) {
    if(num==1)return false;
    for(int i=2; i*i<=num; i++) {
        if(num%i==0)return false;
    }
    return true;
}
int main(int argc,char * argv[]) {
    int M,N,key;
    scanf("%d %d",&M,&N);
    while(!isPrime(M))M++; // M重置为质数
    int hash[M]= {0}; // 存放输入数字的标记数组,hash[i]==1表示i位置已存放输入数字,已被占用
    for(int i=0; i<N; i++) {
        scanf("%d", &key);
        int step=0;
        while(step<M&&hash[(key+step*step)%M]==1) step++; // 二次探测,查找空闲存放位置
        if(i!=0)printf(" ");
        if(step==M)printf("-"); // 二次探测,没有找到空余位置
        else { // 二次探测,查到空余位置
            int index = (key+step*step)%M;
            hash[index]=1;
            printf("%d", index);
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/houzm/p/12241595.html

时间: 2024-07-31 00:14:30

PAT Advanced 1078 Hashing (25) [Hash ?次?探查法]的相关文章

1078. Hashing (25)【Hash + 探测】——PAT (Advanced Level) Practise

题目信息 1078. Hashing (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(

1078. Hashing (25)-PAT甲级真题

1078. Hashing (25)The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the

PAT 1078. Hashing (25)

1078. Hashing (25) The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the

PAT (Advanced Level) 1078. Hashing (25)

二次探测法.表示第一次听说这东西... #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; const int

1078. Hashing (25)

时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to

PAT Advanced 1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be

PAT Advanced 1032 Sharing(25) [链表]

题目 To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same sufix. For example, "loading" and "being" are stored

pat1078. Hashing (25)

1078. Hashing (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash func

PAT (Advanced Level) 1093. Count PAT&#39;s (25)

预处理每个位置之前有多少个P,每个位置之后有多少个T. 对于每个A,贡献的答案是这个A之前的P个数*这个A之后T个数. #include<cstdio> #include<cstring> long long MOD=1e9+7; const int maxn=1e5+10; long long dp1[maxn],dp2[maxn]; char s[maxn]; int main() { scanf("%s",s); memset(dp1,0,sizeof d