PAT-1012 The Best Rank (25 分) 查询分数对应排名(包括并列)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:找出每个学生排名最高的科目,如果排名相同那么就A>C>M>E

思路分析:预处理一个排名查询表,输入分数即可查出排名

#include<bits/stdc++.h>
#define de(x) cout<<#x<<" "<<(x)<<endl
#define each(a,b,c) for(int a=b;a<=c;a++)
using namespace std;
const int maxn=2000+5;
const int inf=0x3f3f3f3f;

int avg[maxn];
int c[maxn];
int math[maxn];
int english[maxn];

int avg_table[105];
int c_table[105];
int math_table[105];
int english_table[105];
struct student
{
    int c;
    int m;
    int e;
    int a;
};
map<string,student>M;
int cmp(int a,int b)
{
    return a>b;
}
/*
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
*/
int main()
{
    int n,m;
    cin>>n>>m;
    string id;

    each(i,1,n)
    {
        student temp;
        cin>>id;
        cin>>temp.c;
        cin>>temp.m;
        cin>>temp.e;
        temp.a=(temp.c+temp.m+temp.e)/3;
        c[i]=temp.c;
        math[i]=temp.m;
        english[i]=temp.e;
        avg[i]=temp.a;
        M[id]=temp;
    }
    sort(avg+1,avg+n+1,cmp);
    for(int i=1;i<=n+1;i++)
    {
        int score=avg[i];
        if(avg_table[score]==0)
        {
            avg_table[score]=i;
        }
    }

    sort(math+1,math+n+1,cmp);
    for(int i=1;i<=n+1;i++)
    {
        int score=math[i];
        if(math_table[score]==0)
        {
            math_table[score]=i;
        }
    }

    sort(c+1,c+n+1,cmp);
    for(int i=1;i<=n+1;i++)
    {
        int score=c[i];
        if(c_table[score]==0)
        {
            c_table[score]=i;
        }
    }

    sort(english+1,english+n+1,cmp);
    for(int i=1;i<=n+1;i++)
    {
        int score=english[i];
        if(english_table[score]==0)
        {
            english_table[score]=i;
        }
    }

    while(m--)
    {
        string query;
        cin>>query;
        if(M.count(query)==0)
        {
            cout<<"N/A"<<endl;
            continue;
        }
        string ans1="E";
        int ans2=english_table[M[query].e];
        //de(ans2);

        if(math_table[M[query].m]<=english_table[M[query].e])
        {
            ans1="M";
            ans2=math_table[M[query].m];
        }
        if(c_table[M[query].c]<=ans2)
        {
            ans1="C";
            ans2=c_table[M[query].c];
        }
        if(avg_table[M[query].a]<=ans2)
        {
            ans1="A";
            ans2=avg_table[M[query].a];
        }
        cout<<ans2<<" "<<ans1<<endl;

    }
}

原文地址:https://www.cnblogs.com/Tony100K/p/11758024.html

时间: 2024-10-09 11:57:43

PAT-1012 The Best Rank (25 分) 查询分数对应排名(包括并列)的相关文章

[PTA] PAT(A) 1012 The Best Rank (25 分)

目录 Problem Solution Analysis Code Problem portal: 1012 The Best Rank (25 分) Solution Analysis ?一名学生有三门科目,以及计算出的一个平均成绩,每一个成绩都会有一个排名,现在想要让你输出某一个同学最高的排名(四种成绩排名的最高),以及对应的科目 ?如果给定的同学的四种课程排名的名次信息已经存在,那么就很简单,在里面找到最小的名次,以及对应的科目输出即可. ?可以创建四个数组,数组的每个元素存储某一门科目的

1012 The Best Rank (25分) vector与结构体排序

1012 The Best Rank (25分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, w

PAT 1012. The Best Rank (25)

1012. The Best Rank (25) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, w

PAT Advanced 1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by e

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by e

1012 The Best Rank (25)(25 分)

1012 The Best Rank (25)(25 分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean ti

1012. The Best Rank (25)——PAT (Advanced Level) Practise

题目信息: 1012. The Best Rank (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Math

PAT(A) 1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by e

PAT乙级1085-----PAT单位排行 (25分)

1085 PAT单位排行 (25分) 输入样例: 10 A57908 85 Au B57908 54 LanX A37487 60 au T28374 67 CMU T32486 24 hypu A66734 92 cmu B76378 71 AU A47780 45 lanx A72809 100 pku A03274 45 hypu 输出样例: 5 1 cmu 192 2 1 au 192 3 3 pku 100 1 4 hypu 81 2 4 lanx 81 2 思路:(struct sc