B - Networking——POJ

B - Networking

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u

Submit Status

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are
given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the
area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points.
The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only
one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j
i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

prime基本算法

#include<stdio.h>
#include<string.h>
int e[100][100];
int n;
int inf=99999;

void init();
int prime();

int main()
{
	int m,i,j,v,u,w;
	while(scanf("%d",&n)&&n)
	{
		scanf("%d",&m);
		init();
		for(i=1;i<=m;i++)
		{
			scanf("%d %d %d",&v,&u,&w);
			if(e[v][u]>w)
			{
				e[v][u]=w;
				e[u][v]=w;
			}
		}
		printf("%d\n",prime());
	}
	return 0;
}

int prime()
{
	int sum=0;
	int book[100]={0};
	int dis[100]={0},i,min,minx,j;
	for(i=1;i<=n;i++)
		dis[i]=e[1][i];
	book[1]=1;
	for(j=1;j<n;j++)
	{
		min=inf;
		for(i=1;i<=n;i++)
		{
			if(min>dis[i]&&book[i]==0)
			{
				min=dis[i];
				minx=i;
			}
		}
		book[minx]=1;
		sum+=min;
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&dis[i]>e[minx][i])
				dis[i]=e[minx][i];
		}
	}
	return sum;
}

void init()
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(i==j)  e[i][j]=0;
			else      e[i][j]=inf;
		}
	}
}
时间: 2024-10-11 19:42:57

B - Networking——POJ的相关文章

(最小生成树) Networking -- POJ -- 1287

链接: http://poj.org/problem?id=1287 代码: #include <cstdio> #include <cstring> #include <cmath> #include <iostream> #include <algorithm> using namespace std; const int N = 210; const int INF = 0xfffffff; int n; int J[N][N], dist

B - Networking - poj 1287

有一些地方需要铺盖电缆,这些地方两点间的路可能不止一条,需要求出来至少需要多少电缆才能让所有的点都连接起来,当然,间接连接也算. ///////////////////////////////////////////////////////////////////////// #include<iostream>#include<cstring>#include<cstdio>#include<queue>#include<vector>usin

Networking POJ - 1287 最小生成树板子题

#include<iostream> #include<algorithm> using namespace std; const int N=1e5; struct edge{ int a,b,w; }e[N]; bool cmp(edge a,edge b) { return a.w<b.w; } int p[N]; int find(int x) { if(p[x]!=x) p[x]=find(p[x]); return p[x]; } int main() { int

[kuangbin带你飞]之&#39;最小生成树 &#39;专题(未完成)

带飞网址: https://vjudge.net/article/187 专题六: POJ 1251 Jungle RoadsPOJ 1287 NetworkingPOJ 2031 Building a Space StationPOJ 2421 Constructing RoadsZOJ 1586 QS NetworkPOJ 1789 Truck HistoryPOJ 2349 Arctic NetworkPOJ 1751 HighwaysPOJ 1258 Agri-NetPOJ 3026 B

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

题目链接:ZOJ1372 POJ 1287 Networking 网络设计 Networking Time Limit: 2 Seconds      Memory Limit: 65536 KB You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible

POJ 1287 Networking (最小生成树)

Networking Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1287 Appoint description:  System Crawler  (2015-06-02) Description You are assigned to design network connections between certain poin

[2016-04-14][POJ][1287][Networking]

时间:2016-04-14 14:48:44 星期四 题目编号:[2016-04-14][POJ][1287][Networking] 题目大意:求最小生成树 分析:直接prim算法,更新边的时候,重边取最小值 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn = 50 + 10; const int inf = 0x3f3f3f3f; i

POJ 1287:Networking(最小生成树Kruskal)

Networking Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5976   Accepted: 3231 Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of po

POJ - 1287 Networking

题目链接:http://poj.org/problem?id=1287 Sample Input 1 0 2 3 1 2 37 2 1 17 1 2 68 3 7 1 2 19 2 3 11 3 1 7 1 3 5 2 3 89 3 1 91 1 2 32 5 7 1 2 5 2 3 7 2 4 8 4 5 11 3 5 10 1 5 6 4 2 12 0 Sample Output 0 17 16 26 分析:最小生成树纯模板 1 #include <cstdio> 2 #include &