csuOJ啊 1553

题目地址:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1553

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
    long long int a[10005],n,k;
    while( cin>>n>>k )
    {
        long long  int coun=1;
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        long long int sum=0;
        for(int i=0; i<n; i++)
        {
            int t=1;
            long long int max=a[i],min=a[i];
            for(int j=i+1; j<n; j++)
            {

                if(a[j]>max)
                    max=a[j];
                if(a[j]<min)
                    min=a[j];
                t=j-i+1;
                if(max-min<=k)
                {
                    coun  = coun < t ? t : coun;
                }
                else
                    break;
            }
        }
        cout<<coun<<endl;
    }
    return 0;
}
时间: 2024-12-21 18:22:31

csuOJ啊 1553的相关文章

CSU 1553 Good subsequence(RMQ问题 + 二分)

题目链接:http://acm.csu.edu.cn/csuoj/problemset/problem?pid=1553 Description Give you a sequence of n numbers, and a number k you should find the max length of Good subsequence. Good subsequence is a continuous subsequence of the given sequence and its m

CSUOJ 1010 Water Drinking

Description The Happy Desert is full of sands. There is only a kind of animal called camel living on the Happy Desert. ‘Cause they live here, they need water here. Fortunately, they find a pond which is full of water in the east corner of the desert.

CSUOJ 1217 奇数个的那个数

Description 给定些数字,这些数中只有一个数出现了奇数次,找出这个数. Input 每组数据第一行n表示数字个数,1 <= n <= 2 ^ 18 且 n % 2 == 1. 接下来n行每行一个32位有符号整数. Output 出现奇数次那个数,每组数据对应一行. Sample Input 5 1 1 2 2 3 7 1 2 1 2 2 3 3 Sample Output 3 2 看了大神的代码 使用位运算o(╯□╰)o 1 # include <stdio.h> 2 i

Aizu 2164 CSUOJ 1436 Revenge of the Round Table

dp套一个burnside的壳子核心还是dpdp[i]表示有i个循环节时的染色方案数注意在dp的时候,不需要考虑重构的问题因为burnside会解决重构的问题dpA[i][j]表示以A开头,长度为i,结尾为j个A的合法方案数dpB[i][j]表示以B开头,长度为i,结尾为j个A的合法方案数接下来我们用dpA,dpB来计算dp[i]显然对于所有的dpB[i][1~k]都是满足dp[i]的因为它表示以B开头,以A结尾的染色方案,且结尾没有超过k个另外还有一部分就是以A开头的了假设我们在整个串的最前面

互斥的数 (Codevs No.1553)

2016-05-31 21:34:15 题目链接: 互斥的数 (Codevs No.1553) 题目大意: 给N个数,如果其中两个数满足一个数是另一个的P倍,则称它俩互斥,求一个不互斥集合的最大容量 解法: 听说跟hash有一点关系,不会.... 还是二分图匹配吧 转化为求最大独立集=N-最大匹配 裸的匈牙利算法上.外加一个map大法搞搞互斥关系 1 //互斥的数 (Codevs No.1553) 2 //二分图匹配 3 #include<stdio.h> 4 #include<algo

csuoj 1511: 残缺的棋盘

http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1511 1511: 残缺的棋盘 时间限制: 1 Sec  内存限制: 128 MB 题目描述 输入 输入包含不超过10000 组数据.每组数据包含6个整数r1, c1, r2, c2, r3, c3 (1<=r1, c1, r2, c2, r3, c3<=8). 三个格子A, B, C保证各不相同. 输出 对于每组数据,输出测试点编号和最少步数. 样例输入 1 1 8 7 5 6 1 1 3 3

CSUOJ 1343

1343: Long Long Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 180  Solved: 48[Submit][Status][Web Board] Description 现在有两个单调递增序列,第一个序列有N个整数,第二个序列有M个整数,现在你可以从第一个序列中选一个数x,然后从第二个序列中选一个数y,那么有多少种情况满足x+y<=K呢? Input 输入包含多组数据.    对于每组测试数据,第一行包含两个整数N, M , K 

并查集--CSUOJ 1601 War

并查集的经典题目: CSUOJ 1601: War Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 247  Solved: 70[Submit][Status][Web Board] Description AME decided to destroy CH’s country. In CH’ country, There are N villages, which are numbered from 1 to N. We say two vill

[ACM] CSU 1553 Good subsequence(尺取法)

题目地址:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1553 给定n的数的序列,求最长连续区间满足区间内的数最大值与最小值的差<=k (尺取法) const int maxn=10010; int num[maxn]; int n,k; int MIN,MAX; int main() { while(scanf("%d%d",&n,&k)!=EOF) { for(int i=1;i<=n;i++) sc