UVA 348 Optimal Array Multiplication Sequence(最优矩阵链乘)

L - Optimal Array Multiplication Sequence

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu

Submit Status Practice UVA
348

Appoint description: 
acmparand  (2013-08-02)System Crawler  (2015-08-04)

Description

Given two arrays A and B, we can determine the array C = AB using the standard definition of matrix multiplication:

The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let‘s say that rows(A) andcolumns(A) are the number
of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A)columns(Bcolumns(A).
For example, if A is a  array, and B is a  array,
it will take  , or 3000 multiplications to compute the C array.

To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if XY, and Z are arrays, then to compute XYZ we could either compute (XYZ or X (YZ).
Suppose X is a  array, Y is a  array,
and Z is a  array. Let‘s look at the number of multiplications required to compute the product using
the two different sequences:

(XYZ

  •  multiplications to determine the product (X Y), a  array.
  • Then  multiplications to determine the final result.
  • Total multiplications: 4500.

X (YZ)

  •  multiplications to determine the product (YZ), a  array.
  • Then  multiplications to determine the final result.
  • Total multiplications: 8750.

Clearly we‘ll be able to compute (XYZ using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplications
required.

Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays
to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates
the end of the input. N will be no larger than 10.

Output

Assume the arrays are named  . Your output for each input
case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly
resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.

Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0

Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))
区间dp模型(记忆化写法和递推已均ac)
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 11
#define inf 0x3f3f3f3f
int a[maxn],b[maxn];
int dp[maxn][maxn];
int p[maxn][maxn];
int dfs(int l,int r){
    //cout<<l<<" "<<r<<endl;
     if(dp[l][r]>0)return dp[l][r];
     if(l==r)return dp[l][r]=0;
     int ans=inf;
     int temp;
     for(int i=l;i<r;i++){
       temp=dfs(l,i)+dfs(i+1,r)+a[l]*b[i]*b[r];
       if(temp<ans){
           ans=temp;
           p[l][r]=i;
       }
     }
     return  dp[l][r]=ans;
}

void solve(int n){
     for(int i=1;i<=n;i++)dp[i][i]=0;
     for(int d=1;d<n;d++){
        for(int i=1;i<=n-d;i++){
            int j=i+d;
            int ans=inf;
            for(int k=i;k<j;k++){
                int temp=dp[i][k]+dp[k+1][j]+a[i]*b[k]*b[j];
                if(temp<ans){
                    ans=temp;
                    p[i][j]=k;
                }
            }
            dp[i][j]=ans;
        }
     }
}
void print_path(int l,int r){
     if(l>r)return;
     if(l==r)printf("A%d",l);
     else{
        printf("(");
        print_path(l,p[l][r]);
        printf(" x ");
        print_path(p[l][r]+1,r);
        printf(")");
     }
}
int main()
{
    int n;
    int t=0;
    freopen("in.txt","r",stdin);
    while(~scanf("%d",&n)&&n){
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a[i],&b[i]);
        }
        //dfs(1,n);
        solve(n);
        printf("Case %d: ",++t);
        print_path(1,n);
        printf("\n");
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-13 02:18:43

UVA 348 Optimal Array Multiplication Sequence(最优矩阵链乘)的相关文章

UVa 348 - Optimal Array Multiplication Sequence

题目:矩阵连乘,求最小运算次数,输出运算优先级(用括号给出). 分析:dp,区间动态规划. 状态:设DP[ l ][ s ]为以 s 开始长度为 l 的区间的 矩阵乘积的最小值: 阶段:区间长度: 决策:DP[ l ][ s ] = min(DP[ k ][ s ] + DP[ l-k ][ s+k ] + 乘法代价){ 1<k<l }: 记录每一步运算的位置,递归输出计算方式即可. 说明:zoj1276(2011-09-19 01:38). #include <iostream>

UVAoj 348 - Optimal Array Multiplication Sequence

1 /* 2 题意:矩阵相乘的最少的步数 3 dp[i][j]=min(dp[i][j], dp[i][k]+dp[k+1][j]+num[i-1]*num[k]*num[j]); 4 表示的是第i个矩阵到第j个矩阵相乘的最少步数 5 sign[i][j]表示的是第i个矩阵到第j个矩阵相乘的最少步数是由第i个矩阵到第sign[i][j]个矩阵相乘最少步数 6 和第sign[i][j]+1个矩阵到第j个矩阵相乘最少步数的得到的最小值! 7 */ 8 #include<iostream> 9 #i

uva 3485 Optimal Array Multiplication Sequence

题目: I - Optimal Array Multiplication Sequence Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Practice UVA 348 Description Given two arrays A and B, we can determine the array C = AB using the standard definition 

UVA 348 &amp; ZOJ 1276 Optimal Array Multiplication Sequence(dp , 矩阵链相乘问题)

Optimal Array Multiplication Sequence Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Description Given two arrays A and B, we can determine the array C = AB using the standard definition of matrix multiplication: The number of

矩阵连乘积 ZOJ 1276 Optimal Array Multiplication Sequence

题目传送门 1 /* 2 题意:加上适当的括号,改变计算顺序使得总的计算次数最少 3 矩阵连乘积问题,DP解决:状态转移方程: 4 dp[i][j] = min (dp[i][k] + dp[k+1][j] + p[i-1] * p[k] * p[j]) (i<=k<j) 5 s[i][j] 记录断开的地方(即加括号的位置),回溯法输出结果 6 */ 7 #include <cstdio> 8 #include <cstring> 9 #include <stri

AYITACM2016省赛第三周I - Optimal Array Multiplication Sequence(dp)

矩阵最少乘法 题意: 给你2个矩阵A.B,我们使用标准的矩阵相乘定义C=AB如下: A阵列中栏(column)的数目一定要等于B阵列中列(row)的数目才可以做此2阵列的相乘.若我们以rows(A),columns(A)分别代表A阵列中列及栏的数目,要计算C阵列共需要的乘法的数目为:rows(A)*columns(B)*columns(A).例如:A阵列是一个10x20的矩阵,B阵列是个20x15的矩阵,那么要算出C阵列需要做10*15*20,也就是3000次乘法. 要计算超过2个以上的矩阵相乘

uva348Optimal Array Multiplication Sequence (最优矩阵链乘+路径输出)

Optimal Array Multiplication Sequence Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu Submit Status Practice UVA 348 Appoint description: Description Download as PDF Given two arrays A and B, we can determine the array C = AB using the

UVA - 348Optimal Array Multiplication Sequence(递推)

题目:Optimal Array Multiplication Sequence 题目大意:给出N个矩阵相乘,求这些矩阵相乘乘法次数最少的顺序. 解题思路:矩阵相乘不满足交换率但满足结合率.dp[i][j] 代表第1个矩阵到第j个矩阵之间的最少的乘法次数,转移状态方程:dp[i][j] = Min(dp[i][k] + dp[k + 1][j]  + A[i - 1] * A[k] *A[j]) k>= i && k <= j - 1.A0A1A2A3..Ak  |  Ak+1

POJ1651:Multiplication Puzzle(区间DP 最优矩阵链乘)

题意:除了头尾不能动,每次取出一个数字,这个数字与左右相邻数字的乘积为其价值,最后将所有价值加起来,要求最小值 和最优矩阵链乘模型一样,最后取出的数决定了序,如果没学过最优矩阵连乘找重复子问题还是比较难找的 DP //180K 0MS #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int dp[110][110];