POJ 3259 Wormholes (图论---最短路 Bellman-Ford || SPFA)

链接:http://poj.org/problem?id=3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered
the wormhole! Each of FJ‘s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be
able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can
bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: NM, and W

Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected
by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:

有一个农场,里面有一些奇怪的单向虫洞,通过虫洞的入口到出口可以让时间倒退,农场主想知道他是否能够通过农场中的路和虫洞走回出发点,并且使时间倒退,给出农场中的N块地, M条路以及W个虫洞;

分析:

由题意可以看出实际目标位寻找负值回路,所以可以使用Bellman - Ford或者SPFA判断图中是否存在负权回路即可;

代码:

(Bellman - Ford):

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 505
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

typedef struct Edge_
{
    int u, v, t;
}Edge;

Edge edge[6005];
int res[MAXN];   //存储源点到每个顶点的最短距离值;
int cas, n, m, w, s, e, t;

void READ_DATA()
{
    scanf("%d %d %d", &n, &m, &w);
    for(int i=0; i<m; i++) {
        scanf("%d %d %d", &s, &e, &t);
        edge[i].u = s, edge[i].v = e, edge[i].t = t;
        edge[i+m].u = e, edge[i+m].v = s, edge[i+m].t = t;
    }
    for(int i=0; i<w; i++) {
        scanf("%d %d %d", &s, &e, &t);
        edge[i+2*m].u = s, edge[i+2*m].v = e, edge[i+2*m].t = -t;
    }
}

bool Bellman(int n, int m, int src)   //判断是否有负环;
{
    memset(res, 0x1f, sizeof(res));  //初始化每个顶点的最短距离为无穷大;
    res[src] = 0;                 //源点的距离为0;
    for(int i=0; i<n; i++) {
        for(int j=0; j<m; j++) {
            if(res[edge[j].u] + edge[j].t < res[edge[j].v]) res[edge[j].v] = res[edge[j].u] + edge[j].t;
        }
    }
    for(int i=0; i<n; i++) {
        for(int j=0; j<m; j++) {
            if(res[edge[j].u] + edge[j].t < res[edge[j].v]) return true;
        }
    }
    return false;
}

int main()
{
    scanf("%d", &cas);
    while(cas--) {
        READ_DATA();
        if(Bellman(n, 2*m+w, 1)) puts("YES");
        else puts("NO");
    }
    return 0;
}

(SPFA):

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 505
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int res[MAXN];   //存储源点到每个顶点的最短距离值;
int map[MAXN][MAXN];
int cnt[MAXN];   //每个点入队次数;
int que[MAXN*MAXN];   //队列;
bool In_que[MAXN];    //标记一个点是否出现在队列中;
int front, rear, cas;  //队首,队尾,测试数据个数;
int n, m, w, s, e, t;

void READ_DATA()
{
    scanf("%d %d %d", &n, &m, &w);
    memset(map, 0x1f, sizeof(map));
    for(int i=0; i<m; i++) {
        scanf("%d %d %d", &s, &e, &t);
        map[s][e] = map[e][s] = map[s][e] > t ? t : map[s][e];
    }
    for(int i=0; i<w; i++) {
        scanf("%d %d %d", &s, &e, &t);
        map[s][e] = map[s][e] < -t ? map[s][e] : -t;
    }
}

bool SPFA(int n, int src)
{
    RST(cnt), RST(In_que);
    front = rear = 0;
    que[++rear] = src;
    cnt[src]++;
    memset(res, 0x1f, sizeof(res));
    res[src] = 0;
    while(front < rear) {
        int current = que[++front];
        In_que[current] = 0;
        for(int i=1; i<=n; i++) {
            if(res[current] + map[current][i] < res[i]) {
                res[i] = res[current] + map[current][i];
                if(!In_que[i]) {
                    que[++rear] = i, cnt[i]++;
                    if(cnt[i] >= n) return true;
                }
            }
        }
    }
    return false;
}

int main()
{
    scanf("%d", &cas);
    while(cas--) {
        READ_DATA();
        if(SPFA(n, 1)) puts("YES");
        else puts("NO");
    }
    return 0;
}

转载请注明出处:blog.csdn.net/keshacookie

POJ 3259 Wormholes (图论---最短路 Bellman-Ford || SPFA)

时间: 2024-11-05 13:43:33

POJ 3259 Wormholes (图论---最短路 Bellman-Ford || SPFA)的相关文章

POJ 3259 Wormholes(最短路,判断有没有负环回路)

F - Wormholes Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u SubmitStatus Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a on

POJ 3259 Wormholes【最短路/SPFA判断负环模板】

农夫约翰在探索他的许多农场,发现了一些惊人的虫洞.虫洞是很奇特的,因为它是一个单向通道,可让你进入虫洞的前达到目的地!他的N(1≤N≤500)个农场被编号为1..N,之间有M(1≤M≤2500)条路径,W(1≤W≤200)个虫洞.FJ作为一个狂热的时间旅行的爱好者,他要做到以下几点:开始在一个区域,通过一些路径和虫洞旅行,他要回到最开时出发的那个区域出发前的时间.也许他就能遇到自己了:).为了帮助FJ找出这是否是可以或不可以,他会为你提供F个农场的完整的映射到(1≤F≤5).所有的路径所花时间都

poj 3259 Wormholes 【最短路之负权环的判断】

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 54435   Accepted: 20273 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

POJ 3259 Wormholes Bellman题解

本题就是需要检查有没有负环存在于路径中,使用Bellman Ford算法可以检查是否有负环存在. 算法很简单,就是在Bellman Ford后面增加一个循环判断就可以了. 题目故事很奇怪,小心读题. #include <stdio.h> #include <string.h> #include <limits.h> const int MAX_N = 501; const int MAX_M = 2501; const int MAX_W = 201; struct E

POJ 3259 Wormholes SPFA算法题解

本题其实也可以使用SPFA算法来求解的,不过就一个关键点,就是当某个顶点入列的次数超过所有顶点的总数的时候,就可以判断是有负环出现了. SPFA原来也是可以处理负环的. 不过SPFA这种处理负环的方法自然比一般的Bellman Ford算法要慢点了. #include <stdio.h> #include <string.h> #include <limits.h> const int MAX_N = 501; const int MAX_M = 2501; const

ACM: POJ 3259 Wormholes - SPFA负环判定

POJ 3259 Wormholes Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way pa

[2016-04-03][POJ][3259][Wormholes]

时间:2016-04-03 20:22:04 星期日 题目编号:[2016-04-03][POJ][3259][Wormholes] 题目大意:某农场有n个节点,m条边(双向)和w个虫洞(单向),(走虫洞可以回到过去的时间),问能否和过去的自己相遇 分析: 题目意思就是给定一个带负权的图,问是否存在负圈, spfa_bfs spfa_dfs bellman_ford #include <vector> #include <queue> #include <algorithm&

POJ 3259 Wormholes(SPFA)

Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Eac

[ACM] POJ 3259 Wormholes (bellman-ford最短路径,判断是否存在负权回路)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 29971   Accepted: 10844 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p