hdu2899——Strange fuction

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3344    Accepted Submission(s): 2446

Problem Description

Now, here is a fuction:

F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

Author

Redow

Recommend

lcy   |   We have carefully selected several similar problems for you:  2199 2289 2298 2141 3400

对这个函数连续求几次导可以发现,对于此函数的导函数,如果y <= 0,那么函数在[0, 100]内单调递增,所以最小值是0

如果y>0,观察其导函数,发现导函数单调递增,所以我们只要找到导函数的零点(即原函数的极小值点),此时可以用二分解决

找到极值点以后,如果它在[0, 100],就把它代入函数,否则说明函数在[0, 100]内单调递减,把100代入函数即可

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
	int t;
	scanf("%d\n", &t);
	while (t--)
	{
		double y;
		scanf("%lf", &y);
		if (y <= 0)
		{
			printf("0.0000\n");
			continue;
		}
		double l = 0, r = 100, mid;
		while(r - l > 1e-6)
		{
			mid = (l + r) / 2;
			double dx = 42.0 * pow(mid, 6) + 48.0 *  pow(mid, 5) + 21.0 *  pow(mid, 2) + 10.0 * mid;
			if (abs(dx - y) < 1e-6)
			{
				break;
			}
			else if(dx - y > 1e-6)
			{
				r = mid;
			}
			else
			{
				l = mid;
			}
		}
		if (mid - 100.0 > 1e-6)
		{
			mid = 100.0;
		}
		double ans = 6 *  pow(mid, 7) + 8 *  pow(mid, 6) + 7 * pow(mid, 3) + 5 *  pow(mid, 2) - y * mid;
		printf("%.4f\n", ans);
	}
	return 0;
} 
时间: 2024-08-04 12:59:37

hdu2899——Strange fuction的相关文章

HDU2899 Strange fuction 【二分】

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2982    Accepted Submission(s): 2202 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

[hdu2899]Strange fuction

来自FallDream的博客,未经允许,请勿转载,谢谢. 题意:T组数据,每次给定y,求F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 的最小值  T<=100 这题貌似是有正常解法的,就是求导之后二分 然而我不会求导 所以呢  上模拟退火 模拟退火呢 大概是说我有一个初始温度,并且以一定的比率衰减.对于每一个状态,向外扩展状态(温度越大扩展范围越大),如果它比目前的状态更优,那么就选择它,不然,以一定的比率接受它(显然答案越劣这个

ACM : HDU 2899 Strange fuction 解题报告 -二分、三分

Strange fuction Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5933 Accepted Submission(s): 4194 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) C

HDU 2899 Strange fuction

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5253    Accepted Submission(s): 3750 Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

hdoj 2899 Strange fuction

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4795    Accepted Submission(s): 3420 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

hdoj 2899 Strange fuction【二分求解方程】

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4599    Accepted Submission(s): 3304 Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

Hdu 2899 - Strange fuction 二分/三分求函数极值点

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4527    Accepted Submission(s): 3251 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=

hdu 2899 Strange fuction (二分)

题目链接:http://acm.hdu.edu.cn/showproblem.pihp?pid=2899 题目大意:找出满足F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)的x值.注意精确度的问题. 1 #include <iostream> 2 #include <cstdio> 3 #include <cmath> 4 using namespace std; 5 double y; 6 7 doub

杭电 HDU ACM Strange fuction

Strange fuction Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4124    Accepted Submission(s): 2964 Problem Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=