hdu 1015 Safecracker DFS解法 ,简单明了

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9327    Accepted Submission(s): 4721

Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein‘s secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn‘t exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution‘
if there is no correct combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

我在这里强烈不建议用六个for循环,如果用暴力枚举,,这题完全没意义了,我就是想多学点~

看代码:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std ;

bool cmp(char a, char b)
{
	return a > b ;
}
int target ;
int cal(int v,int w,int x,int y,int z)
{
	return v-w*w+x*x*x-y*y*y*y+z*z*z*z*z ;
}

bool judge(int v,int w,int x,int y,int z)
{
	return cal(v,w,x,y,z)==target ;
}
bool visited[15] ;
char ans[15],str[15],handle[15];
bool DFS(int num)
{
	if(num == 5)
	{
		handle[5]='\0' ;
		if(judge(handle[0]-'A'+1,handle[1]-'A'+1,handle[2]-'A'+1,
			handle[3]-'A'+1,handle[4]-'A'+1))
			{
				strcpy(ans,handle) ;
				return true ;
			}
		else
		{
			return false ;
		}
	}
	else
	{
		int len = strlen(str) ;
		for(int i = 0 ; i < len ; ++i)
		{
			if(!visited[i])
			{
				handle[num] = str[i] ;
				visited[i] = true ;
				if(DFS(num+1))
				{
					return true ;
				}
				visited[i] = false ;
			}
		}
	}
	return false ;
}

int main()
{
	while(~scanf("%d%s",&target,str))
	{
		if(target == 0 && strcmp("END",str)==0)
		{
			break ;
		}
		int len = strlen(str) ;
		sort(str,str+len,cmp) ;
		memset(visited,0,sizeof(visited)) ;
		//剪枝
		if(cal(str[0]-'A'+1,str[len-1]-'A'+1,str[0]-'A'+1,
			str[len-1]-'A'+1,str[0]-'A'+1) < target)
			{
				printf("no solution\n");
				continue ;
			}
		if(DFS(0))
		{
			printf("%s\n",ans) ;
		}
		else
		{
			printf("no solution\n");
		}
	}
	return 0 ;
}
时间: 2024-11-07 13:47:13

hdu 1015 Safecracker DFS解法 ,简单明了的相关文章

HDU 1015 Safecracker(DFS)

Safecracker Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were des

hdu 1015 Safecracker (纯暴力)

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8183    Accepted Submission(s): 4143 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein

HDU 1015 Safecracker 题解

Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in Wo

hdu 1015 Safecracker 水题一枚

题目链接:HDU - 1015 === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World

HDU 1015 Safecracker【数值型DFS】

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3966    Accepted Submission(s): 2028 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein

hdu 1015(DFS)

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13237    Accepted Submission(s): 6897 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klei

HDU 1015 Safecracker

解题思路:这题相当诡异,样例没过,交了,A了,呵呵,因为理论上是可以通过的,所以 我交了一发,然后就神奇的过了.首先要看懂题目. 1 #include<cstdio> 2 #include<cstring> 3 #include<algorithm> 4 #include<cmath> 5 using namespace std; 6 const int maxn = 15; 7 int vis[maxn], A[maxn], flag, len, sum,

HDU 1015 Safecracker(第一次用了搜索去遍历超时,第二次用for循环能够了,思路一样的)

Safecracker Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 3   Accepted Submission(s) : 1 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe b

HDU 1015.Safecracker【暴力枚举】【8月17】

Safecracker Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were des