Mooncake is a Chinese bakery product traditionally eaten during the
Mid-Autumn Festival. Many types of fillings and crusts can be found in
traditional mooncakes according to the region‘s culture. Now given the
inventory amounts and the prices of all kinds of the mooncakes, together with
the maximum total demand of the market, you are supposed to tell the maximum
profit that can be made.
Note: partial inventory storage can be taken. The sample shows the
following situation: given three kinds of mooncakes with inventory amounts being
180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion
yuans. If the market demand can be at most 200 thousand tons, the best we
can do is to sell 150 thousand tons of the second kind of mooncake, and 50
thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 =
9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line
contains 2 positive integers N (<=1000), the number of different kinds of
mooncakes, and D (<=500 thousand tons), the maximum total demand of the
market. Then the second line gives the positive inventory amounts (in
thousand tons), and the third line gives the positive prices (in billion yuans)
of N kinds of mooncakes. All the numbers in a line are separated by a
space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line,
accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45
此题没有什么难度,就是一个贪心算法,或者说是一个分数背包问题,唯一需要注意的是题目中不能讲amounts的类型设为int,要设为double,不然有一个测试点过不了的,PAT就是一个坑啊。
#include <vector>
#include <algorithm>
#include <cstdio>
#include <functional>
using namespace std;const int NUM=1001;
struct Mooncake
{
double amounts;
double prices;
double rate;
Mooncake()
{
amounts=0.0;
prices=0.0;
rate=0.0;
}
};class Greater:public binary_function<Mooncake,Mooncake,bool>
{
public:
bool operator()(const Mooncake& lhs,const Mooncake& rhs) const
{
return lhs.rate>rhs.rate;
}
};vector<Mooncake> mooncakes;
int main()
{
int N,D;
double amounts,prices;
Mooncake buf;
scanf("%d%d",&N,&D);
int i=0;
for(;i<N;++i)
{
scanf("%lf",&amounts);
buf.amounts=amounts;
mooncakes.push_back(buf);
}
for(i=0;i<N;++i)
{
scanf("%lf",&prices);
mooncakes[i].prices=prices;
mooncakes[i].rate=mooncakes[i].prices/(double)mooncakes[i].amounts;
}
sort(mooncakes.begin(),mooncakes.end(),Greater());
double maxProfit=0.0;
for(i=0;i<N&&D>0;++i)
{
if(D>=mooncakes[i].amounts)
{
maxProfit+=mooncakes[i].prices;
D-=mooncakes[i].amounts;
}
else
{
maxProfit+=mooncakes[i].rate*D;
D=0;
}
}
printf("%.2f\n",maxProfit);
return 0;
}
PAT 1070. Mooncake (25),布布扣,bubuko.com