PAT 1070. Mooncake (25)

Mooncake is a Chinese bakery product traditionally eaten during the
Mid-Autumn Festival.  Many types of fillings and crusts can be found in
traditional mooncakes according to the region‘s culture.  Now given the
inventory amounts and the prices of all kinds of the mooncakes, together with
the maximum total demand of the market, you are supposed to tell the maximum
profit that can be made.

Note: partial inventory storage can be taken.  The sample shows the
following situation: given three kinds of mooncakes with inventory amounts being
180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion
yuans.  If the market demand can be at most 200 thousand tons, the best we
can do is to sell 150 thousand tons of the second kind of mooncake, and 50
thousand tons of the third kind.  Hence the total profit is 7.2 + 4.5/2 =
9.45 (billion yuans).

Input Specification:

Each input file contains one test case.  For each case, the first line
contains 2 positive integers N (<=1000), the number of different kinds of
mooncakes, and D (<=500 thousand tons), the maximum total demand of the
market.  Then the second line gives the positive inventory amounts (in
thousand tons), and the third line gives the positive prices (in billion yuans)
of N kinds of mooncakes.  All the numbers in a line are separated by a
space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line,
accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

此题没有什么难度,就是一个贪心算法,或者说是一个分数背包问题,唯一需要注意的是题目中不能讲amounts的类型设为int,要设为double,不然有一个测试点过不了的,PAT就是一个坑啊。

#include <vector>
#include <algorithm>
#include <cstdio>
#include <functional>
using namespace std;

const int NUM=1001;

struct Mooncake
{
double amounts;
double prices;
double rate;
Mooncake()
{
amounts=0.0;
prices=0.0;
rate=0.0;
}
};

class Greater:public binary_function<Mooncake,Mooncake,bool>
{
public:
bool operator()(const Mooncake& lhs,const Mooncake& rhs) const
{
return lhs.rate>rhs.rate;
}
};

vector<Mooncake> mooncakes;
int main()
{
int N,D;
double amounts,prices;
Mooncake buf;
scanf("%d%d",&N,&D);
int i=0;
for(;i<N;++i)
{
scanf("%lf",&amounts);
buf.amounts=amounts;
mooncakes.push_back(buf);
}
for(i=0;i<N;++i)
{
scanf("%lf",&prices);
mooncakes[i].prices=prices;
mooncakes[i].rate=mooncakes[i].prices/(double)mooncakes[i].amounts;
}
sort(mooncakes.begin(),mooncakes.end(),Greater());
double maxProfit=0.0;
for(i=0;i<N&&D>0;++i)
{
if(D>=mooncakes[i].amounts)
{
maxProfit+=mooncakes[i].prices;
D-=mooncakes[i].amounts;
}
else
{
maxProfit+=mooncakes[i].rate*D;
D=0;
}
}
printf("%.2f\n",maxProfit);
return 0;
}

PAT 1070. Mooncake (25),布布扣,bubuko.com

时间: 2024-12-23 03:35:10

PAT 1070. Mooncake (25)的相关文章

【PAT甲级】1070 Mooncake (25 分)(贪心水中水)

题意: 输入两个正整数N和M(存疑M是否为整数,N<=1000,M<=500)表示月饼的种数和市场对于月饼的最大需求,接着输入N个正整数表示某种月饼的库存,再输入N个正数表示某种月饼库存全部出手的利润.输出最大利润. trick: 测试点2可能包含M不为整数的数据.(尽管题面说明M是正整数,可是根据从前PAT甲级题目的经验,有可能不是整数.....) 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using names

PAT (Advanced Level) 1070. Mooncake (25)

简单贪心.先买性价比高的. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; double eps=1e-7

PAT甲题题解-1070. Mooncake (25)-排序,大水题

#include <iostream> #include <cstdio> #include <algorithm> #include <string.h> using namespace std; /* 3 0 180 150 100 7.5 7.2 4.5 */ const int maxn=1000+5; int amounts[maxn]; float price[maxn]; struct Cake{ float amounts; //注意,这里得

PAT:1070. Mooncake (25) AC

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; struct moomcake { double store; //[cation]这个可能是小数! double sumPrice; double solePrice; }M[1010]; bool cmp(moomcake a,moomcake b) { return a.solePrice>b.soleP

1070. Mooncake (25)

(库存量也是double) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes accordi

PAT 1070 Mooncake

题目意思能搞成这样我也是服了这个女人了 #include <cstdio> #include <cstdlib> #include <vector> #include <algorithm> using namespace std; int main() { int N = 0; double D = 0; scanf("%d%lf", &N, &D); vector<pair<double, double&g

pat1070. Mooncake (25)

1070. Mooncake (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes a

PAT 1070. 结绳

PAT 1070. 结绳 给定一段一段的绳子,你需要把它们串成一条绳.每次串连的时候,是把两段绳子对折,再如下图所示套接在一起.这样得到的绳子又被当成是另一段绳子,可以再次对折去跟另一段绳子串连.每次串连后,原来两段绳子的长度就会减半. 给定N段绳子的长度,你需要找出它们能串成的绳子的最大长度. 输入格式: 每个输入包含1个测试用例.每个测试用例第1行给出正整数N (2 <= N <= 104):第2行给出N个正整数,即原始绳段的长度,数字间以空格分隔.所有整数都不超过104. 输出格式: 在

PAT 1070. 结绳(25)

给定一段一段的绳子,你需要把它们串成一条绳.每次串连的时候,是把两段绳子对折,再如下图所示套接在一起.这样得到的绳子又被当成是另一段绳子,可以再次对折去跟另一段绳子串连.每次串连后,原来两段绳子的长度就会减半. 给定N段绳子的长度,你需要找出它们能串成的绳子的最大长度. 输入格式: 每个输入包含1个测试用例.每个测试用例第1行给出正整数N (2 <= N <= 104):第2行给出N个正整数,即原始绳段的长度,数字间以空格分隔.所有整数都不超过104. 输出格式: 在一行中输出能够串成的绳子的