poj——2771 Guardian of Decency
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 5916 | Accepted: 2458 |
Description
Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:
- Their height differs by more than 40 cm.
- They are of the same sex.
- Their preferred music style is different.
- Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).
So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.
Input
The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:
- an integer h giving the height in cm;
- a character ‘F‘ for female or ‘M‘ for male;
- a string describing the preferred music style;
- a string with the name of the favourite sport.
No string in the input will contain more than 100 characters, nor will any string contain any whitespace.
Output
For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.
Sample Input
2 4 35 M classicism programming 0 M baroque skiing 43 M baroque chess 30 F baroque soccer 8 27 M romance programming 194 F baroque programming 67 M baroque ping-pong 51 M classicism programming 80 M classicism Paintball 35 M baroque ping-pong 39 F romance ping-pong 110 M romance Paintball
Sample Output
3 7
Source
题目大意:
题意:现在有一个老师想带领他的学生出去郊游,但是他非常担心在郊游的过程中有些学生会发生恋爱关系,而他认为发生恋爱关系的可能性比较小的判断标准有以下四个,如果满足四个条件中的任何一个,即被他认为可能发生恋爱关系的可能性比较小:
1>两人身高的差距超过40cm;
2>两人性别相同;
3>两人所喜欢的音乐风格不同;
4>两人最喜爱的运动相同;
现在给出n个学生,并给出每个学生的信息(信息为:身高 性别 所喜欢的音乐风格 喜爱的运动),要求求解最大可以带出去郊游的学生数.
思路:
由于两个女生一定不会发生恋爱关系(此处我们不考虑性取向有问题的情况(ORZ)),所以我们可以以该同学的性别为根据来建立二分图。
然后我们在判断两边的同学是否满足上述情况,若满足则连边。然后对于我们建出的这个图在求最大匹配。这样我们就转化成了裸地匈牙利算法。最多可以带的学生数=总学生数-最大匹配数。
注意:char不能用==直接比,这样比出来的只是第一个字符,而非全部,我们这里要用strcmp比较两个字符的大小,这两个字符的字典序如果相同则返回0,如果第一个字符的字典序大返回1,反之,返回-1。
代码:
#include<cstdio> #include<cstdlib> #include<cstring> #include<iostream> #include<algorithm> #define N 510 using namespace std; char ch; bool vis[N]; int t,n,x,ans,gnum,bnum,pre[N],map[N][N]; struct nn { int h; char fm[10000]; char fs[10000]; }girl[N],boy[N]; int read() { int x=0,f=1;char ch=getchar(); while(ch<‘0‘||ch>‘9‘){if(ch==‘-‘) f=-1; ch=getchar();} while(ch<=‘9‘&&ch>=‘0‘){x=x*10+ch-‘0‘; ch=getchar();} return x*f; } void add_edge() { for(int i=1;i<=bnum;i++) for(int j=1;j<=gnum;j++) if(!strcmp(boy[i].fm,girl[j].fm)&&strcmp(boy[i].fs,girl[j].fs)&&abs(boy[i].h-girl[j].h)<=40) map[i][j]=1; } int find(int x) { for(int i=1;i<=gnum;i++) if(!vis[i]&&map[x][i]) { vis[i]=true; if(pre[i]==0||find(pre[i])) { pre[i]=x; return 1; } } return 0; } int main() { t=read(); while(t--) { ans=0;bnum=0,gnum=0; memset(boy,0,sizeof(boy)); memset(girl,0,sizeof(girl)); memset(pre,0,sizeof(pre)); memset(map,0,sizeof(map)); n=read(); for(int i=1;i<=n;i++) { x=read(); scanf("%c",&ch); if(ch==‘F‘) { girl[++gnum].h=x; cin>>girl[gnum].fm; cin>>girl[gnum].fs; } else { boy[++bnum].h=x; cin>>boy[bnum].fm; cin>>boy[bnum].fs; } } add_edge(); for(int i=1;i<=bnum;i++) { memset(vis,0,sizeof(vis)); if(find(i)) ans++; } printf("%d\n",n-ans); } return 0; }