poj 2418 Hardwood Species(二叉排序树)

Hardwood Species

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 19428 Accepted: 7658

http://poj.org/problem?id=2418

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America‘s temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters.
There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to
4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

Source

Waterloo Local 2002.01.26

/*

用二叉排序树 做的

G++ WA;

C++ AC;

数据结构(严蔚敏)P228

*/

#include<cstdio>

#include<cstring>

#include<cstdlib>

#include<algorithm>

using namespace std;

typedef char Keytype;//关键字的类型

typedef char Elemtype;//插入元素的类型

typedef struct Bitnode

{

Keytype data[50];//排序二叉树的节点信息

int count;

struct Bitnode *lchild;//左孩子指针

struct Bitnode *rchild;//右孩子指针

}Bitnode,*Bitree;

int sum;

int EQ(Keytype a[],Keytype b[])//判断 a==b?

{

if(strcmp(a,b)==0)

return 1;

else

return 0;

}

int LT(Keytype a[],Keytype b[])//判断 a<b?

{

if(strcmp(a,b)<0)

return 1;

else

return 0;

}

int SearchBST(Bitree T,Keytype key[],Bitree f,Bitree &p)

{

if(!T)//查找不成功

{

p=f;

return 0;

}

else if(EQ(key,T->data))//查找成功 

       {

T->count++;

p=T;

      return 1;

  }

else if(LT(key,T->data))

 
 return SearchBST(T->lchild,key,T,p);//在左子树中继续查找 

   else

   
 return SearchBST(T->rchild,key,T,p);//在右子树中继续查找

}

void InsertBST(Bitree &T,Elemtype e[])//插入操作

{

Bitree p;

if(!SearchBST(T,e,NULL,p))//当查找不成功时进行插入操作

{

Bitree s=(Bitree)malloc(sizeof(Bitnode));//申请动态存储空间

s->lchild=s->rchild=NULL;

s->count=1;

strcpy(s->data,e);

if(!p)

T=s;

else if(LT(e,p->data))

p->lchild=s;

else

p->rchild=s;

}

}

void Inodertraverse(Bitree T)//中序遍历排序二叉树

{

if(T)

{

Inodertraverse(T->lchild);

  printf("%s %.4lf\n",T->data,100*((T->count*1.0)/(sum*1.0)));

Inodertraverse(T->rchild);

}

}

char s[50];

void CreateBST(Bitree &T)//创建排序二叉树

{

while(gets(s)&&s[0]!=‘\0‘)

{

InsertBST(T,s);

sum++;

}

}

int main()

{

Bitree T=NULL;

CreateBST(T);

Inodertraverse(T);

return 0;

}

时间: 2024-10-26 11:53:11

poj 2418 Hardwood Species(二叉排序树)的相关文章

[字典树] poj 2418 Hardwood Species

题目链接: http://poj.org/problem?id=2418 Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17511   Accepted: 6949 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and gene

poj 2418 Hardwood Species (trie树)

poj   2418   Hardwood Species http://poj.org/problem?id=2418 trie树+dfs 题意: 给你多个单词,问每个单词出现的频率. 方法:通过字典树,将所有单词放入树中,通过dfs遍历(题目要求按ASSIC码顺序输出单词及其频率),dfs可满足 注意:单词中不一定只出现26个英文字母,ASSIC码表共有256个字符 1 #include <stdio.h> 2 #include <string.h> 3 #include &l

POJ 2418 Hardwood Species(字典树)

题目链接:POJ 2418 Hardwood Species [题意]给出一大串树的名字,可能有重复,然后按字典序输出名字和百分比. [思路]我已开始偷懒用了map来做,这道题给的时间是10s,用map的8s也还是水过了,真是神奇啊,后来还是写了一下字典树,700ms+就过了,效率提升显著啊.这里要注意的是建字典树的ChildSize是256,题目输入不只有字母,还有一些其它字符. 下面贴上代码,先是map的: 1 /* 2 ** POJ 2418 Hardwood Species 3 ** C

POJ 2418 Hardwood Species(STL中map的应用)

题目地址:POJ 2418 通过这个题查了大量资料..知道了很多以前不知道的东西.... 在代码中注释说明吧. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h> #include <queue&

POJ 2418 Hardwood Species Trie解法

计算一个字符串数组中有多少个重复字符串出现. 如果直接使用map容器,那么这条题就很简单了,一下就AC了,因为map已经处理好一切了: 不过时间超过1532ms,有点慢. 如下: int main() { map<string, int> msi; int total = 0; char treeName[40]; while (gets(treeName)) { msi[treeName]++; total++; } for (map<string, int>::iterator

POJ 2418 Hardwood Species(字典树 || map运用)

题目链接:http://poj.org/problem?id=2418 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. America's temperate climates produce forests with hundreds of hardwood

[ACM] POJ 2418 Hardwood Species (Trie树或map)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17986   Accepted: 7138 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

[ACM] POJ 2418 Hardwood Species (Trie树或者map)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17986   Accepted: 7138 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

POJ 2418 Hardwood Species(字典树)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 20085   Accepted: 7911 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri