[2012山东省第三届ACM大学生程序设计竞赛]——Mine Number

Mine Number

题目:http://acm.sdut.edu.cn/sdutoj/problem.php?

action=showproblem&problemid=2410

Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描写叙述

Every one once played the game called Mine Sweeping, here I change the rule. You are given an n*m map, every element is a ‘*‘ representing a mine, or a ‘.‘ representing any other thing. If I ask you what‘s the total number of mines around (i, j), you should
check (i, j)‘s up, down, left, right and also itself (if overstep the boundary, ignore it), if that position is a ‘*‘, you should add one to the total number of (i, j), and here I call the number Mine Number. For example, if the map is "..**.. ", we can get
the Mine Number as "012210" easily, but here is the question, if I give you the Mine Number, can you tell me the original map?

输入

The input consists of multiple test cases.

The first line contains a number T, representing the number of test cases.

Then T lines follow. For each case, the first line contains two numbers n and m (1<=n, m<=20).representing the lines and rows. Then following n lines, each line contain m numbers each number represents the Mine Number.

输出

For each case, please print the case number (beginning with 1) and the original map which you reverted. The data guarantee there is only one result.

演示样例输入

2

7 11

10010100101

21223221222

32354532323

32355532323

31235321333

21022201333

10001000111

5 6

001110

013431

014541

013431

001110

演示样例输出

Case 1:

...........

*..*.*..*.*

*.*****.*.*

*.*****.*.*

*..***..*.*

*...*...***

...........

Case 2:

......

..***.

..***.

..***.

......

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛

一道搜索题,比赛时就是研究这道题,和高恒一起。话说当时方向对了,解题思路非常正确。可是编程时候出了点问题。尤其是最后的代码输出,输出一个字符和一个空格。。

。事实上应该没有空格的。。

。o(╯□╰)o啊。。。

言归正传:

这道题题意非常easy,扫雷玩过吧?

         

上面的数字3,代表该点八个方向上有三颗雷。

这道题题意也差点儿相同,仅仅是数字所代表的是 上下左右与该点   五个方向的雷数量。

题目会给出数字,让你确定 雷的分布图。每一个数据仅仅输出一个解。

DFS,深度优先搜索。

大体的思路方向是:

从0,0開始往后推断。每一个点是否放雷。根据就是周围的数字(上下左右)是否有0的情况。有0就不放雷。

放雷后就要将五个方向的数字减1,然后继续往后推断。

这是基本的推断,可是显然须要大的前提来 剪掉大半棵树。

→首先将第一行枚举,然后每一行依据上一行状态来做:

假设上一行同位置数字为0,则该点不放雷。

假设上一行同位置数字为1。则该点必须放雷,此时推断四周是否有0的情况,没有则放雷,有则回溯。

假设上一行同位置数字不为0或者1。则回溯。

推断到最后一行,须要将最后一行数组推断,是否全为0,是则输出结果。不是则回溯。

就是这样。

#include <iostream>
#include <string.h>
using namespace std;
#define MAX 25
int n,m,num[MAX][MAX],dis[5][2]={0,0,1,0,-1,0,0,1,0,-1};
char Map[MAX][MAX];
bool ispos;
// 推断出界
bool isout(int x,int y)
{
    if( x<0 || y<0 || x>=n || y>=m )    return 1;
    return 0;
}
// 推断五个点是否有小于等于0的位置
bool location(int x,int y)
{
    int i,xx,yy;
    for(i=0;i<5;++i)
    {
        xx=x+dis[i][0];
        yy=y+dis[i][1];
        if( !isout(xx,yy) && num[xx][yy]<=0 )   return false;
    }
    return true;
}
// 假设放雷,五个点数字减1
void change(int x,int y)
{
    int i,xx,yy;
    for(i=0;i<5;++i)
    {
        xx=x+dis[i][0];
        yy=y+dis[i][1];
        if( isout(xx,yy) )  continue;
        --num[xx][yy];
    }
}
// 假设该地原来放雷,可是应该不放。回溯,五个点数字加1
void c_back(int x,int y)
{
    int i,xx,yy;
    for(i=0;i<5;++i)
    {
        xx=x+dis[i][0];
        yy=y+dis[i][1];
        if( isout(xx,yy) )  continue;
        ++num[xx][yy];
    }
}
// 推断最后一行是否符合条件
bool judge_final(void)
{
    int i;
    for(i=0;i<m;++i)
        if( num[n-1][i]!=0 )    return false;
    return true;
}
// 输出结果
void print(void)
{
    int i,j;
    for(i=0;i<n;++i)
    {
        for(j=0;j<m;++j)
            cout<<Map[i][j];
        cout<<endl;
    }
}
void dfs(int x,int y)
{
    if( ispos ) return;
    if( x==n )
    {
        if( judge_final() )
        {ispos=1;print();}
        return;
    }
    if( y==m )  {dfs(x+1,0);return;}
    if( x==0 )  // 首先第一行要进行枚举。不冲突就可以
    {
        if( location(x,y) )
        {
            Map[x][y]=‘*‘;
            change(x,y);
            dfs(x,y+1);
            c_back(x,y);
        }
        Map[x][y]=‘.‘;
        dfs(x,y+1);
    }
    else// 其余行,依据上一行对应位置来推断假设做
    {
        if( num[x-1][y]==0 )    // 上一行为0,此行不能放雷
        {
            Map[x][y]=‘.‘;
            dfs(x,y+1);
        }
        else if( num[x-1][y]==1 )   // 上一行为1,此行必须放雷,推断四周是否有0情况
            if( location(x,y) )
            {
                Map[x][y]=‘*‘;
                change(x,y);
                dfs(x,y+1);
                c_back(x,y);
            }
    }
}

int main()
{
    int i,j,test,t_num;
    char c;
    cin>>test;
    for(t_num=1;t_num<=test;++t_num)
    {
        cin>>n>>m;
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
            {
                cin>>c;
                num[i][j]=c-‘0‘;
            }
        cout<<"Case "<<t_num<<":"<<endl;
        ispos=0;
        dfs(0,0);
    }
    return 0;
}
时间: 2024-08-10 18:33:54

[2012山东省第三届ACM大学生程序设计竞赛]——Mine Number的相关文章

[2012山东省第三届ACM大学生程序设计竞赛]——Fruit Ninja II

Fruit Ninja II 题目:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2416 Time Limit: 5000ms Memory limit: 65536K 有疑问?点这里^_^ 题目描述 Have you ever played a popular game named "Fruit Ninja"? Fruit Ninja (known as Fruit Ninja

[2012山东省第三届ACM大学生程序设计竞赛]——n a^o7 !

n a^o7 ! 题目:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2413 Time Limit: 1000MS Memory limit: 65536K 题目描述 All brave and intelligent fighters, next you will step into a distinctive battleground which is full of sweet and hap

2012年&quot;浪潮杯&quot;山东省第三届ACM大学生程序设计竞赛 Fruit Ninja I

题意: 水果忍者,给你n个水果的出现时间,出现位置,和他是否是好水果,切到好水果+1,切到坏水果-1,连续切到三次以上分数加倍. 每次只能切一刀,两刀之间的间隔大于等于m 问怎样安排能使得分最大: 解法:先求出每一秒出手能得到的最大的得分,双重暴力, 再用DP求出手时间: #include <iostream> #include <cstdio> #include <cstring> #include <cmath> #include <stdio.h

Alice and Bob(2013年山东省第四届ACM大学生程序设计竞赛)

Alice and Bob Time Limit: 1000ms   Memory limit: 65536K 题目描述 Alice and Bob like playing games very much.Today, they introduce a new game. There is a polynomial like this: (a0*x^(2^0)+1) * (a1 * x^(2^1)+1)*.......*(an-1 * x^(2^(n-1))+1). Then Alice as

sdut Mountain Subsequences 2013年山东省第四届ACM大学生程序设计竞赛

Mountain Subsequences 题目描述 Coco is a beautiful ACMer girl living in a very beautiful mountain. There are many trees and flowers on the mountain, and there are many animals and birds also. Coco like the mountain so much that she now name some letter s

[2013山东省第四届ACM大学生程序设计竞赛]——Alice and Bob

Alice and Bob Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 Alice and Bob like playing games very much.Today, they introduce a new game. There is a polynomial like this: (a0*x^(2^0)+1) * (a1 * x^(2^1)+1)*.......*(an-1 * x^(2^(n-1))+1). T

angry_birds_again_and_again(2014年山东省第五届ACM大学生程序设计竞赛A题)

http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2877 题目描述 The problems called "Angry Birds" and "Angry Birds Again and Again" has been solved by many teams in the series of contest in 2011 Multi-University Tr

[2013山东省第四届ACM大学生程序设计竞赛]——Rescue The Princess

Rescue The Princess Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immedia

2014年山东省第五届ACM大学生程序设计竞赛解题报告

A  angry_birds_again_and_again http://www.sdutacm.org/sdutoj/problem.php?action=showproblem&problemid=2877 数学题,求抛物线和直线围成的面积,用积分来做. 设方程 y=ax^2+bx+c ,图中曲线经过原点,所以c=0. 对方程求导 y'=2ax+b ,  y'代表斜率,那么原点(0,0)这一点,代人y'=b,即该点的斜率,根据题意b=tan( α) 如图:在题目中x=tx这一点时,容易混,