面向对象求圆的阴影面积实例

面向对象例子  (求阴影部分面积)

(1)面向过程

$r1 = 10;

$r2 = 5;

$mj = 3.14*$r1*$r1-3.14*$r2*$r2;

echo $mj;

(2)面向对象

class Yuan

{

public $r; 半径

function __construct($bj) 构造函数

{

$this->r = $bj;

}

function mianJi() 返回圆的面积

{

return 3.14*$this->r*$this->r;

}

}

$y1 = new Yuan(10);

$y2 = new Yuan(5);

$zmj = $y1->mianJi()-$y2->mianJi();

echo $zmj;

时间: 2024-10-10 00:50:39

面向对象求圆的阴影面积实例的相关文章

hdu 3264 Open-air shopping malls(求圆相交的面积,二分)

Open-air shopping malls Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2256    Accepted Submission(s): 837 Problem Description The city of M is a famous shopping city and its open-air shopping

c++入门第一天(求圆的面积)

看了一会书,发现C++和C虽然于发上相似,但是解决问题的方式还是不一样的,毕竟面向对象和面向过程是两种不同的思维方式.下面就通过一个求圆的面积的例子,比较C和C++的不同. 需求:输入圆的半径,求解圆的面积 使用C语言来解决:1.定义两个变量半径r.面积s;  2.输入半径;  3.打印结果. 以下是源代码: #include <stdio.h> int main01() { double r, s; //定义变量圆和半径 printf("请输入圆的半径:"); scanf

JAVA求圆的面积

import java.text.DecimalFormat;import java.util.Scanner; public class TheAreaOfCircle { public static void main(String[] args) { /*问题描述 给定圆的半径r,求圆的面积. 输入格式 输入包含一个整数r,表示圆的半径. 输出格式 输出一行,包含一个实数,四舍五入保留小数点后7位,表示圆的面积. 说明:在本题中,输入是一个整数,但是输出是一个实数. 对于实数输出的问题,请

POJ 2546 &amp; ZOJ 1597 Circular Area(求两圆相交的面积 模板)

题目链接: POJ:http://poj.org/problem?id=2546 ZOJ:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=597 Description Your task is to write a program, which, given two circles, calculates the area of their intersection with the accuracy of three di

编程题:带参数的宏定义来实现,求圆的周长和面积。

#include<stdio.h> #define PI 3.14159 #define L(r) 2*PI*(r) #define S(r) PI*(r)*(r) void main() { float radius,circle,area; scanf("%f",&radius); circle=L(radius); area=S(radius); printf("radius:%f\tcircle:%f\tarea:%f\n", radiu

OJ刷题之《默认参数--求圆的面积》

题目描述 根据半径r求圆的面积,如果不指定小数位数,输出结果默认保留两位小数. 部分代码已给定如下,只需要提交缺失的代码. #include <iostream> #include <iomanip> using namespace std; const double PI=3.14159; /* 补充缺少代码 */ int main() { double r; int precision; cin>>r>>precision; showarea(r); s

(c语法百题5)求圆的周长 和 面积

知识点: 头文件#define的用法 浮点型%f的用法,控制小数. 内容: 求圆的周长 和 面积 输入说明: 一行 ,半径值 ,实型 输出说明: pi=3.1415 情况 下 的 周长 和 面积 (保留2位小数),分两行输出 输入样例: 若题目没有特别说明,则应该以多组测试数据方式读取,或者参考a001. 10.0 输出样例 : 62.83 314.15 #include <stdio.h> #define pi 3.1415 int main() { float a; scanf("

使用函数 求圆的面积

<?php /** 使用函数 求圆的面积 **/ function circle($n){ define('PI',3.14); echo PI * $n * $n; } circle(3); ?> 原文地址:https://www.cnblogs.com/xm666/p/11163286.html

hdu 5120 (求两圆相交的面积

题意:告诉你两个圆环,求圆环相交的面积. /* gyt Live up to every day */ #include<cstdio> #include<cmath> #include<iostream> #include<algorithm> #include<vector> #include<stack> #include<cstring> #include<queue> #include<set&