D - FatMouse and Cheese <HDU 1078>

D - FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1‘s.

OutputFor each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:给一个图 从(0,0) 可以垂直或水平走 每次可以走小于等于k的任意距离 但每步的值 必须大于前一步的值 在无路可走时结束(周围k范围内无比该步大的值) 求可走完的最大值

思路:用dfs跑图 在dfs中设置cnt 用来记录上一个状态的最大值 将cnt+当前图里的值记录在二维dp数组中

#include<bits/stdc++.h>
using namespace std;
int n,k,maps[101][101],dp[101][101];
int dix[4]={0,1,0,-1};//x移动数组
int diy[4]={1,0,-1,0};//y移动数组
int dfs(int x,int y)
{
    if(dp[x][y])
        return dp[x][y];//当dp数组不为0 是证明 x,y走过了
    int cnt=0;//用于记录之前值
    for(int i=0;i<4;i++)
    {
        for(int j=1;j<=k;j++)
        {
            int dx=x+dix[i]*j;
            int dy=y+diy[i]*j;
            if(dx<0||dx>=n||dy<0||dy>=n)//判断越界的条件
                break;
            if(maps[x][y]<maps[dx][dy])
                cnt=max(cnt,dfs(dx,dy));//更新cnt
        }
    }
    return  dp[x][y]=cnt+maps[x][y];
}
int main()
{
    while(1)
    {
        cin>>n>>k;
        memset(dp,0,sizeof(dp));//初始化
        if(n==-1&&k==-1)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>maps[i][j];
            }
        }
        cout<<dfs(0,0)<<endl;
    }
     return 0;
}

原文地址:https://www.cnblogs.com/xuxua/p/9278146.html

时间: 2024-12-21 11:16:53

D - FatMouse and Cheese <HDU 1078>的相关文章

P - FatMouse and Cheese HDU 1078 ( 记忆化搜索 )

P - FatMouse and Cheese Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1078 Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid

FatMouse and Cheese HDU - 1078 dp

#include<cstdio> #include<iostream> #include<cstring> using namespace std; int n,k; int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}}; int dp[101][101],mp[101][101]; bool check(int x,int y) { if(x<1||x>n||y<1||y>n) return false; else

[2016-03-28][HDU][1078][FatMouse and Cheese]

时间:2016-03-28 17:40:34 星期一 题目编号:[2016-03-28][HDU][1078][FatMouse and Cheese] #include <algorithm> #include <cstring> #include <cstdio> using namespace std; const int maxn = 100 + 10; int a[maxn][maxn]; int dp[maxn][maxn]; int n ,k; int d

(记忆化搜索) FatMouse and Cheese(hdu 1078)

题目大意: 给n*n地图,老鼠初始位置在(0,0),它每次行走要么横着走要么竖着走,每次最多可以走出k个单位长度,且落脚点的权值必须比上一个落脚点的权值大,求最终可以获得的最大权值 (题目很容易会理解错题意,道友小心) #include <iostream> #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> using namespace std;

HDU 1078 FatMouse and Cheese(记忆化搜索)

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8610    Accepted Submission(s): 3611 Problem Description FatMouse has stored some cheese in a city. The city can be considere

HDU 1078 FatMouse and Cheese(DP)

题意  老鼠在一个小镇吃奶酪  城镇可以看成一个n*n的矩阵  其中每个格子都有一定数量的奶酪mat[i][j]   老鼠从(0,0) 开始吃   而且下个吃的格子里的奶酪必须比上个格子多   老鼠只能水平方向或者垂直方向走  而且每次走的距离不能超过k  求老鼠最多能吃多少奶酪 起点是固定的   比较容易   直接记忆化搜索 令d[i][j]表示以(i,j)为终点的最优解  那么对于所有(i,j)能到达的点(x,y)有  d[i][j]=max(d[i][j],d[x][y]+mat[x][y

HDU 1078 FatMouse and Cheese(记忆化)

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 a

HDU 1078 FatMouse and Cheese ( DP, DFS)

HDU 1078 FatMouse and Cheese ( DP, DFS) 题目大意 给定一个 n * n 的矩阵, 矩阵的每个格子里都有一个值. 每次水平或垂直可以走 [1, k] 步, 从 (0, 0) 点开始, 下一步的值必须比现在的值大. 问所能得到的最大值. 解题思路 一般的题目只允许 向下 或者 向右 走, 而这个题允许走四个方向, 所以状态转移方程为 dp(x, y) = dp(nextX, nextY) + arr(x, y); dp 代表在 x, y 的最大值. 由于 下一

hdu 1078 FatMouse and Cheese (dfs+记忆化搜索)

pid=1078">FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4811    Accepted Submission(s): 1945 Problem Description FatMouse has stored some cheese in a city. The city can