PAT Advanced Level 1053 Path of Equal Weight

1053 Path of Equal Weight (30)(30 分)

Given a non-empty tree with root R, and with weight W~i~ assigned to each tree node T~i~. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let‘s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

\ Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 2^30^, the given weight number. The next line contains N positive numbers where W~i~ (&lt1000) corresponds to the tree node T~i~. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A~1~, A~2~, ..., A~n~} is said to be greater than sequence {B~1~, B~2~, ..., B~m~} if there exists 1 <= k < min{n, m} such that A~i~ = B~i~ for i=1, ... k, and A~k+1~ > B~k+1~.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
/**********************
author: yomi
date: 18.8.16
ps: 本来简单dfs就可以了, 但是要求路径序列要按照非递增顺序输出 这个我想了好一会儿
甚至想到暂存到string数组里 然后sort 结果这是不现实的 除非再搞个哈希 麻烦
再看看题 其实就是每次往下搜索时先选权值最大的 所以 我把每一个父结点下的孩子们都按照
从大到小排了个序。成功解决。
**********************/
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

struct Node
{
    int data;
    int id;
    vector<Node>child;
}node[150];
bool vis[150];
long long int sum = 0, weight;
vector<int>path;
int cnt = 0;
int cmp(Node a, Node b)
{
    return a.data>b.data;
}
void dfs(int index)
{
    if(node[index].child.size() == 0){
        if(sum == weight){
            for(int i=0; i<path.size()-1; i++){
                cout << path[i] << ‘ ‘;
            }
            cout << path[path.size()-1] << endl;
        }
        return;
    }
    for(int i=0; i<node[index].child.size(); i++){
        int id = node[index].child[i].id;
        if(!vis[id]){
            sum += node[id].data;
            path.push_back(node[id].data);
            dfs(id);
            sum -= node[id].data;
            path.pop_back();
        }

    }
}
int main()
{
    int m, n, t, num, d;
    cin >> m >> n >> weight;
    for(int i=0; i<m; i++){
        cin >> node[i].data;
        node[i].id = i;
    }
    for(int i=0; i<n; i++){
        cin >> t >> num;
        for(int j=0; j<num; j++){
            cin >> d;
            node[t].child.push_back(node[d]);
        }
        sort(node[t].child.begin(), node[t].child.end(), cmp);
    }
    sum += node[0].data;
    path.push_back(node[0].data);
    vis[0] = true;
    dfs(0);

    return 0;
}
/**
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
**/

原文地址:https://www.cnblogs.com/AbsolutelyPerfect/p/9488757.html

时间: 2024-07-29 00:39:04

PAT Advanced Level 1053 Path of Equal Weight的相关文章

PAT (Advanced Level) 1053. Path of Equal Weight (30)

简单DFS #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<string> #include<algorithm> using namespace std; const int maxn=100+10;

PAT 1053. Path of Equal Weight (30)

1053. Path of Equal Weight (30) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to Lis defined to be the sum of the

Pat(Advanced Level)Practice--1060(Are They Equal)

Pat1060代码 题目描述: If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two flo

1053. Path of Equal Weight (30)

dfs函数携带vector形参记录搜索路径 时间限制 10 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of

PAT Advanced 1053 Path of Equal Weight (30) [树的遍历]

题目 Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L. Now given any weighted tree,

PAT 1053 Path of Equal Weight

#include <cstdio> #include <cstdlib> #include <vector> #include <algorithm> using namespace std; vector<vector<int>* > paths; class Node { public: vector<int> child; int weight; Node(int w = 0) : weight(w){} }; in

PAT:1053. Path of Equal Weight (30) AC

#include<stdio.h> #include<vector> #include<queue> #include<algorithm> using namespace std; const int MAX=1010; int n,m; //n个节点,m个非叶子节点 long long int S; //待测权值 long long int weight[MAX]; //每个节点的权值 vector<int> child[MAX]; //存储

PAT甲题题解-1053. Path of Equal Weight (30)-dfs

由于最后输出的路径排序是降序输出,相当于dfs的时候应该先遍历w最大的子节点. 链式前向星的遍历是从最后add的子节点开始,最后添加的应该是w最大的子节点, 因此建树的时候先对child按w从小到大排序,然后再add建边. 水题一个,不多说了. #include <iostream> #include <algorithm> #include <cstdio> #include <string.h> using namespace std; const in

1053 Path of Equal Weight (30分)(并查集)

Given a non-empty tree with root R, and with weight W?i?? assigned to each tree node T?i??. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L. Now given any weighted tre