POJ 1088 滑雪 (动规)

滑雪

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 75664 Accepted: 28044

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source

SHTSC 2002

代码:32MS

#include <iostream>
using namespace std;
#define M 110
int map[M][M],len[M][M];
int dis[4][2]={-1,0,0,1,1,0,0,-1};
int r,c;
int dp(int i,int j)
{
	if(len[i][j]!=0) return len[i][j];  //如果它的值已经被改变,那就是有个更高的在旁边。
	int maxx=0,s;                       //而且已经找到还能下降的次数。
	for(int t=0;t<4;t++)
	{
		int temx=i+dis[t][0],temy=j+dis[t][1];
		if(temx>=0&&temx<r&&temy>=0&&temy<c&&map[temx][temy]<map[i][j])
		{
			s=dp(temx,temy);   //我认为这是深搜的思路。dp思路只有一点。
			if(s>maxx)maxx=s;
		}
	}
	len[i][j]=maxx+1;
	return maxx+1;
}
int main(int i,int j)
{
	while(scanf("%d%d",&r,&c)!=EOF)
	{
		int mx=-1;
		for(i=0;i<r;i++)
			for(j=0;j<c;j++)
				scanf("%d",&map[i][j]);
			memset(len,0,sizeof(len));
			for(i=0;i<r;i++)
				for(j=0;j<c;j++)
				{
					len[i][j]=dp(i,j);
					if(len[i][j]>mx) mx=len[i][j];
				}
				 printf("%d\n",mx);
	}
	return 0;
}

POJ 1088 滑雪 (动规)

时间: 2024-10-23 13:41:11

POJ 1088 滑雪 (动规)的相关文章

POJ 2955 Brackets (动规)

Brackets Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 2999   Accepted: 1536 Description We give the following inductive definition of a "regular brackets" sequence: the empty sequence is a regular brackets sequence, if s is a reg

POJ 1088 滑雪 记忆化优化题解

本题有人写是DP,不过和DP还是有点差别的,应该主要是记忆化 Momoization 算法. 思路就是递归,然后在递归的过程把计算的结果记录起来,以便后面使用. 很经典的搜索题目,这种方法很多题目考到的. 关键还是如何把代码写清晰工整了,O(∩_∩)O~. #include <stdio.h> const int MAX_N = 101; int R, C; int arr[MAX_N][MAX_N]; int tbl[MAX_N][MAX_N]; inline int max(int a,

poj 1088 滑雪

http://poj.org/problem?id=1088 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 using namespace std; 5 6 int g[200][200]; 7 int dp[200][200]; 8 int r,c; 9 int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}}; 10 int max1=-1; 11 12

[ACM] poj 1088 滑雪 (记忆化搜索DFS)

求n*m网格内矩形的数目[ACM] poj 1088 滑雪 (记忆化搜索DFS),布布扣,bubuko.com

poj 1088 滑雪 【记忆化搜索】+【DFS】

策略:如题 题目链接:http://poj.org/problem?id=1088 代码: #include<stdio.h> #include<string.h> int map[105][105], dp[105][105], n, m; const int dir[4][2] = {0, 1, 1, 0, 0, -1, -1, 0}; //四个方向 int limit(int x, int y) //判断是不是越界了 { if(x<1||x>n||y<1||

POJ 1088 滑雪(记忆化搜索)

滑雪 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 92384   Accepted: 34948 Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17

poj(1088)——滑雪(经典递推型动归)

题意: 中文题,就是在所有的点中找一个点作为起点,然后叫你找出从起点开始的最长路径是多少. 这里高度必须严格递减. 思路: 一开始我碰到这题时,没有思路,是看题解写的. 但是今天我回头再去看时,发现自己能够独立写出来了,而且和上次的方法不一样.也许这就是进步吧! 其实就是一个递推型动归,如果理解了上一题,那么这题也好做了. 这是第一次写的: #include<stdio.h> #include<string.h> #include<iostream> #include&

poj 1088 滑雪(区间dp+记忆化搜索)

题目链接:http://poj.org/problem?id=1088 思路分析: 1>状态定义:状态dp[i][j]表示在位置map[i][j]可以滑雪的最长区域长度: 2>状态转移方程:由于由位置[i, j]只能向四个方向移动,所以子问题最多有四个:所以dp[i][j]为其邻域可以滑雪的最大区域长度加上从该位置滑到邻域的长度,即1: 代码如下: #include <cstdio> #include <iostream> #include <algorithm&

POJ 1088 滑雪 (深搜)

题目链接:http://poj.org/problem?id=1088 题面: 滑雪 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 83760   Accepted: 31349 Description Michael喜欢滑雪这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出