poj 3264 Balanced Lineup(简单线段树 或 rmq)


Language:
Default

Balanced Lineup

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 36833   Accepted: 17252
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest
cow in the group.

Input

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

求区间最大减最小

线段树代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

using namespace std;

#define N 50005

int n,m,a[N];

struct stud{
 int le,ri;
 int mi,ma;
}f[N*4];

void build(int pos,int le,int ri)
{
	f[pos].le=le;
	f[pos].ri=ri;
	if(le==ri)
	{
		f[pos].mi=f[pos].ma=a[le];
		return ;
	}

	int mid=MID(le,ri);

	build(L(pos),le,mid);
	build(R(pos),mid+1,ri);

	f[pos].ma=max(f[L(pos)].ma,f[R(pos)].ma);
	f[pos].mi=min(f[L(pos)].mi,f[R(pos)].mi);
}

int querymin(int pos,int le,int ri)
{
     if(f[pos].le>=le&&f[pos].ri<=ri)
			return f[pos].mi;

	 int mid=MID(f[pos].le,f[pos].ri);

	 if(mid>=ri)
		return querymin(L(pos),le,ri);

	 if(mid<le)
		return querymin(R(pos),le,ri);

	 return min(querymin(L(pos),le,mid),querymin(R(pos),mid+1,ri));
}

int querymax(int pos,int le,int ri)
{
     if(f[pos].le>=le&&f[pos].ri<=ri)
			return f[pos].ma;

	 int mid=MID(f[pos].le,f[pos].ri);

	 if(mid>=ri)
		return querymax(L(pos),le,ri);

	 if(mid<le)
		return querymax(R(pos),le,ri);

	 return max(querymax(L(pos),le,mid),querymax(R(pos),mid+1,ri));
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE

	int i,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);

		build(1,1,n);
        int le,ri;

		while(m--)
		{
			scanf("%d%d",&le,&ri);
			printf("%d\n",querymax(1,le,ri)-querymin(1,le,ri));
		}
	}
	return 0;
}

RMQ 代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

using namespace std;

#define N  50005

int dpmin[N][20];
int dpmax[N][20];
int n,m,a[N];

void inint()
{
	int i,j;
	for(i=1;i<=n;i++)
		dpmin[i][0]=dpmax[i][0]=a[i];

	for(j=1;(1<<j)<=n+1;j++)
		for(i=1;i+(1<<j)-1<=n;i++)
	{
		  dpmin[i][j]=min(dpmin[i][j-1],dpmin[i+(1<<(j-1))][j-1]);
		  dpmax[i][j]=max(dpmax[i][j-1],dpmax[i+(1<<(j-1))][j-1]);
	}
}

inline int getmax(int le,int ri)
{
	int k=(int)(log(ri-le+1+0.0)/log(2.0));
	return max(dpmax[le][k],dpmax[ri-(1<<k)+1][k]);
}

inline int getmin(int le,int ri)
{
	int k=(int)(log(ri-le+1+0.0)/log(2.0));
	return min(dpmin[le][k],dpmin[ri-(1<<k)+1][k]);
}

int main()
{

//	#ifndef ONLINE_JUDGE
//	  freopen("in.txt","r",stdin);
//	#endif // ONLINE_JUDGE

    int i,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);

		inint();

		int le,ri;
		while(m--)
		{
			scanf("%d%d",&le,&ri);
			printf("%d\n",getmax(le,ri)-getmin(le,ri));
		}

	}
	return 0;
}
时间: 2024-08-29 04:32:08

poj 3264 Balanced Lineup(简单线段树 或 rmq)的相关文章

POJ - 3264 - Balanced Lineup (线段树)

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 39060   Accepted: 18299 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3264 Balanced Lineup (线段树||RMQ)

A - Balanced Lineup Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3264 Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always li

POJ 3264 Balanced Lineup【线段树区间查询求最大值和最小值】

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 53703   Accepted: 25237 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3264 Balanced Lineup 【线段树】

<题目链接> 题目大意: 求给定区间内最大值与最小值之差. 解题分析: 线段树水题,每个节点维护两个值,分别代表该区间的最大和最小值即可. #include <cstdio> #include <cstring> #include <algorithm> using namespace std; #define Lson rt<<1,l,mid #define Rson rt<<1|1,mid+1,r #define INF 0x3f

poj 3246 Balanced Lineup(线段树)

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 38942   Accepted: 18247 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3278 Balanced Lineup【线段树】

题意:给出n个数,a1,a2,a3,---,an,再给出q次询问区间al到ar之间的最大值和最小值的差 学习线段树的第一道题目 学习的这一篇 http://www.cnblogs.com/kuangbin/archive/2011/08/14/2137862.html 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include <cmath> 5 #include<sta

poj 3264 Balanced Lineup(线段数求区间最大最小值)

链接:http://poj.org/problem?id=3264 Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 32772   Accepted: 15421 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order.

poj 3264 Balanced Lineup

题目链接:http://poj.org/problem?id=3264 题目大意:就是给你一串数,问你最大数和最小数的差值....... 思路:最基本的线段树,只需要建树和查询,修改都省啦,但是查询要写两个,一个查询最大值,一个查询最小值......然后就能AC掉.....但是话说poj把它分类到RMQ中.... code: #include<cstdio> #include<cmath> #include<algorithm> #include<iostream

POJ 3264 Balanced Lineup ST表

链接:http://poj.org/problem?id=3264 题意:给一串数字,多次询问,求区间最大值和区间最小值的差. 思路:RMQ问题,可以用O(N^2)的预处理,然后每次O(1)的查询,可以用线段树,O(N)的建树,O(logN)的查询,可以用ST表记录,O(NlogN)的预处理,O(1)的查询. 实际上ST表的预处理过程也是一个DP的过程dp[i][j]表示从第i位开始连续2^j位的区间最值. 预处理:dp[i][j]=min(dp[i][j],dp[i+2^j][j]),查询:q

[POJ] 3264 Balanced Lineup [ST算法]

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 34306   Accepted: 16137 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh