hdu1232&& hdu1213(简单并查集)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1232

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35673    Accepted Submission(s): 18897

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。

注意:两个城市之间可以有多条道路相通,也就是说

3 3

1 2

1 2

2 1

这种输入也是合法的

当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output

1
0
2
998

前两天听学长简单的讲了一下并查集,于是找了两个最简单的并查集水题做了一下,依次就ac了,方法效率不高,等过些天深入学习时再修改吧。

【代码如下】

#include <cstdio>
#include <algorithm>
using namespace std;
    int f[1010],n;
void connect(int i,int j)  //连接
{
    if(f[i]==f[j]) //如果已经连接, 直接返回
        return ;
    int p=f[i];
    int q=f[j];
    for(int i=1;i<=n;i++)//将所有和 f[i]相同的元素置为 和f[j]相同,从而实现了联通
    {
        if(f[i]==p)
            f[i]=q;
    }
}
int main()
{
    int m;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int st;
        scanf("%d",&m);
        for(int i=1;i<=n;i++)
        {
            f[i]=i;           //初始化,使得初始状态,每一个占一个集合,都不联通
        }
        for(int i=0;i<m;i++)
        {
            int p,q;
            scanf("%d%d",&p,&q);
            connect(p,q);
        }
        st=0;
        for(int i=1;i<=n;i++)  //查找有多少不同集合就行了,修路的话再-1;
        {
            if(f[i]==i)
                st++;
        }
        printf("%d\n",st-1);
    }
    return 0;
}

hdu 1231 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17271    Accepted Submission(s): 8456

Problem Description

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

和上一个题目一样,只不过不用减一了,

【代码如下】

#include <iostream>
#include <algorithm>
using namespace std;
int n,k,f[1010];
void connect(int a,int b)
{
    if(f[a]==f[b])
        return ;
    int p=f[a];
    int q=f[b];
    for(int i=1;i<=n;i++)
        if(f[i]==q)
            f[i]=p;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        for(int i=1;i<=n;i++)
            f[i]=i;
        for(int i=0;i<k;i++)
        {
            int a,b;
            cin>>a>>b;
            connect(a,b);
        }
     //   sort(f+1,f+n+1);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(f[i]==i)
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}
时间: 2024-08-29 07:27:55

hdu1232&& hdu1213(简单并查集)的相关文章

POJ 2492 (简单并查集) A Bug&#39;s Life

题意:有编号为1~n的虫子,开始假设这种昆虫是异性恋.然后已知xi 和 yi进行交配,根据已知情况分析能否推理出其中是否有同性恋 这道题和 POJ 1182 食物链 十分相似,不过在更新与父节点关系的时候要简单一些 sex数组保存的是与父节点的性别关系,如果与父节点是同性,则为0,否则是1 每次路径压缩的同时要更新sex[a] = (sex[a] + sex[temp]) % 2; 还有就是如果x 和 y 不在一个集合,两棵树进行合并的时候,考虑x px y py 四者之间的关系,有 paren

【简单并查集】Farm Irrigation

Farm Irrigation Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 6   Accepted Submission(s) : 3 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Benny has a spacious fa

HDU1232 畅通工程 并查集

这道题跟HDU 1213 How Many Tables 并查集非常接近,都是赤裸裸的并查集的题. 思路:假设还需要建n-1条路,每并一次就自减1. 参考代码: #include<stdio.h> int fa[1000]; int find(int u) { return fa[u]==u?u:fa[u]=find(fa[u]); } int main() { int i,n,m,u,v,x,y; scanf("%d%d",&n,&m); while (n

poj1611 简单并查集

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 32781   Accepted: 15902 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 2524 Ubiquitous Religions (简单并查集,三种方式)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 30791   Accepted: 14928 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

HDU 1272 简单并查集

小希的迷宫 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24915    Accepted Submission(s): 7641 Problem Description 上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走.但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双

poj2524(简单并查集)

#include <iostream>#include <stdio.h>#include <string.h>#include <stdlib.h>using namespace std;int n,m;int bin[50001];int findx(int x){    int r=x;    while(r!=bin[r])        r=bin[r];    int j=x,k;    while(j!=r)    {        k=bin

POJ - 2236 Wireless Network(简单并查集)

Wireless Network Time Limit: 10000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap co

POJ - 2524 Ubiquitous Religions(简单并查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description 当今世界有很多不同的宗教,很难通晓他们.你有兴趣找出在你的大学里有多少种不同的宗教信仰. 你知道在你的大学里有n个学生(0 < n <= 50000) .你无法询问每个学生的宗教信仰.此外,许多学生不想说出他们的信仰.避免这些问题的一个方法是问

ACM_“打老虎”的背后(简单并查集)

"打老虎"的背后 Time Limit: 2000/1000ms (Java/Others) Problem Description: "习大大"自担任国家主席以来大力反腐倡廉,各地打击贪腐力度也逐步加强.中国的这种令外国人不解的"风情"到底是何缘由呢?其实中国人都知道,所有的腐败问题基本上都源自官场上的"潜规则",那"潜规则"又是源自什么呢?在中国盛行一句古语,"无关系不成方圆",说的