HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;

‘S’: the start point of the doggie;

‘D’: the Door; or

‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

….

3 4 5

S.X.

..X.

…D

0 0 0

Sample Output

NO

YES

题意:

老鼠需要跑出迷宫,在每个位置停留1s,入口是S(老鼠一开始在这里),需要在T时刻正好跑到D位置(出口)。求老鼠能不能成功逃脱。

一开始我没有用剪枝,果断超时。

还有,好久没用c语言A题了,char输入时~回车绞了我半小时的思维。。

奇偶性剪枝有关内容大家可以百度搜下,我就不写了,我是自己推出来的,和有些版本不一样。

#include <stdio.h>
#include <string.h>
char map[10][10];
int df[10][10];
int sx,sy,dx,dy;
int ans,flag,t,x,y;
void dfs(int xd,int yd,int c){
    //printf("%d %d %d %d\n",xd,yd,c,flag);
    if(xd<0||yd<0){
        return;
    }
    int b=t-c;
    if((xd%2==0&&yd%2!=0)||(xd%2!=0&&yd%2==0)){
        if(b%2!=0){
            if(!((dx%2==0&&dy%2==0)||(dx%2!=0&&dy%2!=0))){
                return;
            }
        }else{
            if(!((dx%2!=0&&dy%2==0)||(dx%2==0&&dy%2!=0))){
                return;
            }
        }
    }else{
        if(b%2==0){
            if(!((dx%2==0&&dy%2==0)||(dx%2!=0&&dy%2!=0))){
                return;
            }
        }else{
            if(!((dx%2!=0&&dy%2==0)||(dx%2==0&&dy%2!=0))){
                return;
            }
        }
    }
    if(map[xd][yd]==‘X‘||df[xd][yd]||flag){
        return;
    }
    if(c>t){
        return;
    }

    if(c==t&&dx==xd&&dy==yd){
        flag=1;
        return;
    }

    df[xd][yd]=1;
    dfs(xd-1,yd,c+1);
    dfs(xd,yd-1,c+1);
    dfs(xd+1,yd,c+1);
    dfs(xd,yd+1,c+1);
    df[xd][yd]=0;
}

int main(){
    while(scanf("%d%d%d",&x,&y,&t),x||y||t){
        memset(df,0,sizeof(df));
        int i,j;
        ans=0;
        flag=0;
        for(i=0;i<10;i++){
            for(j=0;j<10;j++){
                map[i][j]=‘X‘;
            }
        }
        getchar();
        for(i=0;i<x;i++){
            for(j=0;j<y;j++){
                scanf("%c",&map[i][j]);
                if(map[i][j]==‘S‘){
                    sx=i;sy=j;
                }else if(map[i][j]==‘D‘){
                    dx=i;dy=j;ans++;
                }else if(map[i][j]==‘.‘){
                    ans++;
                }
            }
            getchar();
        }
       // printf("%d %d\n",ans,t);
        if(ans<t){
            printf("NO\n");
            continue;
        }
        dfs(sx,sy,0);
        if(flag){
            printf("YES\n");
        }else{
            printf("NO\n");
        }
       // printf("%d",flag);
    }
    return 0;
}
时间: 2025-01-22 01:08:56

HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)的相关文章

HDU 1010 Tempter of the Bone(DFS+奇偶性剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 70665    Accepted Submission(s): 19487 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU - 1010 Tempter of the Bone 深搜模板题(DPS)解题报告

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 88587    Accepted Submission(s): 24116 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU 1010 Tempter of the Bone(深搜)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 86037    Accepted Submission(s): 23462 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

hdu 1010 Tempter of the Bone 深搜+剪枝

题意:在一个坐标内,给定起点和终点,问能否恰好在t时刻到达终点. 以前很少写搜索题,所以看到这个题,就按照普通的深搜写了一下,交上去超时了.后来在网上搜了一下才知道,要剪枝才行.可是,我以前从没写过剪枝,不知道怎么剪,就按照别人的思路往下想.看懂以后,我对剪枝的理解是:对于一些没有必要继续搜索的路径,不再往下深搜,提前返回到上一层.花了半天时间调试代码,终于AC了. 奇偶剪枝:根据题目,doggie必须在第t秒到达门口.也就是需要走t-1步.设doggie开始的位置为(sx,sy),目标位置为(

HDOJ/HDU 1242 Rescue(经典BFS深搜)

Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want to save Angel. Their task is: approa

【深搜加剪枝五】HDU 1010 Tempter of the Bone

Tempter of the BoneTime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 64326    Accepted Submission(s): 17567 Problem Description The doggie found a bone in an ancient maze, which fascinated him a l

HDU 1016 素数环(深搜)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25134 Accepted Submission(s): 11222 Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1,

HDU 2553 N皇后问题(深搜DFS)

N皇后问题 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1757    Accepted Submission(s): 772   Problem Description 在N*N的方格棋盘放置了N个皇后,使得它们不相互攻击(即任意2个皇后不允许处在同一排,同一列,也不允许处在与棋盘边框成45角的斜线上.你的任务是,对于给定的N,求出

HDU 2102 A计划 (深搜)

Problem Description 可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验.魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老.年迈的国王正是心急如焚,告招天下勇士来拯救公主.不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出. 现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示.骑士们一进入时空传输机就会被转到另一层的相对位