hdu 5323 Solve this interesting problem dfs 搜索

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5323

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1470    Accepted Submission(s): 420

Problem Description

Have you learned something about segment tree? If not, don’t worry, I will explain it for you.

Segment Tree is a kind of binary tree, it can be defined as this:

- For each node u in Segment Tree, u has two values: Lu and Ru.

- If Lu=Ru,
u is a leaf node.

- If Lu≠Ru,
u has two children x and y,with Lx=Lu,Rx=?Lu+Ru2?,Ly=?Lu+Ru2?+1,Ry=Ru.

Here is an example of segment tree to do range query of sum.

Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node‘s value Lroot=0 and Rroot=ncontains
a node u with Lu=L and Ru=R.

Input

The input consists of several test cases.

Each test case contains two integers L and R, as described above.

0≤L≤R≤109

LR?L+1≤2015

Output

For each test, output one line contains one integer. If there is no such n, just output -1.

Sample Input

6 7
10 13
10 11

Sample Output

7
-1
12

题意:告诉你一个线段树有 一个区间 l到r,如果有这个种线段树  问根节点  0-n,  n最小是多少。如果没有输出-1

做法:搜索剪枝,主要那个剪枝右边界比较难想 比较重要。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define inf 100000000000
typedef long long ll;
ll ans;

void dfs(ll l,ll r)
{
	if(l<0) return ;//越界
	if(l==0) {ans=min(ans,r); return;}//符合要求 取最小值
	if(l<(r-l+1)) return ;
	//l 这个区间 右边空余的长度,   r-l+1  是这个区间的长度
	//要对称,所以左边空白区间  必须是 这个区间的 某一倍数,可以相等,但是必须要大于等于 当前这个区间。
	//用于限制r的增长
	ll len=r-l+1;
	dfs(l-len,r);
	dfs(l-len-1,r);

	dfs(l,r+len);
	if(l!=r)
	dfs(l,r+len-1);
}
int main()
{
    ll l,r;
    while(scanf("%I64d%I64d",&l,&r)!=EOF){
		ans=inf;
		dfs(l,r);
		if(ans==inf)
			puts("-1");
		else
		printf("%I64d\n",ans);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-06 20:28:47

hdu 5323 Solve this interesting problem dfs 搜索的相关文章

hdu 5323 Solve this interesting problem(dfs)

题目链接:hdu 5323 Solve this interesting problem 逆向思维,每次向左或向右翻倍,知道左端点为0时,即恰好满足的情况,处理处所有情况去取最小值. #include <cstdio> #include <cstring> #include <algorithm> using namespace std; typedef long long ll; const ll inf = 0x3f3f3f3f; ll L, R, N; void

HDU 5323 Solve this interesting problem

搜索... Solve this interesting problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 422    Accepted Submission(s): 98 Problem Description Have you learned something about segment tree? If not,

HDOJ 5323 Solve this interesting problem BFS搜索

BFS暴力搜索..... Solve this interesting problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 974    Accepted Submission(s): 263 Problem Description Have you learned something about segment tree?

HDU 5323 SOLVE THIS INTERESTING PROBLEM 爆搜

链接 Solve this interesting problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 511    Accepted Submission(s): 114 Problem Description Have you learned something about segment tree? If not, d

【搜索】 HDU 5323 Solve this interesting problem

点击打开链接 用线段树方式建树 [ 0, n] 已知[ l, r] 结点 求n 若 建一个[0, 2*r] 的线段树  这是的总点数的奇的,(左子树!=右子树 [0, r]  在左子树里 则n最大为2*r 若 建一个[0, 2*r+1] 的线段树 (左子树==右子树 [0, r]  在左子树里 这时则 [0, r] 就可以建树 所以搜的时候超出2*r 就直接return #include <cstdio> #include <cstring> #include <cstdli

DFS+剪枝 HDOJ 5323 Solve this interesting problem

题目传送门 1 /* 2 题意:告诉一个区间[L,R],问根节点的n是多少 3 DFS+剪枝:父亲节点有四种情况:[l, r + len],[l, r + len - 1],[l - len, r],[l - len -1,r]; 4 */ 5 #include <cstdio> 6 #include <algorithm> 7 #include <cstring> 8 #include <cmath> 9 #include <queue> 10

HDU 5323(2015多校3)-Solve this interesting problem(dfs+剪枝)

题目地址:HDU 5323 题意:给一个l,r,表示区间[l,r],问是否存在区间为[0,n]的线段树的节点区间为[l,r],如果有求最小的n,如果没有输出-1. 思路:因为L/(R-L+1)<=2015,按照线段树的性质每次分区间序号扩大两倍,所以可以得出差不多有22层,所以用爆搜就可以,由上把[l,r]区间不断扩张,直到满足l==0为止.顺便剪剪枝. #include <stdio.h> #include <math.h> #include <string.h>

多校3 1008 Solve this interesting problem

Solve this interesting problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1020    Accepted Submission(s): 279 Problem Description Have you learned something about segment tree? If not, don’

HDU 1312:Red and Black(DFS搜索)

HDU 1312:Red and Black Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From