sicily 1052. Candy Sharing Game

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

Notes:
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase
#include <iostream>
#include <vector>

using namespace std;

int main(int argc, char const *argv[])
{
    int stuNum;
    vector<int> stuCandy;
    while (cin >> stuNum && stuNum != 0) {
        stuCandy.resize(stuNum);
        for (int i = 0; i != stuNum; ++i)
            cin >> stuCandy[i];
        int roundNum = 0;
        while (++roundNum) {
            int firstCandy = stuCandy[0];
            int i;
            for (i = 0; i != stuNum - 1; ++i) {
                stuCandy[i] -= (stuCandy[i] / 2);
                stuCandy[i] += (stuCandy[i + 1] / 2);
                if (stuCandy[i] % 2 != 0)
                    stuCandy[i] += 1;
            }
            stuCandy[i] -= (stuCandy[i] / 2);
            stuCandy[i] += (firstCandy / 2);
            if (stuCandy[i] % 2 != 0)
                stuCandy[i] += 1;    

            for (i = 0; i != stuNum - 1; ++i) {
                if (stuCandy[i] != stuCandy[i + 1])
                    break;
            }
            if (i == stuNum - 1)
                break;
        }
        cout << roundNum << " " << stuCandy[0] << endl;
    }
    return 0;
}
时间: 2024-10-11 06:36:47

sicily 1052. Candy Sharing Game的相关文章

hdu 1034 Candy Sharing Game

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4942    Accepted Submission(s): 3020 Problem Description A number of students sit in a circle facing their teacher in the cente

HDU 1034 Candy Sharing Game 模拟题

一个分糖游戏,找了会规律,没找到,只能直接模拟玩了. 果然0ms过了,看来数据不大,只是考编码能力罢了. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <limits.h> #include <stack> #

ACM-模拟之Candy Sharing Game——hdu1034

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2897    Accepted Submission(s): 1811 Problem Description A number of students sit in a circle facing their teacher in the cent

Candy Sharing Game(hdoj1034)

Problem Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to

J - Candy Sharing Game(模拟题)

主要是理解题目意思,然后就按照它说的来模拟就好了. Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of h

题目1145:Candy Sharing Game

题目描述: A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor

编程题目分类(剪辑)

1. 编程入门 2. 数据结构 3. 字符串 4. 排序 5. 图遍历 6. 图算法 7. 搜索:剪枝,启发式搜索 8. 动态规划/递推 9. 分治/递归 10. 贪心 11. 模拟 12. 算术与代数 13. 组合问题 14. 数论 15. 网格,几何,计算几何 [编程入门] PC 110101, uva 100, The 3n+1 problem, 难度 1 PC 110102, uva 10189, Minesweeper, 难度 1 PC 110103, uva 10137, The T

HDU-1034-Candy Sharing Game(C++ &amp;&amp; 简单模拟)

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3703    Accepted Submission(s): 2311 Problem Description A number of students sit in a circle facing their teacher in the cent

hdoj-1034-Candy Sharing Game

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3812 Accepted Submission(s): 2377 Problem Description A number of students sit in a circle facing their teacher in the center. Ea