Mayor's posters POJ - 2528

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
using namespace std;
typedef long long LL;
const int MAXN = 10010;
struct post
{
    LL l,r;
}p[MAXN];
int x[MAXN<<1];
int H[10000005];
struct node
{
    LL l,r;
    bool laz;//标记当前是否被完全覆盖
}T[MAXN*8+3];

void pushup(LL p)
{
    if(T[p*2].laz&&T[p*2+1].laz)
        T[p].laz = true;
    /*else
        T[p].laz = false;*/
}
void build(LL p,LL l,LL r)
{
    T[p].l = l,T[p].r = r;
    T[p].laz = false;
    if(l==r) return ;
    int mid = (l + r)/2;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
}
bool update(LL x,LL l,LL r)
{
    if(T[x].laz) return false;
    if(l == T[x].l && r == T[x].r)
    {
        T[x].laz = true;
        return true;
    }
    //pushdown(x);
    LL mid = (T[x].l + T[x].r)/2;
    bool R;
    if(r<=mid)
        R =  update(x*2,l,r);
    else if(l>mid)
        R = update(x*2+1,l,r);
    else
    {
        bool r1 = update(x*2,l,mid);
        bool r2 = update(x*2+1,mid+1,r);
        R =  r1||r2;
    }
    if(T[x*2].laz&&T[x*2+1].laz)
        T[x].laz = true;
    return R;
}
int main()
{
    int n;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int cnt = 0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].l,&p[i].r);
            x[cnt++] = p[i].l;
            x[cnt++] = p[i].r;
        }
        sort(x,x+cnt);
        cnt = unique(x,x+cnt)-x;
        for(int i= 0;i<cnt;i++)
            H[x[i]] = i;
        build(1,0,cnt-1);
        int ans = 0;
        for(int i = n-1; i>=0; i--)
            if(update(1,H[p[i].l],H[p[i].r]))
                ans++;
        printf("%d\n", ans);
    }
}

Mayor's posters POJ - 2528

时间: 2024-07-31 10:46:18

Mayor's posters POJ - 2528的相关文章

Mayor&#39;s posters POJ - 2528 (线段树 + 离散化)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 86160   Accepted: 24734 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

Mayor&#39;s posters POJ - 2528 线段树区间覆盖

//线段树区间覆盖 #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; const int N=100010; int flag; struct node{ int l,r; //vis 是这块区域是否完全被覆盖 bool vis; }tr[N<<2]; struct point { int id; int x

线段树 Mayor&#39;s posters

甚至DFS也能过吧 Mayor's posters POJ - 2528 The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to bui

D - Mayor&#39;s posters

D - Mayor's posters POJ - 2528 思路:线段树+离散化. 离散化时注意特殊情况,如果两个数相差大于一,离散时也应该差1.比如 1 3 离散后应该为 1 2. 错因: 1.二分时出现错误,,zz  zz  Orz 2. if(tree[now].l==tree[now].r) return ; 这句话漏了.   Orz          还要注意这句话的位置. #include<cstdio> #include<cstring> #include<i

POJ - 2528 - Mayor&#39;s posters 【线段树+离散化+补点】

http://poj.org/problem?id=2528 #include <cstdio> #include <iostream> #include <set> #include <cstring> #include <string> #define left rt<<1 #define right rt<<1|1 using namespace std; const int MAXN = 32768 + 5; in

POJ 2528 Mayor&#39;s posters (线段树区间更新+离散化)

题目链接:http://poj.org/problem?id=2528 给你n块木板,每块木板有起始和终点,按顺序放置,问最终能看到几块木板. 很明显的线段树区间更新问题,每次放置木板就更新区间里的值.由于l和r范围比较大,内存就不够了,所以就用离散化的技巧 比如将1 4化为1 2,范围缩小,但是不影响答案. 写了这题之后对区间更新的理解有点加深了,重点在覆盖的理解(更新左右两个孩子节点,然后值清空),还是要多做做题目. 1 #include <iostream> 2 #include <

POJ 2528 Mayor&#39;s posters (hash+线段树成段更新)

题意:有一面墙,被等分为1QW份,一份的宽度为一个单位宽度.现在往墙上贴N张海报,每张海报的宽度是任意的,但是必定是单位宽度的整数倍,且<=1QW.后贴的海报若与先贴的海报有交集,后贴的海报必定会全部或局部覆盖先贴的海报.现在给出每张海报所贴的位置(左端位置和右端位置),问张贴完N张海报后,还能看见多少张海报?(PS:看见一部分也算看到.) 思路:简单的成段更新,但是数据量是1千万,会MT,所以要区间压缩(离散化),保证覆盖的关系不变,离散化的时候有个易错的细节,poj数据水了,这个易错点引用h

POJ 2528 Mayor&#39;s posters.

~~~~ 一直MLE,才发现要写离散化操作.其他就是线段树的成段更新(每次用不同标记去更新区间),最后统计下有多少种标记就OK了. 题目链接:http://poj.org/problem?id=2528 大牛写的很详细,请戳:http://blog.csdn.net/metalseed/article/details/8041334 ~~~~ #include<cstdio> #include<cstring> #include<algorithm> #define N

poj 2528 Mayor&#39;s posters【离散化+线段树】

题目:poj 2528 Mayor's posters 题意:给一个长度非常长的墙上贴长度为ai的海报,由于有的会覆盖掉,求最后能看见的海报个数. 分析:题目和POJ2777 一模一样,方法也一样,只不过这个要离散化,其次要数组开大一点.至少2倍. 离散化的时候用了C++的 pair 类,还是比较好用的. 代码: #include <iostream> #include <algorithm> #include <utility> #include <cstrin