Song Jiang's rank list(杭电oj5131)(2014ACM/ICPC亚洲区广州站)

Song Jiang‘s rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 168    Accepted Submission(s): 91

Problem Description

《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai‘an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including
scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one‘s rank is higher. If two
outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.

Input

There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw‘s name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw‘s name.

The input ends with n = 0

Output

For each test case, print the rank list first. For this part in the output ,each line contains an outlaw‘s name and the number of enemies he killed.

Then, for each name in the query of the input, print the outlaw‘s rank. Each outlaw had a major rank and a minor rank. One‘s major rank is one plus the number of outlaws who killed more enemies than him/her did.One‘s minor rank is one plus the number of outlaws
who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It‘s guaranteed
that each query has an answer for it.

Sample Input

5
WuSong 12
LuZhishen 12
SongJiang 13
LuJunyi 1
HuaRong 15
5
WuSong
LuJunyi
LuZhishen
HuaRong
SongJiang
0

Sample Output

HuaRong 15
SongJiang 13
LuZhishen 12
WuSong 12
LuJunyi 1
3 2
5
3
1
2

Source

2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

题意:

按照杀人数从大到小输出,杀人数相同,按名字字典序从小到大规则输出。

然后输入一个名字,输出杀人数大于他自己的人数+1;之后输出名字的字典序

小于他自己并且杀人数相同人数+1,如果这个数为1则不用输出。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct st
{
	char name[303];
	int kill;
}data[202];
int cmp(st a,st b)//注意排序就好。
{
	if(a.kill!=b.kill)
	      return a.kill>b.kill;
	else if(strcmp(a.name,b.name)<0)
	      return 1;
	else
	      return 0;
}
int main()
{
	int i,j,l,n,m,k,t;
	char s[302];
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
		    scanf("%s %d",data[i].name,&data[i].kill);
		sort(data,data+n,cmp);
		for(i=0;i<n;i++)
		{
		     printf("%s %d\n",data[i].name,data[i].kill);
		}
		scanf("%d",&m);
		for(i=0;i<m;i++)
		{
			scanf("%s",s);
			for(l=0;l<n;l++)
			{
				if(strcmp(s,data[l].name)==0)
				{
				    k=l;
			        t=1;
				    for(j=k-1;j>=0;j--)
				    {
					    if(data[k].kill==data[j].kill)
					       t++;
				    }
				    if(t==1)
				        printf("%d\n",k+1);
				    else
				        printf("%d %d\n",k-t+2,t);
			   }
		   }
		}
	}
	return 0;
}

Song Jiang's rank list(杭电oj5131)(2014ACM/ICPC亚洲区广州站)

时间: 2024-10-26 00:42:24

Song Jiang's rank list(杭电oj5131)(2014ACM/ICPC亚洲区广州站)的相关文章

K.Bro Sorting(杭电5122)(2014ACM/ICPC亚洲区北京站)

K.Bro Sorting Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 67    Accepted Submission(s): 39 Problem Description Matt's friend K.Bro is an ACMer. Yesterday, K.Bro learnt an algorithm: Bubbl

hdu 5131 Song Jiang&#39;s rank list(模拟)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 662    Accepted Submission(s): 329 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

[ACM] HDU 5131 Song Jiang&#39;s rank list (模拟)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 36    Accepted Submission(s): 18 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'an

HDU 5131 Song Jiang&#39;s rank list(排序)

题意看样例就可以了啊. 简单的二级排序+暴力查询. Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 264    Accepted Submission(s): 137 Problem Description <Shui Hu Zhuan>,also <Water Margin&

HDOJ 5131 Song Jiang&#39;s rank list 水

水排序 Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 71    Accepted Submission(s): 39 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Na

HDU 5131 Song Jiang&#39;s rank list(水题)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 259    Accepted Submission(s): 134 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

HDU5131-Song Jiang&#39;s rank list HDU5135-Little Zu Chongzhi&#39;s Triangles(大佬写的)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 2006    Accepted Submission(s): 1128 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai

杭电 HDU 1164 Eddy&#39;s research I

Eddy's research I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7117    Accepted Submission(s): 4268 Problem Description Eddy's interest is very extensive, recently  he is interested in prime

hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29577    Accepted Submission(s): 13188 Problem Description A ring is compose of n circles as shown in diagram. Put natural num