[2013山东ACM]省赛 The number of steps (可能DP,数学期望)

The number of steps

nid=24#time" style="padding-bottom:0px; margin:0px; padding-left:0px; padding-right:0px; color:rgb(83,113,197); text-decoration:none; padding-top:0px">

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描写叙述

Mary stands in a strange maze, the maze looks like a triangle(the first layer have one room,the second layer have two rooms,the third layer have three rooms …). Now she stands at the top point(the first layer), and the KEY of this maze is in the lowest layer’s
leftmost room. Known that each room can only access to its left room and lower left and lower right rooms .If a room doesn’t have its left room, the probability of going to the lower left room and lower right room are a and b (a + b = 1 ). If a room only has
it’s left room, the probability of going to the room is 1. If a room has its lower left, lower right rooms and its left room, the probability of going to each room are c, d, e (c + d + e = 1). Now , Mary wants to know how many steps she needs to reach the
KEY. Dear friend, can you tell Mary the expected number of steps required to reach the KEY?

输入

There
are no more than 70 test cases.

In each case , first Input a positive integer n(0

The
input is terminated with 0. This test case is not to be processed.

输出

Please
calculate the expected number of steps required to reach the KEY room, there are 2 digits after the decimal point.

演示样例输入

3
0.3 0.7
0.1 0.3 0.6
0 

演示样例输出

3.41

提示

来源

2013年山东省第四届ACM大学生程序设计竞赛

解题思路:

对于数学期望的定义是这种。数学期望

E(X) = X1*p(X1) + X2*p(X2) + …… + Xn*p(Xn)

比方打靶打中8环的概率为0.3  ,打中7环的概率为0.7,那么打中环数的期望就是 8*0.3 + 7*0.7

本题中对于左边没有屋子的仅仅能向左下和右下走,概率为a,b,对于左边。左下,右下都有屋子的,三种方向都能够走,概率为 e,c,d,对于没有左下,没有右下仅仅能向左走的概率为1.问从顶部到左下角期望走的步数。

就是求数学期望,但预先不知道离散的走的步数。所以须要用到期望的离散性质。

本题中我们用dp[i][j] 表示当前位置距离目的地还须要走的期望步数。那么目的地如果为dp[n][1] (依据建的坐标不一样,位置也不一样),那么dp[n][1]的值为0,由于不须要再走了,那么我们所求的就是dp[1][1] 開始的地方。所以解题的过程。就是一个逆推的过程。

以下,我们用两种视角(来解决本题)

代码:

首先以我们的视角:

#include <iostream>
#include <string.h>
#include <iomanip>
using namespace std;
double dp[100][100];
int n;
double a,b,c,d,e;

int main()
{
    while(cin>>n&&n)
    {
        cin>>a>>b>>c>>d>>e;
        memset(dp,0,sizeof(dp));
        dp[n][1]=0;
        for(int i=2;i<=n;i++)
            dp[n][i]+=1*(dp[n][i-1]+1);//处理最后一行
        for(int i=n-1;i>=1;i--)//从倒数第二行開始处理
        {
            dp[i][1]+=a*(dp[i+1][1]+1)+b*(dp[i+1][2]+1);//处理每一行的第一列
            for(int j=2;j<=n;j++)
                dp[i][j]+=c*(dp[i+1][j]+1)+d*(dp[i+1][j+1]+1)+e*(dp[i][j-1]+1);//处理每一行的除了第一列以外的其他列
        }
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<dp[1][1]<<endl;
    }
    return 0;
}

以故事中主人公的视角:

#include <iostream>
#include <string.h>
#include <iomanip>
using namespace std;
double dp[100][100];
int n;
double a,b,c,d,e;

int main()
{
    while(cin>>n&&n)
    {
        cin>>a>>b>>c>>d>>e;
        memset(dp,0,sizeof(dp));
        dp[n][n]=0;//目的地
        for(int i=n-1;i>=1;i--)
            dp[n][i]+=1*(dp[n][i+1]+1);
        for(int i=n-1;i>=1;i--)//行数
        {
            dp[i][i]+=a*(dp[i+1][i+1]+1)+b*(dp[i+1][i]+1);
            for(int j=i-1;j>=1;j--)
                dp[i][j]+=c*(dp[i+1][j+1]+1)+d*(dp[i+1][j]+1)+e*(dp[i][j+1]+1);
        }
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<dp[1][1]<<endl;
    }
    return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

时间: 2024-10-15 02:28:53

[2013山东ACM]省赛 The number of steps (可能DP,数学期望)的相关文章

[2013山东ACM省赛] The number of steps (概率DP,数学期望)

The number of steps Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 Mary stands in a strange maze, the maze looks like a triangle(the first layer have one room,the second layer have two rooms,the third layer have three rooms -). Now she st

[2013山东ACM省赛] Alice and Bob

Alice and Bob Time Limit: 1000MS Memory limit: 65536K 题目描述 Alice and Bob like playing games very much.Today, they introduce a new game. There is a polynomial like this: (a0*x^(2^0)+1) * (a1 * x^(2^1)+1)*.......*(an-1 * x^(2^(n-1))+1). Then Alice ask

[2012山东ACM省赛] n a^o7 !(模拟,字符替换)

n a^o7 ! Time Limit: 1000MS Memory limit: 65536K 题目描述 All brave and intelligent fighters, next you will step into a distinctive battleground which is full of sweet and happiness. If you want to win the battle, you must do warm-up according to my inst

[2012山东ACM省赛] Pick apples (贪心,全然背包,枚举)

Pick apples Time Limit: 1000MS Memory limit: 165536K 题目描写叙述 Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because s

13年山东省赛 The number of steps(概率dp水题)

转载请注明出处: http://www.cnblogs.com/fraud/          ——by fraud The number of steps Time Limit: 1 Sec  Memory Limit: 128 M Description Mary stands in a strange maze, the maze looks like a triangle(the first layer have one room,the second layer have two ro

[2012山东ACM省赛] Pick apples (贪心,完全背包,枚举)

Pick apples Time Limit: 1000MS Memory limit: 165536K 题目描述 Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she

[2011山东ACM省赛] Binomial Coeffcients(求组合数)

Binomial Coeffcients nid=24#time" style="padding-bottom:0px; margin:0px; padding-left:0px; padding-right:0px; color:rgb(83,113,197); text-decoration:none; padding-top:0px"> Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描写叙述 输入

山东省第六届ACM省赛 H---Square Number 【思考】

题目描述 In mathematics, a square number is an integer that is the square of an integer. In other words, it is the product of some integer with itself. For example, 9 is a square number, since it can be written as 3 * 3. Given an array of distinct intege

[2012山东ACM省赛] Fruit Ninja II (三重积分,椭球体积)

大概去年夏天的时候,在<C和指针>里面一个练习题要求实现一个很简单的不包含打印浮点数功能的printf函数.但是很好奇,于是一直纠结下去,结果就是知道了printf的实现,自己也写了一个简单的.或许是夏天的原因吧,那时候暑假没回去,凌晨四点兴奋到不能睡觉.那时候刚开始写blog.没想整理一下,只是简单的把最重要的实现"工具"贴了一个blog在 http://blog.csdn.net/cinmyheart/article/details/9804189 那时候第一次看lin