poj2773 Happy 2006

Happy 2006

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 9987   Accepted: 3434

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

解题思路:二分枚举1-2^64之间的数x,找到1-x与m互质的个数s,这里利用容斥原理,如果s与k相等,那么该x即为结果;

参考代码:

#include <iostream>
#include <vector>
#include <math.h>
using namespace std;
typedef long long ll;
const int MAX = 1000010;
int p[MAX],count;
void fun(ll n){
	ll i;
	count=0;
	for (i=2;i*i<=n;i++){
		if (n%i==0){
			p[count++]=i;
			while (n%i==0)
				n/=i;
		}
	}
	if (n>1)
		p[count++]=n;
}
ll solve(ll n,ll r){
	ll sum=0;
	for (int i=1;i<(1<<count);i++){
		ll mult=1,bits=0;
		for (int j=0;j<count;j++){
			if (i&(1<<j)){
				bits++;
				mult*=p[j];
			}
		}
		ll cur=r/mult;
		if (bits%2==1)
			sum+=cur;
		else
			sum-=cur;
	}
	return r - sum;
}
int main(){
	ll n,m,mid,num;
	while (cin>>n>>m){
		fun(n);
		ll r=0xffffffff,l=1;
		while (r-l>0){
			mid=(r+l)/2;
			num=solve(n,mid);
			if (num>=m)
				r=mid;
			else
				l=mid+1;
		}
		cout<<l<<endl;
	}
	return 0;
}
时间: 2024-10-05 12:15:41

poj2773 Happy 2006的相关文章

POJ2773 Happy 2006【容斥原理】

题目链接: http://poj.org/problem?id=2773 题目大意: 给你两个整数N和K.找到第k个与N互素的数(互素的数从小到大排列).当中 (1 <= m <= 1000000,1 <= K <= 100000000 ). 解题思路: K非常大,直接从小到大枚举找出不现实,仅仅能二分答案.二分枚举[1.INF]范围内全部的数x, 找到1~x范围内与N互素的数个数.假设等于K,则就是结果. 然后考虑1~x范围内与N互素的数个数 = x - 1~x范围内与N不互素的

poj2773 Happy 2006(二分+容斥)

题目链接:点这里!!!! 题意: 给你两个整数m(1<=m<=1e6),k(1<=k<=1e8).求第k个与m互质的数是多少. 题解: 直接二分+容斥. 代码: #include<cstdio> #include<cstring> #include<iostream> #include<sstream> #include<algorithm> #include<vector> #include<bitse

【poj2773】Happy 2006 欧几里德

题目描述: 分析: 根据欧几里德,我们有gcd(b×t+a,b)=gcd(a,b) 则如果a与b互质,则b×t+a与b也一定互质,如果a与b不互质,则b×t+a与b也一定不互质. 所以与m互质的数对m取模具有周期性,则根据这个方法我们就可以很快的求出第k个与m互质的数. 假设小于m的数且与m互质的数有l个,其中第i个是ai,则第k*l+i个与m互质的数是k*m+ai. 所以,我就for一遍求出所有m以内的与m互质的数,然后根据周期性求解.(感觉有点暴力对吧) 代码如下,很短的: 1 #inclu

【poj2773】 Happy 2006

http://poj.org/problem?id=2773 (题目链接) 题意:给出两个数m,k,要求求出从1开始与m互质的第k个数. Solution 数据范围很大,直接模拟显然是不行的,我们需要用到一些奇奇怪怪的方法. 考虑是否可以通过某些途径快速得到解,然而并没有头绪.正难则反,能不能通过计算不与m互质的数的个数来得到互质的数的个数呢?答案是可行的,我们可以运用容斥. 二分一个答案mid,容斥统计出在区间[1,mid]中是m的质因子的倍数的数的个数ans,然后我们可以用mid-ans得到

POJ2773---Happy 2006(容斥+二分)

Description Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9-are all relatively prime to 2006. Now your job is easy: for the given integer m, find the K-th element

ISA Server 2006 软件防火墙管理

项目背景 公司是以生产制造企业,分有综合管理部.市场部.业务部.研发部门及制造部.为了适应市场的拓展,扩大公司网络规模,并希望拥有一套安全.高效.畅通的网络设施.安全.高效的网络,可以极大提高公司的办公效率.使公司安全高效的发展. ISA Server 2006 软件防火墙管理下载链接: http://down.51cto.com/data/2268161

AutoCAD .NET开发大师Kean有价值的博客 2006年8月 .NET内容整理

一 Calling AutoCAD commands from .NET 使用.NET调用AutoCAD命令 In this earlier entry I showed some techniques for calling AutoCAD commands programmatically from ObjectARX and from VB(A). Thanks to Scott Underwood for proposing that I also mention calling com

POJ 2773 Happy 2006 (分解质因数+容斥+二分 或 欧几里德算法应用)

Happy 2006 Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 10309   Accepted: 3566 Description Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are a

Error Code: 2006 - MySQL 鏈嶅姟鍣ㄥ凡绂荤嚎

将sql文件导入到mysql时候,就一直报这个错误.我试过网上各种方法都行不通.最后将下面一句执行了一下就可以了,而且没有重启mysql. SET GLOBAL max_allowed_packet=67108864; Error Code: 2006 - MySQL 鏈嶅姟鍣ㄥ凡绂荤嚎,布布扣,bubuko.com