poj 2367 Genealogical tree(拓扑)

Genealogical tree

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3685   Accepted: 2453   Special Judge

Description

The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of
children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further,
there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it
is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University
Internal Contest October‘2000 Junior Session

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define M 550
int mp[M][M],du[M],re[M];
int n,m;
void topo(){
	int t=0,i;
	queue<int> q;
	for(i=1;i<=n;i++){
		if(du[i]==0)
			q.push(i);
	}
	while(!q.empty()){
		int s=q.front();
		q.pop();
		re[t++]=s;
		for(i=1;i<=n;i++){
			if(mp[s][i] && --du[i]==0){
				q.push(i);
			}
		}
	}
	printf("%d",re[0]);
	for(i=1;i<t;i++)
		printf(" %d",re[i]);
	 printf("\n");
}
int main(){
	int i,j,x;
	while(scanf("%d",&n)!=EOF){
		memset(mp,0,sizeof(mp));
		memset(du,0,sizeof(du));
		for(i=1;i<=n;i++){
			while(scanf("%d",&x),x){
				mp[i][x]=1;
				du[x]++;
			}
		}
		topo();
	}
	return 0;
} 
时间: 2024-08-11 09:53:12

poj 2367 Genealogical tree(拓扑)的相关文章

POJ 2367 Genealogical tree 拓扑题解

一条标准的拓扑题解. 我这里的做法就是: 保存单亲节点作为邻接表的邻接点,这样就很方便可以查找到那些点是没有单亲的节点,那么就可以输出该节点了. 具体实现的方法有很多种的,比如记录每个节点的入度,输出一个节点之后,把这个节点对于其他节点的入度去掉,然后继续查找入度为零的点输出.这个是一般的做法了,效果和我的程序一样的. 有兴趣的也可以参考下我这种做法. #include <stdio.h> #include <string.h> #include <vector> us

POJ 2367 Genealogical tree 拓扑排序入门

Description The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surpris

POJ 2367 Genealogical tree 拓扑排序入门题

Genealogical tree Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8003   Accepted: 5184   Special Judge Description The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. T

poj 2367 Genealogical tree(拓扑排序)

本题链接:点击打开链接 本题大意: 首先输入一个N,表示有N行,也表示有N个点,编号从1到N,接下来有N行,第i行输入的数据代表这些编号要在i的前面,每行输入0表示结束,求一种符合题意的拓扑序列.解题思路: 此题就是基本的拓扑排序,弄清楚题意应该就不难了吧,具体请参考代码: #include<stdio.h> #include<string.h> #define INF 0x3f3f3f3f #define MAX 220 int indegree[MAX]; int head[M

poj 2367 Genealogical tree【拓扑排序输出可行解】

Genealogical tree Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3674   Accepted: 2445   Special Judge Description The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. T

POJ 2367 Genealogical tree(拓扑排序)

Genealogical tree Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3332   Accepted: 2233   Special Judge Description The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. T

图论之拓扑排序 poj 2367 Genealogical tree

题目链接 http://poj.org/problem?id=2367 题意就是给定一系列关系,按这些关系拓扑排序. #include<cstdio> #include<cstring> #include<queue> #include<vector> #include<algorithm> using namespace std; const int maxn=200; int ans; int n; int in[maxn]; //记录入度

POJ 2367 Genealogical tree (拓扑排序基础题)

题目链接:http://poj.org/problem?id=2367 题目: Description The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one paren

poj 2367 Genealogical tree (拓扑排序)

火星人的血缘关系很奇怪,一个人可以有很多父亲,当然一个人也可以有很多孩子.有些时候分不清辈分会产生一些尴尬.所以写个程序来让n个人排序,长辈排在晚辈前面. 输入:N 代表n个人 1~n 接下来n行 第i行表示第i个人的孩纸,无序排列,可能为空.0代表一行输入结束. (大概我的智商真的不合适,否则怎么这么久了连个拓扑排序都写不好,T了三次..) 代码: /******************************************** Problem: 2367 User: Memory: