HDU-1048-The Hardest Problem Ever(C++ && 偶尔一水......)

The Hardest Problem Ever

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19343    Accepted Submission(s): 9061

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure
it out without knowing how it worked.

You are a sub captain of Caesar‘s army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e.,
if the letter is ‘A‘, the cipher text would be ‘F‘). Since you are creating plain text out of Caesar‘s messages, you will do the opposite:

Cipher text

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input

START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

Source

South Central USA 2002

Recommend

We have carefully selected several similar problems for you:  1018 1032 1062 1091 1076

题目的意思很明确:就是按照题目给定的要求解密字符串,解密的规则如下:

Cipher text(原密码)

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text(破译密码)

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

不难发现大于或者等于‘E‘的字符都是向前推进5个字符,而小于等于‘E‘的字符也是向前推进5个字符,不过超出的部分从‘Z‘往前面推!

另外注意一下输入格式:(包括多组输入数据)\

1.ENDINPUT表示程序的结束!

2.每组输入数据以START开始,END结束.

最后上代码:

#include <stdio.h>
#include <string.h>
int main(void)
{
    char str[200];
    int i;
    while (gets(str) != NULL && strcmp(str, "ENDOFINPUT"))
    {
        if (!strcmp(str, "START") || !strcmp(str, "END"))
            continue;
        for(i=0;i<strlen(str);i++)
        {
            if(str[i]>='A')
            {
                if(str[i]<='E')
                {
                    str[i]='V'+str[i]-'A';
                    printf("%c",str[i]);
                }
                else
                {
                    printf("%c",str[i]-5);
                }
            }
            else
            {
                printf("%c",str[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
时间: 2024-11-05 06:25:58

HDU-1048-The Hardest Problem Ever(C++ && 偶尔一水......)的相关文章

JAVA HDU 1048 The Hardest Problem Ever

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1048 1 package hdu; 2 3 import java.io.BufferedInputStream; 4 import java.util.Scanner; 5 6 public class hdu_1048 { 7 8 public static void main(String[] args) { 9 Scanner in = new Scanner(new BufferedInp

HDU 1048.The Hardest Problem Ever【字符串处理】【8月25】

The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cip

HDU 1048 - The Hardest Problem Ever

让你改一改字符 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 char s[105]; 6 const char list[]={'V','W','X','Y','Z','A','B','C','D','E','F','G' 7 ,'H','I','J','K','L','M','N','O','P','Q','R','S' 8 ,'T','

(HDU)1048 --The Hardest Problem Ever( 最难的问题)

题目链:http://vjudge.net/problem/HDU-1048 其实就是一个密码变成明文的过程,找出规律就可以了. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 6 int main() 7 { 8 char text[10000]; 9 while(gets(text)) 10 { 11 if (!strcmp(text, &

HDOJ 1048 The Hardest Problem Ever

[题意]:很普通的解码问题,所有的大写字母左移5位.注意A-E的移动是加21,其他的减5. [代码:AC] #include <iostream> #include <iomanip> #include <cstring> #include <cstdlib> #include <cstdio> using namespace std; #define MAX 200+10 int main() { char str[MAX]; while (g

The Hardest Problem Ever(杭电1048)

/*The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This c

(字符串 枚举)The Hardest Problem Ever hdu1048

The Hardest Problem Ever 链接:http://acm.hdu.edu.cn/showproblem.php?pid=1048 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 31307    Accepted Submission(s): 14491 Problem Description Julius Caesa

HDU 1048 What Is Your Grade? (简单模拟)

 What Is Your Grade? Problem Description "Point, point, life of student!" This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in

hdu 5293 Tree chain problem(树链剖分+树形dp)

题目链接:hdu 5293 Tree chain problem 维护dp[u], sum[u],dp[u]表示以u为根节点的子树的最优值.sum[u]表示以u节点的所有子节点的dp[v]之和.对于边a,b,w,在LCA(a,b)节点的时候进行考虑.dp[u] = min{dp[u], Sum(a,b) - Dp(a,b) + sum[u] | (ab链上的点,不包括u } #pragma comment(linker, "/STACK:1024000000,1024000000")