[ACM] poj 2096 Collecting Bugs (概率DP,期望)

Collecting Bugs

Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 2026   Accepted: 971
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers
exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.

Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s
subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of
each category.

Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be
interested in Ivan‘s opinion about the reliability of the obsolete version.

A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems.
The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.

Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

解题思路:

一个软件有 s 个子系统,存在 n 种 bug。某人一天能找到一个 bug。问,在这个软件中找齐 n 种 bug,并且每个子系统中至少包含一个 bug 的时间的期望值(单位:天)。注意:bug 是无限多的,每个 bug
属于任何一种 bug 的概率都是 1/n;出现在每个系统是等可能的,为 1/s。

令 ex[i][j] 表示已经找到了 i 种 bug,且 j 个子系统至少包含一个 bug,距离完成目标需要的时间的期望。

这样说有点不好理解。换一种方法。有n个bug1有s个bug2,ex[i][j]表示为已经发现了i个bug1,j个bug2,离目标发现s个bug1,n个bug2还需要的期望天数。这样所求就是ex[0][0],而ex[n][s]则为0,因为已经全部发现,不需要额外的天数了。到下一天,可能产生四种情况,ex[i][j],没有发现任何bug,ex[i+1][j],发现一个bug1, ex[i][j+1],发现一个bug2,ex[i+1][j+1],发现两个bug,那么

ex[i][j]= 1+p1*ex[i][j] +p2*ex[i+1][j]+p3*ex[i][j+1]+p4*ex[i+1][j+1]   ,需要加1,因为是下一天

(后来右想了想,为什么由ex[i][j]可以推出四种情况,然后就可以说ex[i][j]=后面的式子呢,其实这里ex[i][j] “ 实际上”,这里说的实际,是在实际工作中,你要发现两个bug,肯定首先得发现一个bug吧,所以ex[i][j]其实是由后面那四个式子推出来的,因为我们这里ex[i][j]表示的意义就是距离完成目标还需要的时间期望。)

p1= (i/n)*(j/s)=(i*j)/(n*s)

p2=((n-i)/n)*(j/s)=(n-i)*j/(n*s)

p3=(i/n)*((s-j)/s)=i*(s-j)/(n*s)

p4=((n-i)/n)*((s-j)/s)=(n-i)*(s-j)/(n*s)

这样整理出来就是

ex[i][j]=1+ (i*j)/(n*s)*ex[i][j]+(n-i)*j/(n*s)*ex[i+1][j]+i*(s-j)/(n*s)*ex[i][j+1]+(n-i)*(s-j)/(n*s)*ex[i+1][j+1]

右边(i*j)/(n*s)*ex[i][j]移到左边合并同类项。得到:

ex[i][j]=(  1+(n-i)*j/(n*s)*ex[i+1][j]+i*(s-j)/(n*s)*ex[i][j+1]+(n-i)*(s-j)/(n*s)*ex[i+1][j+1]  )    
/   (1-(i*j)/(n*s))

参考资料:

http://kicd.blog.163.com/blog/static/126961911200910168335852/

代码:

#include <iostream>
#include <string.h>
#include <iomanip>
using namespace std;
const int maxn=1005;
double ex[maxn][maxn];

int main()
{
    memset(ex,0,sizeof(ex));
    int n,s;
    cin>>n>>s;
    double m=n*s*1.0;
    for(int i=n;i>=0;i--)
        for(int j=s;j>=0;j--)
    {
        if(i==n&&j==s)
        continue;
        ex[i][j]=(1+((n-i)*(s-j)/m)*ex[i+1][j+1]+((n-i)*j/m)*ex[i+1][j]+(i*(s-j)/m)*ex[i][j+1])/(1-i*j/m);
    }
    cout<<setiosflags(ios::fixed)<<setprecision(4)<<ex[0][0];
    return 0;
}

[ACM] poj 2096 Collecting Bugs (概率DP,期望)

时间: 2024-07-31 03:23:48

[ACM] poj 2096 Collecting Bugs (概率DP,期望)的相关文章

poj 2096 Collecting Bugs (概率dp 天数期望)

题目链接 题意: 一个人受雇于某公司要找出某个软件的bugs和subcomponents,这个软件一共有n个bugs和s个subcomponents,每次他都能同时随机发现1个bug和1个subcomponent,问他找到所有的bugs和subcomponents的期望次数. 分析: 期望倒着推,概率正着推. dp[i][j]表示已经找到i种bug,并存在于j个子系统中,要达到目标状态的天数的期望.显然,dp[n][s]=0,因为已经达到目标了.而dp[0][0]就是我们要求的答案.dp[i][

Poj 2096 Collecting Bugs (概率DP求期望)

C - Collecting Bugs Time Limit:10000MS     Memory Limit:64000KB     64bit IO Format:%I64d & %I64u Submit Status Description Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software b

POJ 2096 Collecting Bugs(dp 期望)

题目链接:http://poj.org/problem?id=2096 Description Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n ca

poj 2096 Collecting Bugs (概率dp)

题意:有s个系统,n种bug,一个程序员每天可以发现一个bug,求发现存在s个系统,n种bug的天数的期望 思路:定义dp[i][j]是已经发现i种bug,j个系统的期望 dp[i+1][j+1] 表示在一个新的系统中发现新bug 它的概率为 (n-i)/n*(s-j)/s dp[i+1][j]     表示在一个已经发现过的系统中发现了一种新的bug 概率为 (n-i)/n*j/s dp[i][j+1]     表示在一个新系统中发现一种已经发现过的bug 概率为 i/n*(s-j)/s dp

POJ 2096 Collecting Bugs(概率DP)

解题思路: 题目比较难理解,大致题意就是一共有N种bugs,分别属于S个子系统,求找到N种BUG并且每种子系统的bug都被找到所需要的天数的数学期望. dp[i][j]表示找到 i 种bug 属于 j 个子系统到 目标状态所需要的数学期望.dp[i][j]可以由四种状态转移而来. (i * j) / (n * s) * d[i][j]; (n - i) * j / (n * s) * dp[i+1][j]; i * (s - j)/(n * s) * dp[i][j + 1]; (n - i)

POJ 2096 Collecting Bugs 概率dp(水

题目链接:点击打开链接 题意: 点击打开链接 对于这里的dp做法是: 写一个状态x,然后把从x转移出去的方程写出来,即 x = y1+y2+··· 其中所有的yi都是已知的. 这样我们就会得到一个方程是从未知到已知. 但是dp是由已知到未知.所以我们再呵呵回来.. #include <cstdio> #include <iostream> #include <cstring> #include <queue> #include <algorithm&g

POJ 2096:Collecting Bugs 概率DP求期望

Collecting Bugs 题目连接: http://poj.org/problem?id=2096 题意: Ivan喜欢收集bug,他每天都会找到一个bug,找到的这个bug有一种属性并且属于一个子系统,bug共有n种属性,子系统共有s个 (0<n, s≤1000),求Ivan集齐了n种bug且每个子系统都有bug的期望. 题解: 第一道求期望的题,令dp[i][j]表示系统已经有了i个系统的全部j种bug并且要得到所有bug的天数的期望,因此dp[n][s]=0,而dp[0][0]则是所

poj 2096 Collecting Bugs 【概率DP】【逆向递推求期望】

Collecting Bugs Time Limit: 10000MS   Memory Limit: 64000K Total Submissions: 3523   Accepted: 1740 Case Time Limit: 2000MS   Special Judge Description Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material s

POJ 2096 Collecting Bugs(概率DP求期望)

传送门 Collecting Bugs Time Limit: 10000MS Memory Limit: 64000K Total Submissions: 4333 Accepted: 2151 Case Time Limit: 2000MS Special Judge Description Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stu