解题报告 之 SGU326 Perspective

解题报告 之 SGU326 Perspective

Description

Breaking news! A Russian billionaire has bought a yet undisclosed NBA team. He‘s planning to invest huge effort and money into making that team the best. And in fact he‘s been very specific about the expected result: the first place.

Being his advisor, you need to determine whether it‘s possible for your team to finish first in its division or not.

More formally, the NBA regular season is organized as follows: all teams play some games, in each game one team wins and one team loses. Teams are grouped into divisions, some games are between the teams in the same division, and some are between the teams
in different divisions.

Given the current score and the total number of remaining games for each team of your division, and the number of remaining games between each pair of teams in your division, determine if it‘s possible for your team to score at least as much wins as any other
team in your division.

Input

The first line of input contains N (2 ≤ N ≤ 20) — the number of teams in your division. They are numbered from 1 to N, your team has number 1.

The second line of input contains N integers w1w2,..., wN, where wi is the total number of games that ith team has won
to the moment.

The third line of input contains N integers r1r2,..., rN, where ri is the total number of remaining games for the ith team
(including the games inside the division).

The next N lines contain N integers each. The jth integer in the ith line of those contains aij — the number of games remaining between teams i and j.
It is always true that aij=a ji and aii=0, for all iai1 + ai2 +... + aiN ≤ ri.

All the numbers in input are non-negative and don‘t exceed 10\,000.

Output

On the only line of output, print "

YES

" (without quotes) if it‘s possible for the team 1 to score at least as much wins as any other team of its division, and "

NO

" (without quotes) otherwise.

Sample Input

sample input
sample output
3
1 2 2
1 1 1
0 0 0
0 0 0
0 0 0
YES
sample input
sample output
3
1 2 2
1 1 1
0 0 0
0 0 1
0 1 0
NO

题目大意:本小组内有N支队伍,你是team1。现在每个队已经有了score[i]的分,并且总共还剩下remain[i]场比赛(包括组内比赛和跨组比赛)。然后给你一个N*N的矩阵match表示组内剩余比赛,match[i][j]表示i与j队伍还剩多少场比赛,保证match[i][j]==match[j][i],并且match[i][i]==0(忽然想起了前面那道坑题不保证这一点,妈蛋)。每场比赛不存在平局,赢的得1分,输的得2分。然后问你你们组是否有可能得小组第一(分数大于等于其他所有组内队伍)?

分析:更前面的WHU1124 Football Coach异曲同工。思路就不赘述了,请参考上一篇博文,细节在于这道题有外部比赛,那么我们的最优假设基于team1所有外部比赛都获胜,而其他组的所有外部比赛都输。而且组内比赛只要关于team1的也是都由team1获胜。剩下的再跑最大流限定得分为score[1]-score[i],再验证满流即可。

上代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int MAXN = 610;
const int MAXM = 361000;
const int INF = 0x3f3f3f3f;

struct Edge
{
	int to, cap, next;
};

Edge edge[MAXM];
int level[MAXN];
int head[MAXN];
int score[MAXN];
int remain[MAXN];
int match[MAXN][MAXN];
int src, des, cnt;

void addedge( int from, int to, int cap )
{
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].next = head[from];
	head[from] = cnt++;

	swap( from, to );

	edge[cnt].to = to;
	edge[cnt].cap = 0;
	edge[cnt].next = head[from];
	head[from] = cnt++;

}

int bfs()
{
	memset( level, -1, sizeof level );
	queue<int> q;
	while (!q.empty())
		q.pop();

	level[src] = 0;
	q.push( src );

	while (!q.empty())
	{
		int u = q.front();
		q.pop();

		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].to;
			if (edge[i].cap > 0 && level[v] == -1)
			{
				level[v] = level[u] + 1;
				q.push( v );
			}
		}
	}
	return level[des] != -1;
}

int dfs( int u, int f )
{
	if (u == des) return f;
	int tem;

	for (int i = head[u]; i != -1; i=edge[i].next)
	{
		int v = edge[i].to;
		if (edge[i].cap > 0 && level[v] == level[u] + 1)
		{
			tem = dfs( v, min( f, edge[i].cap ) );
			if (tem > 0)
			{
				edge[i].cap -= tem;
				edge[i^1].cap += tem;
				return tem;
			}
		}
	}
	level[u] = -1;
	return 0;
}

int Dinic()
{
	int ans = 0, tem;
	while (bfs())
	{
		while (tem = dfs( src, INF ))
		{
			ans += tem;
		}
	}
	return ans;
}

int main()
{
	int n;
	src = 0;
	des = 605;
	while (cin >> n)
	{
		memset( head, -1, sizeof head );
		cnt = 0;
		int flow = 0;
		for (int i = 1; i <= n; i++)
		{
			cin >> score[i];
		}
		for (int i = 1; i <= n; i++)
		{
			cin >> remain[i];
		}
		//每队还剩多少场比赛

		for (int i = 1; i <= n; i++)
		for (int j = 1; j <= n; j++)
		{
			cin >> match[i][j];
			remain[i] -= match[i][j];
		}
		//算出每个队伍有几场外部比赛

		int g = 21;
		for (int i = 1; i <= n; i++)
		{
			for (int j = i + 1; j <= n; j++)
			{
				if (match[i][j])
				{
					if (i == 1)
					{
						score[1] += match[i][j];
					}
					else
					{
						addedge( src, g, match[i][j] );
						addedge( g, i, match[i][j] );
						addedge( g, j, match[i][j] );
						g++;
						flow += match[i][j];
					}
				}
			}
		}

		int flag = true;
		for (int i = 1; i <= n; i++)
		{
			if(i==1)
				score[i] += remain[i];

			if (score[i] > score[1] && i > 1)
			{
				flag = false;
				break;
			}
		}//更新外部比赛后的最高得分
		if (!flag)
		{
			cout << "NO" << endl;
			continue;
		}

		for (int i = 2; i <= n; i++)
		{
			addedge( i, des, score[1] - score[i] );
		}

		if (Dinic() == flow) cout << "YES" << endl;
		else cout << "NO" << endl;

	}	

	return 0;
}

好了下午要复习一下嵌入式系统。。今天没听课,呵呵。

时间: 2024-07-31 00:44:20

解题报告 之 SGU326 Perspective的相关文章

解题报告 之 POJ3057 Evacuation

解题报告 之 POJ3057 Evacuation Description Fires can be disastrous, especially when a fire breaks out in a room that is completely filled with people. Rooms usually have a couple of exits and emergency exits, but with everyone rushing out at the same time

hdu 1541 Stars 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541 题目意思:有 N 颗星星,每颗星星都有各自的等级.给出每颗星星的坐标(x, y),它的等级由所有比它低层(或者同层)的或者在它左手边的星星数决定.计算出每个等级(0 ~ n-1)的星星各有多少颗. 我只能说,题目换了一下就不会变通了,泪~~~~ 星星的分布是不是很像树状数组呢~~~没错,就是树状数组题来滴! 按照题目输入,当前星星与后面的星星没有关系.所以只要把 x 之前的横坐标加起来就可以了

【百度之星2014~初赛(第二轮)解题报告】Chess

声明 笔者最近意外的发现 笔者的个人网站http://tiankonguse.com/ 的很多文章被其它网站转载,但是转载时未声明文章来源或参考自 http://tiankonguse.com/ 网站,因此,笔者添加此条声明. 郑重声明:这篇记录<[百度之星2014~初赛(第二轮)解题报告]Chess>转载自 http://tiankonguse.com/ 的这条记录:http://tiankonguse.com/record/record.php?id=667 前言 最近要毕业了,有半年没做

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告 勘误1:第6题第4个 if最后一个条件粗心写错了,答案应为1580. 条件应为abs(a[3]-a[7])!=1,宝宝心理苦啊.!感谢zzh童鞋的提醒. 勘误2:第7题在推断连通的时候条件写错了,后两个if条件中是应该是<=12 落了一个等于号.正确答案应为116. 1.煤球数目 有一堆煤球.堆成三角棱锥形.详细: 第一层放1个, 第二层3个(排列成三角形), 第三层6个(排列成三角形), 第四层10个(排列成三角形). -. 假设一共

[noip2011]铺地毯(carpet)解题报告

最近在写noip2011的题,备战noip,先给自己加个油! 下面是noip2011的试题和自己的解题报告,希望对大家有帮助,题目1如下 1.铺地毯(carpet.cpp/c/pas) [问题描述]为了准备一个独特的颁奖典礼,组织者在会场的一片矩形区域(可看做是平面直角坐标系的第一象限)铺上一些矩形地毯.一共有n 张地毯,编号从1 到n.现在将这些地毯按照编号从小到大的顺序平行于坐标轴先后铺设,后铺的地毯覆盖在前面已经铺好的地毯之上.地毯铺设完成后,组织者想知道覆盖地面某个点的最上面的那张地毯的

ACdream 1203 - KIDx&#39;s Triangle(解题报告)

KIDx's Triangle Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others) Submit Statistic Next Problem Problem Description One day, KIDx solved a math problem for middle students in seconds! And than he created this problem. N

解题报告 之 CodeForces 91B Queue

解题报告 之 CodeForces 91B Queue Description There are n walruses standing in a queue in an airport. They are numbered starting from the queue's tail: the 1-st walrus stands at the end of the queue and the n-th walrus stands at the beginning of the queue.

解题报告 之 POJ1226 Substrings

解题报告 之 POJ1226 Substrings Description You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings. Input The first li

解题报告 之 UVA563 Crimewave

解题报告 之 UVA563 Crimewave Description Nieuw Knollendam is a very modern town. This becomes clear already when looking at the layout of its map, which is just a rectangular grid of streets and avenues. Being an important trade centre, Nieuw Knollendam a