Milk Pails(BFS)

Milk Pails

时间限制: 1 Sec  内存限制: 64 MB
提交: 16  解决: 4
[提交][状态][讨论版]

题目描述

Farmer
John has received an order for exactly M units of milk (1≤M≤200) that
he needs to fill right away. Unfortunately, his fancy milking machine
has just become broken, and all he has are two milk pails of integer
sizes X and Y (1≤X,Y≤100) with which he can measure milk. Both pails are
initially empty. Using these two pails, he can perform up to K of the
following types of operations (1≤K≤100):

- He can fill either pail completely to the top.

- He can empty either pail.

- He can pour the contents of one pail
into the other, stopping when the former becomes empty or the latter
becomes full (whichever of these happens first).

Although FJ realizes he may not be able to end up with exactly M total
units of milk in the two pails, please help him compute the minimum
amount of error between M and the total amount of milk in the two pails.
That is, please compute the minimum value of |M−M′| such that FJ can
construct M′ units of milk collectively between the two pails.

输入

The first, and only line of input, contains X, Y, K, and M.

输出

Output the smallest distance from M to an amount of milk FJ can produce.

样例输入

14 50 2 32

样例输出

18【分析】这跟昨天的 母亲的牛奶那题特别像,两个瓶,一开始都为空,有三种操作,将一个瓶灌满,讲一个瓶清空,然后就是将一个瓶网另一个瓶倒,直到到完或者到满。将昨天的代码稍微改了一下。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define inf 0x3f3f3f3f
#define mod 1000000007
typedef long long ll;
using namespace std;
const int N=210;
int n,dp[N],len;
int w[N][N];
int g[3];
int a,b,c;
int X,Y,K,M;
set<int>p;
int minn=inf;
struct man {
    int x,y;
    int step;
};

void bfs() {
    w[0][0]=1;
    queue<man>q;
    man s;
    s.x=0;
    s.y=0;
    s.step=0;
    q.push(s);
    while(!q.empty()) {
        man t=q.front();
        q.pop();
        minn=min(minn,abs((t.x+t.y)-M));
        if(t.step==K)continue;
        int f[3];
         f[0]=t.x;
            f[1]=t.y;
         if(!w[f[0]][0]){man kk;kk.x=f[0];kk.y=0;kk.step=t.step+1;w[f[0]][0]=1;q.push(kk);}
         if(!w[f[0]][g[1]]){man kk;kk.x=f[0];kk.y=g[1];kk.step=t.step+1;w[f[0]][g[1]]=1;q.push(kk);}
         if(!w[0][f[1]]){man kk;kk.x=0;kk.y=f[1];kk.step=t.step+1;w[0][f[1]]=1;q.push(kk);}
         if(!w[g[0]][f[1]]){man kk;kk.x=g[0];kk.y=f[1];kk.step=t.step+1;w[g[0]][f[1]]=1;q.push(kk);}
        for(int i=0; i<2; i++) {
            f[0]=t.x;
            f[1]=t.y;
            if(f[i]==0)continue;
            for(int j=0; j<2; j++) {
                f[0]=t.x;
                f[1]=t.y;
                man k;
                if(i==j||f[j]==g[j])continue;
                if(f[i]+f[j]>=g[j]) {
                    f[i]=f[i]-(g[j]-f[j]);
                    f[j]=g[j];
                    // printf("@%d %d\n",f[i],f[j]);
                } else if(f[i]+f[j]<g[j]) {
                    f[j]+=f[i];
                    f[i]=0;

                }
                k.x=f[0];
                k.y=f[1];
                // printf("!!!%d %d %d\n",k.x,k.y,k.z);
                if(w[k.x][k.y]==0) {
                        k.step=t.step+1;
                    q.push(k);
                    w[k.x][k.y]=1;
                }
            }
        }
    }
}

int main() {
    memset(w,0,sizeof(w));

    cin>>X>>Y>>K>>M;
    g[0]=X;
    g[1]=Y;
    bfs();
   cout<<minn<<endl;
    return 0;
}

时间: 2024-07-30 16:21:50

Milk Pails(BFS)的相关文章

USACO Mother&amp;#39;s Milk(bfs)

a=9MvljJDNdls&S=milk3">题目请点我 题解: 水杯倒水的问题非常经典,套路也是一样的,bfs找出全部状态. 这道题的关键在于每次都应该进行六次的倒水尝试,细心一点.PS:三维数组表示状态真的非常方便. 代码实现: /* ID: eashion LANG: C++ TASK: milk3 */ #include <iostream> #include <cstdio> #include <cstdlib> #include &l

USACO Mother&#39;s Milk(bfs)

题目请点我 题解: 水杯倒水的问题很经典,套路也是一样的,bfs找出所有状态.这道题的关键在于每次都应该进行六次的倒水尝试,细心一点.PS:三维数组表示状态真的很方便. 代码实现: /* ID: eashion LANG: C++ TASK: milk3 */ #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> #include <queue> #

pots(BFS)

D - Pots Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Submit Status Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: Input On the first and

USACO抓牛catchcow (bfs)

这题是黄巨大出的比赛题. http://poj.org/problem?id=3278 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤

hdu 1728 逃离迷宫 (BFS)

逃离迷宫 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 14376    Accepted Submission(s): 3458 Problem Description 给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方

牛汇(BFS)入金具体流程(图文指导)

牛汇开户流程:bfsforex牛汇入金教程 所谓入金,也就是充值的意思,必须充钱到平台才能进行外汇交易.首先,我们先登录bfsforex牛汇官方网站,在交易办公室功能区域下面,点击账户入金: 为您提供中国各大银行的网银支付解决方案,支持人民币支付,和信用卡入金,入金是实时到账的. 牛汇(BFS)入金具体流程(图文指导),布布扣,bubuko.com

URAL 1930 Ivan&#39;s Car(BFS)

Ivan's Car Time limit: 1.5 secondMemory limit: 64 MB The world is in danger! Awful earthquakes are detected all over the world. Houses are destroyed, rivers overflow the banks, it is almost impossible to move from one city to another. Some roads are

【判重+广搜(bfs)】魔板

判重+广搜(bfs)]魔板 Time Limit: 1000MS Memory Limit: 32768KB Special Judge 有一个两行四列的魔板,每个格子里有一个1到8的数字(数字唯一),现在我们可以对魔板进行以下操作: 1.交换两行的数字. 2.将第一列移到第二列,第二列到第三列,第三列到第四列,第四列到第一列. 3.将中间四个数顺时针转一次. 现给你初始状态,我末状态请你用最小的步数将它从初始状态变到末状态. 输入: 前两行,每行4个数表示初状态. 后两行,每行4个数表示末状态

[LeetCode] Binary Tree Zigzag Level Order Traversal(bfs)

Given a binary tree, return the zigzag level order traversal of its nodes' values. (ie, from left to right, then right to left for the next level and alternate between). For example: Given binary tree {3,9,20,#,#,15,7}, 3 / 9 20 / 15 7 return its zig