ACM学习历程——HDU5137 How Many Maos Does the Guanxi Worth(14广州10题)(单源最短路)

Problem Description

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don‘t have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.
   Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu‘s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu‘s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.
   You hate Boss Liu and you want to undermine Boss Liu‘s plan. All you can do is to persuade ONE person in Boss Liu‘s guanxi net to reject any request. This person can be any one, but can‘t be Boss Liu or the schoolmaster. If you can‘t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.

Input

There are several test cases.
   For each test case:
   The first line contains two integers N and M. N means that there are N people in Boss Liu‘s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N.   M means that there are M guanxis in Boss Liu‘s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)
   Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.
   The input ends with N = 0 and M = 0.
   It‘s guaranteed that Boss Liu‘s request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.

Sample Input

4 5

1 2 3

1 3 7

1 4 50

2 3 4

3 4 2

3 2

1 2 30

2 3 10

0 0

Sample Output

50

Inf

按照题目的意思,对点进行枚举,并单源最短路搜救可以了。注意判断条件即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>

using namespace std;

int n, m, d[31][31];
int dis[31];
bool vis[31];

void Input()
{
    memset(d, -1, sizeof(d));
    int a, b, c;
    for (int i = 0; i < m; ++i)
    {
        scanf("%d%d%d", &a, &b, &c);
        if (d[a][b] == -1 || d[a][b] > c)
            d[a][b] = d[b][a] = c;
    }
}

int SPFA(int x)
{
    memset(vis, 0, sizeof(vis));
    memset(dis, -1, sizeof(dis));
    dis[1] = 0;
    queue <int> q;
    q.push(1);
    int k;
    while (!q.empty())
    {
        k = q.front();
        q.pop();
        vis[k] = 0;
        for (int i = 2; i <= n; ++i)
        {
            if (d[k][i] == -1 || i == x)
                continue;
            if (dis[i] == -1 || dis[i] > dis[k] + d[k][i])
            {
                dis[i] = dis[k] + d[k][i];
                if (vis[i] == 0)
                {
                    q.push(i);
                    vis[i] = 1;
                }
            }
        }
    }
    return dis[n];
}

int qt()
{
    int ans, v;
    for (int i = 2; i < n; ++i)
    {
        v = SPFA(i);
        if (v == -1)
            return -1;
        if (i == 2)
            ans = v;
        else
            ans = max(ans, v);
    }
    return ans;
}

int main()
{
    //freopen("test.txt", "r", stdin);
    while (scanf("%d%d", &n, &m) != EOF && n && m)
    {
        Input();
        int ans = qt();
        if (ans == -1)
            printf("Inf\n");
        else
            printf("%d\n", ans);
    }
    return 0;
}
时间: 2024-10-12 06:41:05

ACM学习历程——HDU5137 How Many Maos Does the Guanxi Worth(14广州10题)(单源最短路)的相关文章

HDU 5137 How Many Maos Does the Guanxi Worth (14广州 Floyd 最短路)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 468    Accepted Submission(s): 164 Problem Description "Guanxi" is a very important word in Chinese. I

HDU5137 How Many Maos Does the Guanxi Worth (13广州现场赛K题 )--最短路问题

链接:click here 题意:从2~n-1这几个点中任意去掉一个点,使得从1到n的最短路径最大,如果任意去掉一个点1~n无通路输出Inf. 去年这道题现场是队友1A过的,感觉好NB,当时还不会最短路问题,只是脑子里大概有这么个印象,做了之发现数据比较水,今天看了一下Dijkstra 和Floyd,用两种算法实现了一下: 题目描述有点长,但是搞清楚了,就很容易了,因为数据实在很水,算是最短路入门训练的一道题了 Dijkstra 算法 (1)令S={源点s + 已经确定了最短路径的顶点vi} (

ACM学习历程—HDU 5023 A Corrupt Mayor&#39;s Performance Art(广州赛区网赛)(线段树)

Problem Description Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money. Becaus

HDU5137 How Many Maos Does the Guanxi Worth(枚举+dijkstra)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 760    Accepted Submission(s): 290 Problem Description "Guanxi" is a very important word in Chinese. It

ACM学习历程—HDU 5446 Unknown Treasure(数论)(2015长春网赛1010题)

Problem Description On the way to the next secret treasure hiding place, the mathematician discovered a cave unknown to the map. The mathematician entered the cave because it is there. Somewhere deep in the cave, she found a treasure chest with a com

ACM学习历程——HDU5017 Ellipsoid(模拟退火)(2014西安网赛K题)

---恢复内容开始--- Description Given a 3-dimension ellipsoid(椭球面) your task is to find the minimal distance between the original point (0,0,0) and points on the ellipsoid. The distance between two points (x 1,y 1,z 1) and (x 2,y 2,z 2) is defined as  Input

hdu5137 How Many Maos Does the Guanxi Worth(单源最短路径)

题目链接:点击打开链接 题目描述:现在有一张关系网,网中有n个结点标号为1-n,有m个关系,每个关系之间有一个权值.问从2-n-1中任意去掉一个结点之后,从1-n的距离中所有最小值的最大值为多少? 解题思路:多次调用Dijkstra即可,每次标记那个结点不通即可 代码: #include <cstdio> #include <queue> #include <cstring> #define MAXN 31 #define MAXE 1010 #define INF 1

ACM学习历程—HDU 4726 Kia&#39;s Calculation( 贪心&amp;&amp;计数排序)

DescriptionDoctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 12

ACM学习历程—UESTC 1226 Huatuo&#39;s Medicine(数学)(2015CCPC L)

题目链接:http://acm.uestc.edu.cn/#/problem/show/1226 题目就是构造一个对称的串,除了中间的那个只有1个,其余的两边都是对称的两个,自然答案就是2*n-1. 代码: #include <iostream> #include <cstdio> #include <cstdlib> #include <cmath> #include <cstring> #include <algorithm> #