HDU 1045 Fire Net(dfs,跟8皇后问题很相似)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14670    Accepted Submission(s): 8861

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

Source

Zhejiang University Local Contest 2001

题目意思:

就是给你一个地图,地图上有一些墙,向地图内放炮台,不要让两个炮台能互相射击到对方,

当然中间有墙就可以阻隔他们。求最多能放多少炮台。

分析:

如果放炮台,在该点设置一个炮台标记,

判断某一点是否可以放炮台,就是从该点向四个方向找,碰到墙停止,碰到别的炮台就返回0,表示该点不能放炮台。

code:

#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
using namespace std;
char G[5][5];
int n,sum;
bool check(int x,int y)
{
    if(G[x][y]==‘X‘)//该点是墙
        return false;
    for(int i=x;i<n;i++)//下
    {
        if(G[i][y]==‘X‘)
            break;
        if(G[i][y]==‘S‘)
            return false;
    }
    for(int i=x;i>=0;i--)//上
    {
        if(G[i][y]==‘X‘)
            break;
        if(G[i][y]==‘S‘)
            return false;
    }
    for(int j=y;j<n;j++)//右
    {
        if(G[x][j]==‘X‘)
            break;
        if(G[x][j]==‘S‘)
            return false;
    }
    for(int j=y;j>=0;j--)//左
    {
        if(G[x][j]==‘X‘)
            break;
        if(G[x][j]==‘S‘)
            return false;
    }
    return true;
}

void dfs(int x,int y,int num)
{
    if(x==n)
    {
        sum=max(sum,num);
        return ;
    }
    for(int j=y;j<n;j++)
    {
        if(check(x,j))
        {
            G[x][j]=‘S‘;
            dfs(x,j,num+1);
            G[x][j]=‘.‘;
        }
    }
    dfs(x+1,0,num);
}
int main()
{
    while(cin>>n,n)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>G[i][j];
            }
        }
        sum=0;
        dfs(0,0,0);
        cout<<sum<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/yinbiao/p/9359440.html

时间: 2024-08-09 22:01:58

HDU 1045 Fire Net(dfs,跟8皇后问题很相似)的相关文章

HDU 1045 Fire Net(DFS)

Fire Net Problem Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings t

hdu 1045 Fire Net DFS入门题

Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7012    Accepted Submission(s): 3975 Problem Description Suppose that we have a square city with straight streets. A map of a city is a

HDU 1045 - Fire Net (最大独立集)

题意:给你一个正方形棋盘.每个棋子可以直线攻击,除非隔着石头.现在要求所有棋子都不互相攻击,问最多可以放多少个棋子. 这个题可以用搜索来做.每个棋子考虑放与不放两种情况,然后再判断是否能互相攻击来剪枝.最后取可以放置的最大值. 这里我转化成求最大独立集来做. 首先将每个空地编号,对于每个空地,与该位置可以攻击到的空地连边.找最多的空地使得不互相攻击,即求该图的最大独立集.与搜索做法基本一致,但是说法略有不同. 1 #include<iostream> 2 #include<cstring

HDU 1045 Fire Net 贪心

Problem Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings through wh

HDU 1045——Fire Net——————【最大匹配、构图、邻接矩阵做法】

Fire Net Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1045 Description Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, e

hdu 1045 Fire Net(最小覆盖点+构图(缩点))

http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1045 Description Suppose that we have a square city with straight streets. A map of a city

HDU 1045 Fire Net 状压暴力

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045 Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8073    Accepted Submission(s): 4626 Problem Description Suppose that we have a squar

HDU 1045 Fire Net【DFS深搜】

Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9880    Accepted Submission(s): 5739 Problem Description Suppose that we have a square city with straight streets. A map of a city is a

HDU - 1045 Fire Net (dfs 或 二分图)

题意:给出一个不会超过4x4的mapmap中有墙,以及空白处.然后你要在空白处放置尽可能多的炮台炮台对向四周发射子弹,即(炮台不能放在同一行或者列除非有强阻挡)思路:首先想到了dfs枚举(就像八皇后一样回溯法),我们尽可能多的在一行一行的放置.关于放置搜索的问题,我们判断是否合法关于二分图匹配(完全没有想出来怎么匹配..)在网上看了别人的题解才懂由于同行或者同列不能多个放置(即每行每列只能放一个除了有墙挡)然后就是建图:将每行每列连续的部分缩成一个点如图:(画的真的丑...) 我们然后这就有连接