hdu 5288 OO’s Sequence 分解因子

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288

OO’s Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 588    Accepted Submission(s): 209

Problem Description

OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there‘s no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know

∑i=1n∑j=inf(i,j) mod (109+7).

Input

There are multiple test cases. Please process till EOF.

In each test case:

First line: an integer n(n<=10^5) indicating the size of array

Second line:contain n numbers ai(0<ai<=10000)

Output

For each tests: ouput a line contain a number ans.

Sample Input

5
1 2 3 4 5

Sample Output

23

题意:

本来的题意问  枚举所有i,j ,1<=i<=j<=n,  然后计算f(i,j)和是多少。

f(l,r)的值 是 输入的数组下标 l到r中有多少 数是无法被这个区间 任意一个数整除的。

做法:

转换种思想就是 某个数num[i],在多少个区间内 可以不被区间其他任何数整除。  答案加上区间个数。

所以 可以左右两边枚举过来。

以左边枚举过来为例:

把最近出现的数 记录下来,记录到 has数组。   如num[i]      记录成has[num[i]]=i

然后把每个数的因子枚举,判断最近左边出现因子在哪。  然后那个位子+1 就是左端点了。

在同样处理出右端点, 左右端点知道就很容易算出num[i]在多少区间内符合要求 加到ans里。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
#include <set>
using namespace std;

int num[100010];

int zuo[100010];

int you[100010];

int has[10010];
int Scan()
{
    int res = 0, ch, flag = 0;

    if((ch = getchar()) == '-')                //判断正负
        flag = 1;

    else if(ch >= '0' && ch <= '9')            //得到完整的数
        res = ch - '0';
    while((ch = getchar()) >= '0' && ch <= '9' )
        res = res * 10 + ch - '0';

    return flag ? -res : res;
}

vector<int>my[10010];

int main()
{
    int n;

    for(int i=1;i<=10000;i++)
    {
        for(int j=1;j<=i;j++)
        {
            if(i%j==0)
            {
                my[i].push_back(j);
            }
        }
        //printf("%d\n",my[i].size());
    }

    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            //scanf("%d",&num[i]);
            //num[i]=min(10000,i);
            num[i]=Scan();
        }

        memset(zuo,-1,sizeof zuo);
        memset(you,-1,sizeof you);
        /*
        memset(has,0,sizeof has);

        for(int i=1;i<=n;i++)
        {
            if(has[num[i]]!=0)
                zuo[i]=has[num[i]]+1;//左边最近被整除
            has[num[i]]=i;
        }
        memset(has,0,sizeof has);
        for(int i=n;i>=1;i--)
        {
            if(has[num[i]]!=0)
                you[i]=has[num[i]]-1;//左边最近被整除
            has[num[i]]=i;
        }
        */
        memset(has,0,sizeof has);
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<my[num[i]].size();j++)
            {
                int tt=my[num[i]][j];
                if(has[tt])
                {
                    if(num[i]%tt==0)
                    {
                        if(zuo[i]!=-1)
                            zuo[i]=max(zuo[i],has[tt]+1);
                        else
                            zuo[i]=has[tt]+1;
                    }
                }
            }
            has[num[i]]=i;
        }

        memset(has,0,sizeof has);
        for(int i=n;i>=1;i--)
        {
            for(int j=0;j<my[num[i]].size();j++)
            {
                int tt=my[num[i]][j];
                if(has[tt])
                {
                    if(num[i]%tt==0)
                    {
                        if(you[i]!=-1)
                            you[i]=min(you[i],has[tt]-1);
                        else
                            you[i]=has[tt]-1;
                    }
                }
            }
            has[num[i]]=i;
        }

        for(int i=1;i<=n;i++)
        {
            if(zuo[i]==-1)
                zuo[i]=1;

            if(you[i]==-1)
                you[i]=n;
            //printf("zz%d yy%d\n",zuo[i],you[i]);
        }

    //    puts("-----------");
        __int64 ans=0;
        for(int i=1;i<=n;i++)
        {
            __int64 l,r;
            l=(__int64)(i-zuo[i]+1);
            r=(__int64)(you[i]-i+1);

            //printf("zz%d yy%d\n",l,r);
            ans=(ans+l*r)%1000000007;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-06 17:38:35

hdu 5288 OO’s Sequence 分解因子的相关文章

HDU 5288 OO’s Sequence (暴力枚举因子)

题目链接:HDU 5288 OO's Sequence 题意:给出一个n,表示n个数的序列,函数f(l,r)定义,在l,r区间中存在多少个数,不能被其他数整除.求累加所有子区间的函数值 思路:从ai的小范围入手 1.a不能被b整除,即a的所有因子中不存在b,所以打表枚举所有的数的因子. 2.找到一个数(位置为i)满足条件时最左端l和最右端r,(i-l)*(r-i)就是对答案的贡献. AC代码: #include <stdio.h> #include <algorithm> #inc

HDU 5288 OO&#39;s sequence (2015多校第一场 二分查找)

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 955    Accepted Submission(s): 358 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the nu

hdu 5288 OO’s Sequence

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know ∑(i=1->n)∑(j=i

HDU 5288 OO‘s sequence

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 题面: OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 985    Accepted Submission(s): 375 Problem Description OO has got a array

Hdu 5288 OO’s Sequence 2015多小联赛A题

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1751    Accepted Submission(s): 632 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the n

HDU 5288 OO’s Sequence(多校第一场1001)

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 900    Accepted Submission(s): 339 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the nu

hdu 5288 OO’s Sequence(2015多校第一场第1题)枚举因子

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 题意:在闭区间[l,r]内有一个数a[i],a[i]不能整除 除去自身以外的其他的数,f(l,r)表示在这区间内a[i]这样的数的个数,,现给你n个数,求所有区间的f(l,r)的和. 思路:对于每个数a[i]求出他的左右侧最靠近他的且是他的因子的位置L.R,并记录,那么对于每个数a[i]都有了他的L,R,而对于每个a[i]在f(l,r)有价值的次数之和就是(i-L+1)*(R-i+1) 代码:

HDU 5288 OO’s Sequence(数学啊 多校2015)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to kn

hdu 5288 OO’s Sequence(计数)

Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know ∑i=1n∑j=inf(i,j) mod (109+7). Input There are mul