PAT 1079. 延迟的回文数

PAT 1079. 延迟的回文数

给定一个 k+1 位的正整数 N,写成 ak...a1a0 的形式,其中对所有 i 有 0 <= ai < 10 且 ak > 0。N 被称为一个回文数,当且仅当对所有 i 有 ai = ak-i。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number

给定任意一个正整数,本题要求你找到其变出的那个回文数。

输入格式:

输入在一行中给出一个不超过1000位的正整数。

输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下

A + B = C
其中A是原始的数字,B是A的逆转数,C是它们的和。A从输入的整数开始。重复操作直到C在10步以内变成回文数,这时在一行中输出“C is a palindromic number.”;或者如果10步都没能得到回文数,最后就在一行中输出“Not found in 10 iterations.”。

输入样例 1:

97152

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

输入样例 2:

196

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

分析

题目不难,注意一下,若题目给出的数本来就是回文数字,则输出“xxxxxx is a palindromic number. ”

代码如下

#include<iostream>
#include<algorithm>
using namespace std;
string pal(string a){
    string b,s;
    b.resize(a.size());
    copy(a.rbegin(),a.rend(),b.begin()); // 利用反向迭代器和copy快速得到其反转数字
    int t=0,n; char c;
    for(int i=a.size()-1;i>=0;i--){ // 将数字和其反转数字相加
        int n=(a[i]-'0'+b[i]-'0'+t)%10;
        t=(a[i]-'0'+b[i]-'0'+t)/10;
        c='0'+n;
        s.insert(s.begin(),1,c);
    }
    if(t){
    c='0'+t;
    s.insert(s.begin(),1,c);
    }
    cout<<a<<" + "<<b<<" = "<<s<<endl;
    return s;
}
int main(){
    string s;
    cin>>s; int cnt=0;
    while(1){
        int flag=0;
        for(int i=0;i<=(s.size()-1)/2;i++){ // 判断是否是回文数字
        if(s[i]!=s[s.size()-1-i])
        flag=1;
        }
        if(flag==0){
            cout<<s<<" is a palindromic number.";
            break;
        }else if(flag==1&&cnt==10){
            cout<<"Not found in 10 iterations.";
            break;
        }
        s=pal(s); cnt++;
    }
    return 0;
} 

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8150244.html

时间: 2024-10-08 20:23:15

PAT 1079. 延迟的回文数的相关文章

PTA乙级(1079 延迟的回文数 (20分))

1079 延迟的回文数 (20分) https://pintia.cn/problem-sets/994805260223102976/problems/994805261754023936 1 #include <cstdio> 2 #include <cstring> 3 #include <string> 4 #include <iostream> 5 #include <algorithm> 6 #include <cmath>

1079 延迟的回文数 (20 分)

#include <bits/stdc++.h> using namespace std; #define ll long long string turn(string s) { reverse(s.begin(),s.end()); return s; } string add(string a,string b) { string c = a; int m = 0; for(int i = a.size()-1;i>=0;i--) { c[i] = (a[i]-'0'+b[i]-'

B1079 延迟的回文

给定一个 k+1 位的正整数 N,写成 a?k???a?1??a?0?? 的形式,其中对所有 i 有 0 且 a?k??>0.N 被称为一个回文数,当且仅当对所有 i 有 a?i??=a?k−i??.零也被定义为一个回文数. 非回文数也可以通过一系列操作变出回文数.首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现.如果一个非回文数可以变出回文数,就称这个数为延迟的回文数.(定义翻译自 https://en.wikipedia.org/

shu_1180 回文数(一)

http://202.121.199.212/JudgeOnline/problem.php?cid=1079&pid=21 分析: 回文串判断,字符串处理 1. atoi 函数(ascii tointeger 将字符串转换成整型数) 头文件: #include <stdlib.h> int atoi(const char *nptr): 由于程序中使用string类,所以应该用 str.c_str() 将string转为c语言下的字符串数组. 2. itoa函数(与atoi功能相反)

判断一个数是否为回文数

#include <stdio.h> int is_palindromic(int num) {  char _old = num;  char _new = 0;  while (num)  {   _new = _new * 10 + (num % 10);   num = num / 10;  }  if (_new == _old)  {   return 1;  }  else  {   return 0;  } } int main() {  int num = 0;  scanf

LeetCode 9 Palindrome Number (回文数)

翻译 确定一个整数是否是回文数.不能使用额外的空间. 一些提示: 负数能不能是回文数呢?(比如,-1) 如果你想将整数转换成字符串,但要注意限制使用额外的空间. 你也可以考虑翻转一个整数. 然而,如果你已经解决了问题"翻转整数(译者注:LeetCode 第七题), 那么你应该知道翻转的整数可能会造成溢出. 你将如何处理这种情况? 这是一个解决该问题更通用的方法. 原文 Determine whether an integer is a palindrome. Do this without ex

要求循环输入一个数,判断是否为回文数

import java.util.Scanner; public class HuiWenShu { public static void main(String[] args) { Scanner input = new Scanner(System.in); char c = 'y'; //初始化c为y,为下面的循环做好准备 while(c == 'y'){ while(c == 'y'){ System.out.println("请随意输入一个大于三位的奇位数"); //回文数属

回文数 第N个回文数

判断回文数还是不难,如果能转为字符串就更简单了. 如果是求第N个回文数呢. 12321是一个回文数,这里先考虑一半的情况. 回文数的个数其实是有规律的.如: 1位回文数: 9个 2位回文数: 9个 3位回文数: 90个 4位回文数: 90个 5位回文数: 900个 6位回文数: 900个 … 我们看到9.90.900,是不是很有规律,那是什么原因?很简单,我们把回文数拆开两半 [123321]来看.两半的变化一样的,那我们只算其中一半就行了.首位不能是0,所以左半最小为 100,最大为999,共

Palindrome Number (回文数)

回文数是指这样的数字:正读和倒读都是一样的.如:595,2332都是回文数,234不是回文数. 注意:负数不是回文数 Determine whether an integer is a palindrome. Do this without extra space. Some hints: Could negative integers be palindromes? (ie, -1) If you are thinking of converting the integer to string