POJ3624 Charm Bracelet 【01背包】

Charm Bracelet

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22621   Accepted: 10157

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1
≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

题意:给定物品数量n和背包容量m,n个物品的重量weight和价值val,求能获得的最大价值。

题解:状态转移方程:dp[i][j] = max(dp[i-1][j], dp[i-1][j-w[i]] + v[i]);其中状态dp[i][j]表示前i个物品放在容量为j的背包中能获得的最大价值。二维数组可以压缩成一维以节省空间,但是内层循环需要倒序。

原始版本:耗时360ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight) dp[j] = max(dp[j], dp[j - weight] + val);
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}<span style="font-family:FangSong_GB2312;">
</span>

优化后的代码:耗时219ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight && dp[j - weight] + val > dp[j])
				dp[j] = dp[j - weight] + val;
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}

用二维dp数组写了一个,果断的超了内存,占用内存大概12882*3404*4/1024=171兆,题目限制是65兆

TLE:

#include <stdio.h>
#define maxn 12882

int dp[3404][maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, m, weight, val, i, j;
    scanf("%d%d", &n, &m);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = 1; j <= m; ++j)
            if(j >= weight)
                dp[i][j] = max(dp[i-1][j], dp[i-1][j-weight] + val);
            else dp[i][j] = dp[i-1][j];
    }
    printf("%d\n", dp[n][m]);
    return 0;
}
时间: 2024-08-07 12:31:02

POJ3624 Charm Bracelet 【01背包】的相关文章

poj3624 Charm Bracelet(0-1背包 滚动数组)

题目链接:https://vjudge.net/problem/POJ-3624 题意:有N个物品,分别有不同的重量Wi和价值Di,Bessie只能带走重量不超过M的物品,要是总价值最大,并输出总价值. 一开始使用正常的dp然后显示超内存,按下面代码也超内存(dp数组太大了)但这种方法可以学习一下 #include <iostream> #include <cstring> using namespace std; int n,m; //int w[3403],d[12881];

POJ 3624 Charm Bracelet(01背包裸题)

Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 38909   Accepted: 16862 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible fro

POJ 3624 Charm Bracelet (01背包)

Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 26078   Accepted: 11726 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible fro

[USACO07DEC]手链Charm Bracelet——01背包

题目描述 Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400),

POJ - 3624 Charm Bracelet (01背包基础)

题意: 即是给你一个容量M的包,有N件物品,每件物品有分别对应的 价值value 以及 重量weight .然后在不超过该背包容量的情况下能得到的最大价值为多少? 思路: 由于这是最基础的问题,所以就记录当对 01背包状态转移方程式的 理解. 对于动态规划来说,首先要知道我们要确定哪些状态量.然后再基于这些状态量进行状态转移得到我们最后希望得到的答案. 比如对于序列求最值来说我们习惯记录最后位取的是谁(即末位j),那么同理我们也可以记录我们当前选的是哪一种 物品.同时容量在状态中是必不可少的,所

poj3642 Charm Bracelet(0-1背包)

题目意思: 给出N,M,N表示有N个物品,M表示背包的容量,接着给出每个物品的体积和价值,求背包能够装在的最大价值. http://poj.org/problem?id=3624 题目分析: o-1背包问题,转化方程.dp[j]:表示容量为j的时候,背包的最大价值 dp[j]=max(dp[j],dp[j-w[i]]+d[i]); AC代码: #include<iostream> #include<cstring> using namespace std; int dp[20000

Charm Bracelet(poj3624)(01背包)

Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 24165   Accepted: 10898 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible fro

POJ3624 Charm Bracelet(典型01背包问题)

Time Limit: 1000MS          Memory Limit: 65536K          Total Submissions: 32897          Accepted: 14587 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms poss

Charm Bracelet-POJ3624(01背包)

http://poj.org/problem?id=3624 Charm Bracelet Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 29444   Accepted: 13198 Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it wi