杭电 1242 Rescue(广搜)

http://acm.hdu.edu.cn/showproblem.php?pid=1242

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15597    Accepted Submission(s): 5663

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel‘s friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there‘s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel‘s friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor
ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

刚开始看到这个题的时候觉得用模板就行啦,不算难,可是敲出代码提交一直错,真心一下子想不通,想我这样脾气暴躁的人,简直要被气死了。

AC代码(一):用广搜模板做的,侥幸AC。

#include<iostream>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
#define max 201

char a[max][max];
int move[4][2]={-1,0,1,0,0,1,0,-1},v[max][max];//移动方向排列在这里很重要。
int n,m,ans;
struct node
{
    int x,y,step;
};

void bfs(int i,int j)
{
    queue<node>q;
    node now,next;
    now.x=i;
    now.y=j;
    v[now.x][now.y]=1;
    now.step=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(a[now.x][now.y]=='r')
        {
            ans=now.step;
            return ;
        }
        else
        {
            for(int t=0;t<4;t++)
            {
                next.x=now.x+move[t][0];
                next.y=now.y+move[t][1];
                if(!v[next.x][next.y]&&a[next.x][next.y]!='#'&&next.x>=0&&next.x<n&&next.y>=0&&next.y<m)
                {
                    v[next.x][next.y]=1;
                    if(a[next.x][next.y]=='.'||a[next.x][next.y]=='r')
                        next.step=now.step+1;
                    else
                        if(a[next.x][next.y]=='x')
                            next.step=now.step+2;
                        q.push(next);
                }
            }
        }

    }
    return ;
}

int main()
{
    int i,j;
    while(cin>>n>>m)
    {
        ans=0;
        memset(v,0,sizeof(v));
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                cin>>a[i][j];
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(a[i][j]=='a')
                    bfs(i,j);
            }
        }
            if(ans)
                cout<<ans<<endl;
            else
                cout<<"Poor ANGEL has to stay in the prison all his life.\n";
    }
    return 0;
}

AC代码(二):用优先队列做的,比上一个靠谱些。

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

#define M 205
char c[M][M];
int v[M][M];
int w[4][2]={-1,0,0,-1,0,1,1,0};
int ans,n,m;

struct node
{
	int x,y,time;
	friend bool operator< (const node a,const node b)
	{
		return a.time>b.time;
	}
};

void bfs(int a,int b)
{
	node now,tmp;
	priority_queue<node>   q;
	now.time=0;
	now.x=a;
	now.y=b;
	memset(v,0,sizeof(v));
	v[a][b]=1;
	q.push(now);

	while(!q.empty())
	{
		now=q.top();
		q.pop();
		if(c[now.x][now.y]=='r')
		{
			ans=now.time;
			return ;
		}

		for(int i=0;i<4;i++)
		{
			tmp.x=now.x+w[i][0];
			tmp.y=now.y+w[i][1];
			if(tmp.x>=0&&tmp.x<n&&tmp.y>=0&&tmp.y<m
				&&!v[tmp.x][tmp.y]&&c[tmp.x][tmp.y]!='#')
			{
				v[tmp.x][tmp.y]=1;
				if(c[tmp.x][tmp.y]=='r'||c[tmp.x][tmp.y]=='.')
					tmp.time=now.time+1;
				if(c[tmp.x][tmp.y]=='x')
					tmp.time=now.time+2;
				q.push(tmp);
			}
		}
	}
	return;
}

int main()
{
	while(cin>>n>>m)
	{
		int i,j,x,y;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				cin>>c[i][j];
				if(c[i][j]=='a')
					x=i,y=j;
			}

		ans=0;
		bfs(x,y);
		if(ans)
			cout<<ans<<endl;
		else
			cout<<"Poor ANGEL has to stay in the prison all his life.\n";
	}

	return 0;
}

杭电 1242 Rescue(广搜),布布扣,bubuko.com

时间: 2024-10-24 21:29:24

杭电 1242 Rescue(广搜)的相关文章

A计划 HDU杭电2102【广搜+STL队列】

Problem Description 可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验.魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老.年迈的国王正是心急如焚,告招天下勇士来拯救公主.不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出. 现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示.骑士们一进入时空传输机就会被转到另一层的相对位

杭电ACM1242——Rescue~~BFS+优先队列

这题,简单的BFS就可以搞定.题目的大概意思是最短时间从地图的r到达a. 一开始,用普通的队列来做,结果内存超了,原因是N和M最大200:普通的队列会浪费一大堆内存,所以应该改用优先队列来做. 下面是AC的代码: #include <iostream> #include <queue> #include <cstdio> using namespace std; class data { public: int x, y, cost; friend bool opera

hdu 1242:Rescue(BFS广搜 + 优先队列)

Rescue Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 14   Accepted Submission(s) : 7 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Angel was caught by the MOLIGPY

杭电 1372 Knight Moves(广搜模板题)

http://acm.hdu.edu.cn/showproblem.php?pid=1372 Knight Moves Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6439    Accepted Submission(s): 3886 Problem Description A friend of you is doing res

杭电ACM1312——Red and Black~~广搜

这一题,简单的广搜或者深搜都可以搞定,时间复杂度都差不多. 我用的是广搜.题目的意思是:@是一个人的起始位置,#不可以走,. 可以走,求出可以走的位置的个数. 一开始没有用结构体来存储坐标,直接用的是z = x * 10 + y:将z入队,结果错了,原因是在取余整除的时候会出错.改用结构体就OK了. 下面是AC的代码: #include <iostream> #include <queue> #include <cstdio> using namespace std;

杭电 1518 Square (深搜)(回溯)

http://acm.hdu.edu.cn/showproblem.php?pid=1518 Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8343    Accepted Submission(s): 2706 Problem Description Given a set of sticks of various

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

杭电1253 胜利大逃亡

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24756    Accepted Submission(s): 9478 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的