hdoj 2122 Ice_cream’s world III

并查集+最小生成树

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1121    Accepted Submission(s):
365

Problem Description

ice_cream’s world becomes stronger and stronger; every
road is built as undirected. The queen enjoys traveling around her world; the
queen’s requirement is like II problem, beautifies the roads, by which there are
some ways from every city to the capital. The project’s cost should be as less
as better.

Input

Every case have two integers N and M (N<=1000,
M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following
N lines, each line contain three integers S, T and C, meaning S connected with T
have a road will cost C.

Output

If Wiskey can’t satisfy the queen’s requirement, you
must be output “impossible”, otherwise, print the minimum cost in this project.
After every case print one blank.

Sample Input

2 1

0 1 10

4 0

Sample Output

10

impossible

kruskal算法

#include<stdio.h>
#include<algorithm>
using namespace std;
int set[1100];
struct record
{
	int beg;
	int end;
	int money;
}s[11000];
int find(int fa)
{
	int ch=fa;
	int t;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[ch];
		set[ch]=fa;
		ch=t;
	}
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	set[fx]=fy;
}
bool cmp(record a,record b)
{
	return a.money<b.money;
}
int main()
{
	int n,m,j,i,sum,village,road;
	while(scanf("%d%d",&village,&road)!=EOF)
	{

		for(i=0;i<village;i++)
		set[i]=i;
		for(i=0;i<road;i++)
		{
			scanf("%d%d%d",&s[i].beg,&s[i].end,&s[i].money);
		}
		sort(s,s+road,cmp);
		sum=0;
		for(i=0;i<road;i++)
		{
		    if(find(s[i].beg)!=find(s[i].end))
		    {
		    	mix(s[i].beg,s[i].end);
		    	sum+=s[i].money;
		    }
		}
		m=0;
		for(i=0;i<village;i++)
		{
			if(set[i]==i)
			m++;
		}
		if(m>1)
		printf("impossible\n\n");
		else
		printf("%d\n\n",sum);
	}
	return 0;
}

  

时间: 2024-08-29 07:50:10

hdoj 2122 Ice_cream’s world III的相关文章

hdoj 2122 Ice_cream’s world III 【最小生成树】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1254    Accepted Submission(s): 414 Problem Description ice_cream's world becomes stronger and stronger; every road is buil

hdoj 2122 Ice_cream’s world III【最小生成树】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1237    Accepted Submission(s): 408 Problem Description ice_cream's world becomes stronger and stronger; every road is buil

hdu 2122 Ice_cream’s world III(最小生成树)

感觉就是 畅通工程的改版 直接贴代码了 #include<stdio.h> #include<string.h> #include<math.h> #include<iostream> #include<algorithm> #include<queue> #include<stack> #define mem(a,b) memset(a,b,sizeof(a)) #define ll __int64 #define MA

HDU - 2122 Ice_cream’s world III

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2122 最小生成树问题,可采用Kruskal算法,贪心策略,每次选取无向带权图的最短边,并把两端点用 并查集的方式添加到一个集合内. 1 #include<stdio.h> 2 #include<string.h> 3 #include<algorithm> 4 const int maxn=1000+5,maxm=10000+10; 5 int u[maxm],v[maxm

HDU 2122 Ice_cream’s world III【最小生成树】

解题思路:基础的最小生成树反思:不明白为什么i从1开始取,就一直WA,难道是因为村庄的编号是从0开始的吗 Ice_cream’s world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1032    Accepted Submission(s): 335 Problem Description ice_cream’s wo

hdu 2122(Ice_cream’s world III)(最小生成树,两种算法都可以)

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 926    Accepted Submission(s): 303 Problem Description ice_cream's world becomes stronger and stronger; every road is built

A - Ice_cream’s world III

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 2122 Description ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world;

HDU2122 Ice_cream’s world III【Kruskal】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 997    Accepted Submission(s): 321 Problem Description ice_cream's world becomes stronger and stronger; every road is built

hdoj 2120 Ice_cream&#39;s world I

Ice_cream's world I Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 741    Accepted Submission(s): 429 Problem Description ice_cream's world is a rich country, it has many fertile lands. Today,