GNS3 配置Static p2p GRE over IPsec

1、实验拓扑

2、基础网络配置

R1配置:

interface FastEthernet0/0

ip address 12.1.1.1 255.255.255.0

interface FastEthernet1/0

ip address 13.1.1.1 255.255.255.0

R2配置:

interface FastEthernet0/0

ip address 12.1.1.2 255.255.255.0

interface FastEthernet1/0

ip address 172.16.1.254 255.255.255.0

ip route 0.0.0.0 0.0.0.0 12.1.1.1

R3配置:

interface FastEthernet0/0

ip address 13.1.1.3 255.255.255.0

interface FastEthernet1/0

ip address 192.168.1.254 255.255.255.0

ip route 0.0.0.0 0.0.0.0 13.1.1.1

R4配置:

interface FastEthernet0/0

ip address 172.16.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.1.254

R5配置:

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.254

3、配置Static p2p GRE over IPsec

3.1、配置GRE

R2配置:

interface Tunnel2

ip address 1.1.1.1 255.255.255.0

tunnel source 12.1.1.2

tunnel destination 13.1.1.3

R3配置:

interface Tunnel3

ip address 1.1.1.2 255.255.255.0

tunnel source 13.1.1.3

tunnel destination 12.1.1.2

3.2、配置LAN-TO-LAN VPN(此时的ACL与普通的LAN-TO-LAN VPN有差异)

R2配置:

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key cisco123 address 13.1.1.3

crypto ipsec transform-set ccie esp-3des esp-sha-hmac

access-list 100 permit gre host 12.1.1.2 host 13.1.1.3

crypto map mymap 1 ipsec-isakmp

set peer 13.1.1.3

set transform-set ccie

match address 100

interface FastEthernet0/0

crypto map mymap

R3配置:

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key cisco123 address 12.1.1.2

crypto ipsec transform-set ccie esp-3des esp-sha-hmac

access-list 100 permit gre host 13.1.1.3 host 12.1.1.2

crypto map mymap 1 ipsec-isakmp

set peer 12.1.1.2

set transform-set ccie

match address 100

interface FastEthernet0/0

crypto map mymap

3.3、配置动态路由协议(此时私网流量走的都是隧道。)

R2配置:

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 172.16.1.0 0.0.0.255 area 0

R3配置:

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

4、NAT对Static p2p GRE over IPsec的影响

通过上面得知,内网流量走的都是GRE隧道,所以,当NAT应用在物理口时对Static p2p GRE over IPsec是没有影响的。但当NAT应用在Tunnel口时,必须将内网网段排除。

时间: 2024-10-12 17:09:59

GNS3 配置Static p2p GRE over IPsec的相关文章

GNS3 配置Dynamic p2p GRE over IPsec

1.实验拓扑 2.基础网络配置 R1配置: ip dhcp excluded-address 13.1.1.1 13.1.1.2 ip dhcp pool net13 network 13.1.1.0 255.255.255.0 default-router 13.1.1.1 interface FastEthernet0/0 ip address 12.1.1.1 255.255.255.0 interface FastEthernet1/0 ip address 13.1.1.1 255.2

Dynamic P2P GRE over IPsec

R1(config)#int f0/0 R1(config-if)#ip add 12.1.1.1 255.255.255.0 R1(config-if)#no sh R1(config-if)#exit R1(config)#int f0/1 R1(config-if)#ip add 10.1.1.1 255.255.255.0 R1(config-if)#no sh R1(config-if)#exit R1(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.2

P2P GRE over IPsec

R1(config)#interface tunnel 1 R1(config-if)#ip address 1.1.1.1 255.255.255.0 R1(config-if)#tunnel source 12.1.1.1 R1(config-if)#tunnel destination 23.1.1.3 R1(config-if)#exit R3(config)#int tunnel 3 R3(config-if)#ip address 1.1.1.3 255.255.255.0 R3(c

VPN技术:GRE Over IPSEC

普通的IPSEC VPN主要适用于不同厂家VPN之间的对接,兼容性非常好,IOS路由器和ASA可以和大部分的非思科厂家的VPN设备进行IPSEC VPN对接.然而,这种普通的IPSEC VPN并不适用于复杂的网络环境,主要存在如下问题: 由于没有虚拟隧道接口,不支持通过运行动态路由协议来实现路由互通: 由于没有虚拟隧道接口,不能对通信点之间的明文流量进行控制和监测(如ACL.QOS.NAT.Netflow等): 操作较多,每增加一个站点或网段,都要增加许多感兴趣流,排错复杂. 为了解决普通IPS

Cisco路由器配置GRE over IPsec

拓扑图 实验目的: 通过CRE over IPsec的方式实现R1网段:172.16.10.0/24和R2网段:172.17.10.0/24通信加密. 由于IPsec VPN不支持组播,而GRE支持多种协议,所以一般情况下会选择GRE over IPsec. 配置思路: 通过ACL设置感兴趣流 配置IKE第一阶段 配置IKE第二阶段 新建MAP,并应用于接口 设置路由,下一跳为tunnel 0 配置: R1: 配置接口IP信息 interface Loopback0  ip address 17

GRE OVER IPSEC过程解析

一,产生背景 IPsec是如今十分主流的分支机构互联VPN协议,其本身强大的加密与验证功能保障了在互联网传递时私网数据的安全,但是面对当前多元化的访问需求,Ipsec VPN并不能满足客户对私网网段之间复杂的互访要求:在实际环境中,分隔两地的机构要求通过VPN隧道建立私网之间的路由邻居关系,而Ipsec VPN本身并不具备传递路由的能力,所以GRE over IPSEC技术应运而生. 二,基本原理 我们知道,传统的IPsec VPN针对数据包的安全性要求,通常采用采用两种协议进行数据包封装:AH

【DCN】Gre over ipsec vpn

流量被加密的过程: 首先数据包进入路由器,路由器查询路由表,进入Tu0,数据被GRE封包,再次查询路由表,到物理接口,触发加密图,数据加密,再送出路由器. GRE OVER  IPSEC VPN 的出现解决了IPSEC VPN不能加密组播及广播报文的问题使得IPSEC VPN不能在动态路由协议中得到应用,而使用GRE OVER IPSEC VPN的好处就是GRE能够很好的封闭组播及广播流量,再被IPSEC VPN加密传输使得这一方案得到广泛应用. GRE OVER IPSEC VPN 的ACL表

CCIE学习笔记 ----GRE over IPsec

GRE over IPsec 这种东西主要可以传nat和各种加密包头的东西 R1: ! interface Ethernet0/0 ip address 192.168.12.1 255.255.255.0 ip ospf 1 area 0 --------------------------------------------------------------------------------- R2: crypto isakmp policy 10 authentication pre-

用Mikrotik Router搭建GRE over IPSec 备用链路

公司在国内.日本.美国.德国.新加坡等多地均有业务,中间业务网络用的公司专有GPN(Global Private Network中文名是全球私有化网络)链路,目前测试搭建一条备用链路,用于网络冗余和故障切换. 初步选用方案GRE over IPSec,跑ospf路由协议. 一.为何要选GRE over IPSec: 各个site网络比较多,需要使用路由协议进行互联: IPSEC不支持组播,即不能传递路由协议,在承载路由协议上不如GRE隧道方便: GRE隧道不能提供加密保障: 使用GRE在两个网关