背包 [HDU 1963] Investment

由于HDU上这个题目显示有问题,不好复制,所以从虚拟OJ上复制了

Investment

Time Limit:10000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

John never knew he had a grand-uncle, until he received the notary??s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.

John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:

Value Annual interest
4000 400
3000 250

With a capital of 10000 one could buy two bonds of 4000, giving a yearly interest of 800. Buying two bonds of 3000, and one of 4000 is a better idea, as it gives a yearly interest of 900. After two years the capital has grown to 11800, and it makes sense to sell a 3000 one and buy a 4000 one, so the annual interest grows to 1050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is 12850, which allows for three times 4000, giving a yearly interest of 1200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most 1000000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of 1000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output ?C on a separate line ?C the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

多重背包模板题

进行N次(N表示多少年)多重背包即可,注意除以1000压缩空间、见代码- -

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100010

int w[N];
int v[N];
int dp[N];

int main()
{
    int T,n,s,time,i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&s,&time,&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            w[i]/=1000; //由于都是1000的倍数,所以同时除以1000压缩空间
        }
        int val=s;
        while(time--) //time次完全背包即可
        {
            s/=1000; //为什么可以这样?因为就算是整数除法,截去了百位数,但是由于价钱都是1000的倍数,所以几百元也买不起
            memset(dp,0,sizeof(dp));
            for(i=1;i<=n;i++)
            {
                for(j=w[i];j<=s;j++)
                {
                    dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
                }
            }
            val+=dp[s]; //答案加上这一年的利息
            s=val;    //更新本金
        }
        cout<<val<<endl;
    }
    return 0;
}
时间: 2024-08-04 08:19:26

背包 [HDU 1963] Investment的相关文章

hdu 1963 Investment 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1963 题目意思:有 本金 money,还有一些股票的种类,第 i 种股票买入需要 value[i] 这么多钱,相应会有一定的利息interest[i],问经过若干年 year 后,每年都以最优的方案投资,总的资金有多少? 完全背包题,不过要看清楚 这句话:The value of a bond is always a multiple of $1 000,否则TLE了 1 #include <ios

hdu 1963 Investment 完全背包

hdu题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1963 poj题目链接:http://poj.org/problem?id=2063 完全背包 每过一年就重新做一次完全背包 注意到本钱非常大 不能直接暴力 看到基金的成本都是1000的倍数(注意它没说本钱什么的也是1000的倍数) 就要灵活对f[]进行处理了 最后一个问题是 f[]应该给多大 第一次我给了1010然后跪了 才发现只是说本金不超过一百万 注意到一个条件 利息不会超过10% 所以1

hdu 1963 Investment 多重背包

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1963 //多重背包 #include <cstdio> #include <cstring> #include <iostream> using namespace std; const int maxn = 1000000 + 10; #define N 15 long long dp[maxn], ans; int c[N], w[N], V; void Pack(in

初涉分组背包 HDU 1561 The more,The better

给出一个森林,每棵树均为一组物品,首先推出每棵树可以组成的物品种类. 然后是基本的分组背包模板. 即 最外层枚举组数,次外层枚举背包容量,内层枚举物品体积. 对于每棵树有 ans[root][i+j] = ans[root][ i ] + ans[son][ j ]. 题水数据也水,不多说了. #include <iostream> #include <algorithm> #include <cstdlib> #include <cstdio> #incl

【板+背包】多重背包 HDU Coins

http://acm.hdu.edu.cn/showproblem.php?pid=2844 [题意] 给定n种价值为Ci,个数为Wi的硬币,问在1~V中的这些数中哪些数能由这些硬币组成? [思路] 多重背包,二进制优化,时间复杂度为O(V*log∑ni) [Accepted] 1 #include<iostream> 2 #include<cstdio> 3 #include<cmath> 4 #include<cstring> 5 #include<

完全背包HDU 2159

dp[j][kk]  = max(dp[j][i],dp[j-a[i].cost][kk-1]+dp[a[i].vla]); j个空间里放kk个获得的最大的价值 比一般的完全背包多了一层循环,因为要最多k件 找的时候只要找到第一次>=n的时候就可以了 FATE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 8291    Accept

01背包 HDU 2639,第K优解

只要每次都保存前k优解就可以了 注意当价值一样时,只算一种,所以要进行去重复 的操作 用到了unique, 1 2 2 4 0 0 unique之后1 2 4 0 0 2 Bone Collector II Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2433    Accepted Submission(s): 1277 Prob

完全背包[HDU 1114] Piggy-Bank

Piggy-Bank Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12466    Accepted Submission(s): 6312 Problem Description Before ACM can do anything, a budget must be prepared and the necessary fina

dp重拾-01背包--HDU 2602

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …The bone collector had a big bag with a volume of V ,and along his tri