POJ 3723.Conscription 最小生成树

Conscription

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13438   Accepted: 4699

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223题目链接:http://poj.org/problem?id=3723题意:招收n个女的和m个男的,每招收一个人付出10000元,现在他(她)们之间有关系,如果x,y之间的关系为d,当招收了x后在招收y,则y的招收费用为10000-d;同理,当招收了y之后再招收x,则x的招收费用为10000-d。因为招收顺序不同,招收总费用也会不同,求出招收费用最低。
思路:关系之间建立一条无向边,利用某些关系招收会形成一个生成树,当要招收总费用最低,那么需要生成树的边权值最大。如果关系图的权值取负数,就是求最小生成树。代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<set>
using namespace std;
typedef pair<int,int> P;
typedef long long ll;
const int maxn=1e5+100,inf=0x3f3f3f3f,mod=1e9+7;
const ll INF=1e13+7;
struct edge
{
    int from,to;
    int cost;
};
edge es[maxn];
vector<edge>G[maxn];
int used[maxn];
priority_queue<P,vector<P>,greater<P> >que;
void addedge(int i,int u,int v,int w)
{
    es[i].from=u,es[i].to=v,es[i].cost=w;
    G[u].push_back(es[i]);
}
int prim(int s)
{
    int ans=0;
    que.push(P(0,s));
    while(!que.empty())
    {
        P p=que.top();
        que.pop();
        int u=p.second,d=p.first;
        if(used[u]) continue;
        used[u]=1;
        ans+=d;
        for(int i=0; i<G[u].size(); i++)
        {
            edge e=G[u][i];
            if(used[e.to]) continue;
            que.push(P(e.cost,e.to));
        }
    }
    return ans;
}
int main()
{
    int t;
    int n,m,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&r);
        for(int i=0;i<n+m;i++)
        {
            G[i].clear();
            used[i]=0;
        }
        for(int i=1; i<=r; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            addedge(i,u,v+n,-w);
            addedge(i,v+n,u,-w);
        }
        int ans=0;
        for(int i=0; i<n+m; i++)
            if(!used[i]) ans+=prim(i);
        printf("%d\n",(n+m)*10000+ans);
    }
    return 0;
}

最小生成树prim算法

				
时间: 2024-07-30 02:51:53

POJ 3723.Conscription 最小生成树的相关文章

poj 3723 Conscription(最小生成树拓展)

Conscription Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7702   Accepted: 2667 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be

POJ 3723 Conscription 最小生成树 克鲁斯卡尔算法变形

#include <cstdio> #include <iostream> #include <algorithm> #include <queue> #include <stack> #include <cstdlib> #include <cmath> #include <set> #include <map> #include <vector> #include <cstri

poj 3723 Conscription 【最大生成树|最大权森林】

题目:poj 3723 Conscription 题意:要征兵n个男兵和m个女兵,每个花费10000元,但是如果已经征募的男士兵中有和将要征募的女士兵关系好的,那么可以减少花费,给出关系,求最小花费. 分析:这个题目初始一个是个二分图,以为可以从这里入手,但是这个题目这个性质没用. 初始花费没人10000,那么减去其中有关系的就是当前的花费. 要是花费最少,那么减去的最大即可,又因为没人只征募一次,即最多选择一个,所以减去一个最大生成树就ok AC代码: #include <cstdio> #

POJ 3723 Conscription (Kruskal并查集求最小生成树)

Conscription Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14661   Accepted: 5102 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to b

POJ 3723 Conscription(最小生成树)

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationshi

POJ 3723 Conscription

http://poj.org/problem?id=3723 这道题 把男生画一边 女生画一边 ---->是一个二部图的结构 就很容易看出 要pay最少 实际上就是找到一个连接所有点权值和最大的图 但是又要求 一个人只能使用一种关系减钱 所以不能有回路 ---->是一棵树 所以就是求最大生成树 有了前面并查集题目的经验 我们可以让i < N为女生 i >=N 作为男生 来维持这个并查集 那么就自然的使用Kruskal即可 1 #include <iostream> 2

poj - 3723 Conscription(最大权森林)

http://poj.org/problem?id=3723 windy需要挑选N各女孩,和M各男孩作为士兵,但是雇佣每个人都需要支付10000元的费用,如果男孩x和女孩y存在亲密度为d的关系,只要他们其中有一个已经被选中,那么在选另一个人需要的费用为100000-d,给定R个关系,输出一个最低费用,每个关系只能使用一次. 把人看作顶点,关系看作边,就可以转化为无向图中的最大权森林问题,最大权森林问题可以通过把所有边权取反之后用最小生成树的算法求解. 1 #include <cstdio> 2

POJ 3723 Conscription(征兵) 题解

此文为博主原创题解,转载时请通知博主,并把原文链接放在正文醒目位置. 题目链接:http://poj.org/problem?id=3723 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect

POJ 3723 Conscription (最大权森林 + Kruskal算法)

Conscription Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8317   Accepted: 2887 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be