Catch That Cow BFS求线性双向最短路径

Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

开始考虑用dfs做。。没考虑双向问题,向左向右会陷入死循环。还是BFS大法好,,求最短路径问题,遍历部分点即可。

#include<stdio.h>
#include<queue>
using namespace std;

struct Node{
    int x,y;
}node;
int b[200010];

int main()
{
    int n,k;
    queue<Node> q;
    scanf("%d%d",&n,&k);
    if(n==k) printf("0\n");    //特判
    else{
    node.x=n;
    node.y=0;
    q.push(node);
    b[n]=1;
    while(q.size()){
        node.x=q.front().x*2;
        node.y=q.front().y+1;
        if(node.x<=200010&&node.x>=0){
            if(node.x==k){
                printf("%d\n",node.y);
                break;
            }
            if(b[node.x]==0){
                b[node.x]=1;
                q.push(node);
            }
        }
        node.x=q.front().x+1;
        node.y=q.front().y+1;
        if(node.x<=200010&&node.x>=0){
            if(node.x==k){
                printf("%d\n",node.y);
                break;
            }
            if(b[node.x]==0){
                b[node.x]=1;
                q.push(node);
            }
        }
        node.x=q.front().x-1;
        node.y=q.front().y+1;
        if(node.x<=200010&&node.x>=0){
            if(node.x==k){
                printf("%d\n",node.y);
                break;
            }
            if(b[node.x]==0){
                b[node.x]=1;
                q.push(node);
            }
        }
        q.pop();
    }
    }
    return 0;
}
时间: 2024-11-06 18:33:46

Catch That Cow BFS求线性双向最短路径的相关文章

[ACM] hdu 2717 Catch That Cow (BFS)

Catch That Cow Problem Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same

HDU 2717 Catch That Cow(bfs)

Catch That Cow Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10575    Accepted Submission(s): 3303 Problem Description Farmer John has been informed of the location of a fugitive cow and want

POJ 3278 Catch That Cow(BFS,板子题)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 88732   Accepted: 27795 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

POJ 3275 Catch That Cow(bfs)

Catch That Cow Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number

poj 3278 Catch That Cow (bfs搜索)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 46715   Accepted: 14673 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

poj 3278 catch that cow BFS(基础水)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 61826   Accepted: 19329 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

HDU2717 Catch That Cow ( BFS )

Catch That Cow Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a

Catch That Cow (BFS广搜)

问题描述: Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has

POJ 3278 Catch That Cow(bfs)

题意:给定n,k两个数,三种操作,加一,减一,乘2,求n到k的最少步数: 思路:广搜求最少步数: #include<cstdio> #include<cstring> #include<algorithm> using namespace std; int n,m; int q[500010]; int num[500010]; int bfs() { int b=0,e=0; q[e++]=n; if(n==m) return 0; while(b<e) { i