统计字符
题目链接
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
统计一个给定字符串中指定的字符出现的次数
Input
测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串。注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一。当读到‘#‘时输入结束,相应的结果不要输出。
Output
对每个测试用例,统计第1行中字符串的每个字符在第2行字符串中出现的次数,按如下格式输出:
c0 n0
c1 n1
c2 n2
...
其中ci是第1行中第i个字符,ni是ci出现的次数。
Sample Input
I
THIS IS A TEST
i ng
this is a long test string
Sample Output
I 2
i 3
5
n 2
g 2
注:第2个测试用例中,空格也是被统计的字符之一。
采用了一种比较麻烦的方法:字符串的hash方法
#include<iostream>
using namespace std;
inline int hashFunc(char c)
{
int hashValue;
if(c >= 'A' && c <= 'Z')
hashValue = 257 + c - 'A';
else if(c >= 'a' && c <= 'z')
hashValue = 257 + 26 + c - 'a';
else
hashValue = 0 + c - ' ';
return hashValue;
}
int main()
{
//freopen("in.txt","r", stdin);
string str1, str2;
while(getline(cin, str1), str1!="#")
{
getline(cin, str2);
int arr[400] = {0};
for(int i=0;i<str2.length();i++)
arr[hashFunc(str2[i])]++;
for(int i=0;i<str1.length();i++)
printf("%c %d\n",str1[i], arr[hashFunc(str1[i])]);
}
return 0;
}
下边的是一种简单的方法:
#include<iostream>
#include <cstring>
#include<memory.h>
using namespace std;
int main() {
char a[6], b[81];
int ans[256]={0};
while (gets(a) && a[0] != '#') {
gets(b);
memset(ans,0,256*sizeof(int));
// 统计出每个字符的出现次数
for(int i=0;i<strlen(b);i++){
ans[b[i]]++;
}
// 直接输出结果
for(int i=0;i<strlen(a);i++){
printf("%c %d\n", a[i], ans[a[i]]);
}
}
return 0;
}
原文地址:https://www.cnblogs.com/SYDong/p/12253249.html
时间: 2024-10-11 09:19:08