POJ1789:Truck History(Prim算法)

http://poj.org/problem?id=1789

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company‘s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

此题难点在于读题,明白题意后就是一个很简单的最小生成树

明白一点就行:将每一个卡车类型代码(truck type codes)作为一个结点,任意两个 卡车类型代码中 相同位置即字符数组a[i],a[i+1] 上 a[i]和a[i+1]为不同字符的位置的个数 做为

这两个结点之间的路径的权值。

读题啊,硬伤啊!

#include <iostream>
#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
using namespace std;
char a[2001][8];
int map[2001][2001];
int n,dis[2001],v[2001];
void prim()
{
    int min,sum=0,k;
    for(int i=1; i<=n; i++)
    {
        v[i]=0;
        dis[i]=INF;
    }
    for(int i=1; i<=n; i++)
        dis[i]=map[1][i];
    v[1]=1;
    for(int j=1; j<n; j++)
    {
        min=INF;
        for(int i=1; i<=n; i++)
        {
            if(v[i]==0&&dis[i]<min)
            {
                k=i;
                min=dis[i];
            }
        }
        sum+=min;
        v[k]=1;
        for(int i=1; i<=n; i++)
        {
            if(v[i]==0&&map[k][i]<dis[i])
            {
                dis[i]=map[k][i];
            }
        }
    }
    cout<<"The highest possible quality is 1/"<<sum<<"."<<endl;
}
int main()
{
    int count;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(int i=1; i<=n; i++)
            scanf("%*c%s",a[i]);
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                count=0;
                for(int k=0; k<7; k++)
                    if(a[i][k]!=a[j][k])
                    {
                        count++;
                    }
                map[i][j]=count;
                map[j][i]=count;
            }
        }
        prim();
    }
    return 0;
}
时间: 2024-10-14 13:28:17

POJ1789:Truck History(Prim算法)的相关文章

POJ1789 Truck History【Prim】

Truck History Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 19456 Accepted: 7498 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. T

POJ1789 Truck History 【最小生成树Prim】

Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18981   Accepted: 7321 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for brick

Truck History(prim &amp; mst)

Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19772   Accepted: 7633 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for brick

POJ2032 Truck History(Prim)

Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 24724   Accepted: 9636 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for brick

POJ 1789 -- Truck History(Prim)

 POJ 1789 -- Truck History Prim求分母的最小.即求最小生成树 1 #include<iostream> 2 #include<cstring> 3 #include<algorithm> 4 using namespace std; 5 const int maxn = 2000 + 10; 6 const int INF = 1000000; 7 int n;//有几个卡车 8 char str[maxn][10]; 9 int d[ma

POJ-1789 Truck History---最小生成树Prim算法

题目链接: https://vjudge.net/problem/POJ-1789 题目大意: 用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数.一个编号只能由另一个编号"衍生"出来,代价是这两个编号之间相应的distance,现在要找出一个"衍生"方案,使得总代价最小,也就是distance之和最小. 思路: 最小生成树模板题,这里是稠密图,应该用prim算法 直接在原来模板的基础上稍加改动即可 1 #inclu

poj1789Truck History(最小生成树prim算法)

题目链接: 啊哈哈,点我点我 思路:根据字符串中不同的长度建图,然后求图的最小生成树.. 题目: Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18272   Accepted: 7070 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vege

poj 1789 Truck History 最小生成树 prim

Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19122   Accepted: 7366 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for brick

poj1789(Truck History)

题目大意: 题目意思一个卡车类型由7个字符构成,每个字符所在的位置有它特定的含义,这里有一个Q的含义为N个不同卡车之间7个字符之间相同位置不同字符的个数cnt之和,求出最小的Q(存在一种N哥卡车两两比较后cnt之和最小). 解题思路; 主要是理解题意,把卡车看成编号为(1-N)的数,两两比较卡车的cnt值为编号x-y的cost值.然后分析后建图,因为求最小的Q值意为求图中生成树的最小权值就是求最小生成树. 代码: 1 #include <algorithm> 2 #include <io