HDU 4004 The Frog's Games(基本算法-贪心,搜索-二分)

The Frog‘s Games

Problem Description

The annual Games in frogs‘ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000).
There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog‘s longest jump distance).

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m.

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output

For each case, output a integer standing for the frog‘s ability at least they should have.

Sample Input

6 1 2
2
25 3 3
11
2
18

Sample Output

4
11

Source

The 36th ACM/ICPC
Asia Regional Dalian Site —— Online Contest

Recommend

lcy

题目大意:

长为L的河流,中间有n个石头,告诉你石头的位置,青蛙的跳跃能力至少为多少中途跳m次能跳过去?

解题思路:

二分+贪心的题目,因为青蛙的跳跃能力越强需要的次数就越少,因此青蛙的跳跃能力有单调性,所以二分枚举青蛙的跳跃能力,在判断这个能力下是否能够跳过去,这个用贪心解决,每次在这个能力下尽可能跳到远的石头上,最后看m次是否跳到了对岸。

解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int L,n,m;
vector <int> v;

void input(){
    int x;
    v.clear();
    v.push_back(0);
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        v.push_back(x);
    }
    v.push_back(L);
    sort(v.begin(),v.end());
}

bool canJump(int dis){
    int s=0,l=0,pos=0,vsize=v.size();
    for(int i=0;i<m;i++){
        while( l<vsize && v[l]<=s+dis){
            pos=v[l];
            l++;
        }
        s=pos;
    }
    if(s>=L) return true;
    else return false;
}

void solve(){
    int l=0,r=L;
    while(l<r){
        int mid=(l+r)/2;
        if(canJump(mid)) r=mid;
        else l=mid+1;
    }
    printf("%d\n",r);
}

int main(){
    while(scanf("%d%d%d",&L,&n,&m)!=EOF){
        input();
        solve();
    }
    return 0;
}

HDU 4004 The Frog's Games(基本算法-贪心,搜索-二分),布布扣,bubuko.com

HDU 4004 The Frog's Games(基本算法-贪心,搜索-二分)

时间: 2024-08-25 06:34:59

HDU 4004 The Frog's Games(基本算法-贪心,搜索-二分)的相关文章

HDU 4004 The Frog&#39;s Games 二分 贪心

戳这里:HDU 4004 //思路:二分经典入门题...贪心判方案是否可行 1 #include "bits/stdc++.h" 2 using namespace std; 3 int L, n, m; 4 int pos[500010], dis[500010]; 5 6 bool Cant(int Dis_Jump) 7 { 8 int i, Dis_Sum = 0, Count = 0; 9 for(i = 1; i <= n + 1; ++i) { 10 if(dis[

hdu 4004 The Frog&#39;s Games【二分】

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 3980    Accepted Submission(s): 1931 Problem Description The annual Games in frogs' kingdom started again. The most famous game

HDU 4004 The Frog&#39;s Games 二分

1.题意:一条河长为L,河上有N块石头,一只青蛙可以利用这些石头从河的一端跳到对岸,可以跳不超过M次,求各种跳法中,找到最小化的最大步长.输入第一行依次给出L.N.M,第二行依次给出N块石头距离起点的距离. 2.分析:这类最小化最大值的问题用二分来求解最高效.先预先处理,连同起点,终点,共N+2个点排序,两两相减得到N+1段距离C[i],即跨一步的最小距离.二分维护mid值,上界为河长L,下界为两两距离之中的最大值maxC[i](反证易知),以mid值分割C[i]数组,分割的段数<=M则mid偏

hdu 4004 The Frog&#39;s Games 【二分】

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 4565    Accepted Submission(s): 2225 Problem Description The annual Games in frogs' kingdom started again. The most famous game

hdu 4004 The Frog&#39;s Games

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4004 The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over

HDU 4004 The Frog&#39;s Games(二分+小思维+用到了lower_bound)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 9678    Accepted Submission(s): 4428 The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triat

HDU 4004 The Frog&#39;s Games(二分答案)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 10307    Accepted Submission(s): 4686 Problem Description The annual Games in frogs' kingdom started again. The most famous game

hdoj 4004 The Frog&#39;s Games(二分)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 5676    Accepted Submission(s): 2732 Problem Description The annual Games in frogs' kingdom started again. The most famous game i

HDU 4024 Dwarven Sniper’s hunting (计算几何-其它,搜索-二分)

Dwarven Sniper's hunting Problem Description Now the hunting starts in the world named DOTA, a stupid PC game which cannot play with others together. Among the individuals in the game, there are two heroes named Dwarven Sniper and Lycanthrope. Lycant