POJ 1068--Parencodings--括号逆匹配(模拟)

Parencodings

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19655   Accepted: 11870

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

题意搞了就好几天。。sad 回来补题

题目中给了两个序列 p 和 w 和一个串s(s是已经匹配好的括号)其中p序列中的第i个数代表第i个右括号前面的左括号的个数(好蛋疼) w序列中第i个数代表第i个右括号和与之匹配的左括号这中间有多少对匹配的括号(包括i) 很简单,根据给定p序列把s串模拟出来,然后从左边开始遍历s,遇到右括号就向前逆向匹配,就是找到与这个右括号匹配的左括号,可以设两个变量l,r
初始化为0,从遇到的这个右括号的位置开始遇到左括号l++,遇到右括号r++,当l==r时 l的值就是匹配的括号的对数。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cctype>
#include <algorithm>
#include <vector>
using namespace std;
int a[1000100],ans[1000100];
char s[1000010];
int main()
{

	int i,j,n,t;
	cin>>t;getchar();
	while(t--)
	{
	  int p=0;
	  cin>>n;a[0]=0;
	  for(i=1;i<=n;i++)
		cin>>a[i];
	  for(i=1;i<=n;i++)
	  {
	  	for(j=0;j<a[i]-a[i-1];j++)
			s[p++]='(';
		s[p++]=')';
	  }
	  s[p]='\0';
	  //cout<<s<<endl;
	  int q=0;
	  for(i=0;i<p;i++)
	  {
	  	if(s[i]==')')
		{
			int l=0,r=0;
			for(j=i;j>=0;j--)
			{
				if(s[j]=='(')l++;
				if(s[j]==')')r++;
				if(l==r) break;
			}
			ans[q++]=r;
		}
	  }
	  for(i=0;i<q;i++)
		if(i!=q-1)
		cout<<ans[i]<<" ";
	    else
		cout<<ans[i]<<endl;
	}
	return 0;
}

POJ 1068--Parencodings--括号逆匹配(模拟),布布扣,bubuko.com

时间: 2025-01-16 01:31:35

POJ 1068--Parencodings--括号逆匹配(模拟)的相关文章

[ACM] POJ 1068 Parencodings(模拟)

Parencodings Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19352   Accepted: 11675 Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn

poj 1068 Parencodings

Parencodings Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 22797   Accepted: 13363 Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn

HDU 1361 &amp; POJ 1068 Parencodings(模拟)

题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1361 POJ:http://poj.org/problem?id=1068 Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn where

poj 1068 Parencodings(模拟)

Parencodings Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19434   Accepted: 11734 题目大意:  给出一个整数表示有n组测试样例  每个样例包含两组数  一个整数m 和一个有m个元素的p数组 数组中的元素表示的意思为第i个' ) '之前有多少个' ( '   . 要求输出一个w数组其元素表示的意思为在第i个' ) '和它匹配的'('之间有多少组已匹配好的括号  (包括其自身) 例如 S

POJ 1068 Parencodings (模拟),暑假第一题~

终于考完高线大,头也不那么疼了,也终于有空来刷题了~,先来一发水题试试水 题目链接:http://poj.org/problem?id=1068 简单的模拟,麻烦在理解题意,,英语好的请无视这句: [分析] S (((()()()))) P-sequence 4 5 6666 W-sequence 1 1 1456 如这个 S字符串, 题目给你一串数 4 5 6 6 6 6    对应P1 P2,,,Pn 意思是,第n个右括号')'左边有Pn 个左括号 ,,例如 456666 第1个右括号")&

poj 1068 Parencodings 模拟题

Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). q B

POJ 之 Parencodings (类似括号的处理问题)

Parencodings Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19550   Accepted: 11804 Description Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: q By an integer sequence P = p1 p2...pn

POJ 3087 Shuffle&#39;m Up (模拟)

Shuffle'm Up Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5850   Accepted: 2744 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of

poj 2406 Power Strings KMP匹配

对于数组s[0~n-1],计算next[0~n](多计算一位). 考虑next[n],假设t=n-next[n],如果n%t==0,则t就是问题的解,否则解为1. 这样考虑: 比如字符串"abababab", a  b a b a b a b * next     -1 0 1 2 3 4 5 6  7 考虑这样的模式匹配,将"abababab#"当做主串,"abababab*"当做模式串,于是进行匹配到n(n=8)时,出现了不匹配: 主串