HDU 3336 Count the string (KMP next数组运用——统计前缀出现次数)

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6375    Accepted Submission(s): 2947

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1

4

abab

Sample Output

6

Author

[email protected]

Source

HDOJ Monthly Contest – 2010.03.06

题意:统计一个字符串的所有前缀在字符串中出现的次数的和

分析:next数组的运用,因为next数组可以表示以当前坐标的前一个字符结尾的字符串的前缀和后缀有多少个字符相等

举个例子,有一个字符串

0   1    2    3    4    5    6    7    8   9   10   11  12  13

a    b    c    d    a    b    d    a    b    c    d    a    b

-1  0    0    0    0    1    2    0    1    2   3    4    5     6

可见当i=9时,前缀ab和当前的abcdabdab最后的ab相等,所以长度为2,本应该答案是+1,但是想一想,既然ab都匹配了,那么a也会是匹配的,所以答案应该+2,发现这难道

不就是next[i]的值吗?所以说,只用加next[i]的值就行了,因为当前字符匹配完成之后,前面的字符也被匹配了。

所以最后的答案=字符串长度(前缀的个数)+每一个非0的next[]数组的值

但是这里要注意一点就是说,当next[i]+1==next[i+1]的时候,说明后面的字符会继续匹配下去,这种情况就不要加了,因为会重复统计。

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
#define FIN freopen("in.txt","r",stdin)
using namespace std;
const int MAXN=200000+5;
const int MOD=10007;
int n;
int nex[MAXN];
char str[MAXN];

void getnext()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<=n)
    {
        if(k==-1 || str[j]==str[k])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int main()
{
    //FIN;
    int kase;
    scanf("%d",&kase);
    while(kase--)
    {
        int ans=0;
        scanf("%d %s",&n,str);
        getnext();
        for(int i=0;i<=n;i++)
        ans=(ans+nex[n]+n)%MOD;
        for(int i=0;i<n;i++)
        {
            if(nex[i]>0 && (nex[i]+1)!=nex[i+1])
                ans=(ans+nex[i])%MOD;
        }
        printf("%d\n",ans);
    }
    return 0;
}

时间: 2024-09-30 11:24:18

HDU 3336 Count the string (KMP next数组运用——统计前缀出现次数)的相关文章

hdu 3336 Count the string KMP+DP

Count the string Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 6375    Accepted Submission(s): 2947 Problem Description It is well known that AekdyCoin is good at string problems as well as n

hdu 3336 Count the string(next数组)

题意:统计前缀在串中出现的次数 思路:next数组,递推 #include<iostream> #include<stdio.h> #include<string.h> using namespace std; #define MaxSize 200005 #define Mod 10007 char str[MaxSize]; int _next[MaxSize]; int dp[MaxSize]; int len; void GetNext(char t[]){//

hdu 3336 Count the string(KMP)

一道应用kmp算法中next数组的题目 这其中vis[i]从1加到n vis[i]=[next[i]]+1; #include<string.h> #include<stdlib.h> #include<stdio.h> #include<iostream> #include<algorithm> using namespace std; char s[200005]; int b; int next[200005]; int vis[20000

hdu 3336 Count the string

Count the stringTime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4239    Accepted Submission(s): 1977 Problem Description It is well known that AekdyCoin is good at string problems as well as num

HDU 3336 Count the string (next数组活用)

Count the string Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5224    Accepted Submission(s): 2454 Problem Description It is well known that AekdyCoin is good at string problems as well as n

HDU 3336 Count the string (基础KMP)

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: s: "abab" The prefixes are: "a", "ab&qu

KMP——hdu 3336 count the string

Count the string Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10478    Accepted Submission(s): 4893 Problem Description It is well known that AekdyCoin is good at string problems as well as n

HDU 3336 Count the string(KMP算法next数组的应用)

解题思路: 求前缀数组出现的次数之和,next[i] > 0 表示长度为next[i]的前缀又出现了一次. #include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <algorithm> #include <cmath> #include <vector> #include <queue> #

hdu 3336 Count the string【kmp】

http://acm.hdu.edu.cn/showproblem.php?pid=3336 题意:给你一个字符串,问字符串每一个前缀在字符串中的出现总次数. 思路:kmp的应用,自身和自身进行匹配,每次匹配时,如果没有匹配到结束,模式串按next数组向后移动,出现匹配至结束的情况,匹配串往后移动一位 ,匹配过程中,出现失配时,统计当前已经匹配的字符个数,累加到总数中,直到匹配串移动到最后一位. 其实前两天就在网上看题解用kmp+dp的方法来写了这道题,然而后来细思一些细节,自己并没有弄懂,所以