hdoj 1492 The number of divisors(约数) about Humble Numbers 【数论】【质因子分解 求和】

定理:一个正整数 n 可以用素因子唯一表示为 p1^r1 * p2^r2 * ...
pk^rk (其中 pi 为素数) , 那么这个数的因子的个数就是,(r1+1)*(r2+1)*...*(rk+1).

理解:为什么是加1之后再相乘,因为一个数的的因子数至少为1和他自身,但因为r1,r2。。可以为0,所以因子的个数为(r1+1)。。。

拓展一下:

定理1: 一个正整数 n 可以用素因子唯一表示为 p1^r1 * p2^r2 * ... pk^rk (其中 pi 为素数) , 那么这个数的因子的个数就是,(r1+1)*(r2+1)~(rk+1).

定理2:如果一个数字 n = p1^r1 * p2^r2 * ... pk^rk ,那么 n*n = p1^r1 * p2^r2 * ... pk^rk   * p1^r1 * p2^r2 * ... pk^rk ,它的因子的个数就是 (2*r1+1)*(2*r2+1)~(2*rk+1)

Humble Numbers只要2,3,5,7,因此只要统计这四个因子的数目就可以了!

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2486    Accepted Submission(s): 1203

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input

The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output

For each test case, output its divisor number, one line per case.

Sample Input

4
12
0

Sample Output

3
6

代码:

#include<stdio.h>
int main()
{
    __int64 n, c2, c3, c5, c7;
    while(scanf("%I64d", &n), n){
        c2 = c3 = c5 =c7 = 1;
        while(n%7 == 0){
            c7++;
            n/=7;
        }
        while(n%5==0){
            c5++;
            n/=5;
        }
        while(n%3==0){
            c3 ++;
            n /= 3;
        }
        while(n%2 == 0){
            c2 ++;
            n /= 2;
        }
        __int64 ans =c2*c3*c5*c7;
        printf("%I64d\n", ans);
    }
}

hdoj 1492 The number of divisors(约数) about Humble Numbers 【数论】【质因子分解 求和】,布布扣,bubuko.com

时间: 2024-11-18 21:21:35

hdoj 1492 The number of divisors(约数) about Humble Numbers 【数论】【质因子分解 求和】的相关文章

HDU 1492 The number of divisors(约数) about Humble Numbers 数论

The number of divisors(约数) about Humble Numbers Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8,

HDU 1492 The number of divisors(约数) about Humble Numbers(数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1492 Problem Description A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the firs

The number of divisors(约数) about Humble Numbers

The number of divisors(约数) about Humble Numbers Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3033    Accepted Submission(s): 1465 Problem Description A number whose only prime factors are 2,3

HDU - The number of divisors(约数) about Humble Numbers

Description A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. Now given a humble number, please write

The number of divisors(约数) about Humble Numbers--hdu1492

http://acm.hdu.edu.cn/showproblem.php?pid=1492 题目大意:  给你一个n    这个n呢  他的素因子只有2 3 5 7 这四个数   没有其他的素因子   求他的因子数   n是2的64次方 分析  :  只求出他的素因子的个数  每一个加一  相乘就行 #include<cstdio> #include<cstring> #include<stack> #include<vector> #include<

hdu-1492 The number of divisors(约数) about Humble Numbers---因子数公式

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1492 题目大意: 给出一个数,因子只有2 3 5 7,求这个数的因子个数 解题思路: 直接求出指数即可 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 #include<cmath> 6 #include<queue>

水题 HDOJ 4727 The Number Off of FFF

题目传送门 1 /* 2 水题:判断前后的差值是否为1,b[i]记录差值,若没有找到,则是第一个出错 3 */ 4 #include <cstdio> 5 #include <iostream> 6 #include <algorithm> 7 #include <cstring> 8 #include <string> 9 #include <cmath> 10 using namespace std; 11 12 const in

hdoj.3826 Squarefree number

hdoj 3826 Squarefree number 考虑一个数能被完全平方数整除,当且仅当对其分解质因数以后,至少有一个质数的指数\(≥2\) 借用试除法分解质因数的思路,大于\(\sqrt[3]{N}\)的质因子至多只有一个.那么,大于 \(\sqrt[3]{N}\) 的质因数的平方整除 $N $ 的个数至多也只有一个,而且指数至多为 \(2\) ,因为指数再大或者再乘上一个等数量级的完全平方数都会超过 $ 10^{18} $ 的数据范围. 然后就筛出 \(\sqrt[3]{10^{18}

HDOJ Guess the number 3337【神题-抓取杭电后台输出数据】

Guess the number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 7077    Accepted Submission(s): 1626 Problem Description AekdyCoin is the most powerful boy in the group ACM_DIY, whose signatur