2015苏州大学ACM-ICPC集训队选拔赛(2) 1001 1010

草爷要的榜

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 41   Accepted Submission(s) : 26

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

苏州大学代表队又勤奋地开始了训练。
今天开了一场时长5小时的组队训练赛,苏州大学的n(1<=n<=100)支校队奋力拼(hua)搏(shui),每一支队伍都做出来了k(1<=k<=10)道题,但是因为罚时有差别,所以名次也不同。
现在给出了每个队伍的AC情况,请按照罚时从少到多输出每个队伍的罚时。

排名规则如下:
1、如果AC题数不同,则过题目数多的队伍名次靠前;
2、如果AC题数相同,则按照罚时多少,总罚时少的队伍名次靠前。
罚时计算规则如下:
1、每个题目只有AC时它的罚时才计入总罚时,总罚时为每个AC题目的基础罚时和加罚时的和;
2、每个AC了的题目的基础罚时是从比赛开始到这题AC所经过的分钟数;
3、每个AC了的题目的加罚时是:第一次AC之前的每个错误提交(包括WA、RE、TLE、MLE等)会额外增加20分钟加罚时。

Input

多组数据(<=100),请读到文件结尾。
每组数据以两个整数n和k开头;
接下来为n支队伍的过题时间以及提交次数,每支队伍占两行:
每支队伍第一行为k个时间,格式(xx:yy),第i个时间表示第i个题AC时间为xx小时yy分钟。
每支队伍第二行为k个整数,第i个整数表示第i个题总提交次数a[i](1<=a[i]<=200,总次数包括一次AC提交);
数据保证总罚时在32位整数内,每支队伍某题AC之后不再提交该题。

Output

对于每组输入,输出一行:
按照本场训练赛的罚时从少到多输出各个队伍的总罚时(分钟数),每两个数间用一个空格隔开。

Sample Input

3 5
00:59 00:25 04:16 00:12 03:57
1 2 1 1 3
01:03 00:17 02:38 00:22 02:08
1 1 1 1 1
00:44 00:29 03:42 00:20 01:53
1 1 3 1 1
1 7
00:27 01:58 03:15 00:47 02:44 04:13 02:39
2 1 4 4 1 7 4
4 3
02:12 00:42 00:24
4 1 1
01:27 03:03 00:31
1 2 1
00:58 00:33 00:18
1 1 1
04:05 00:41 01:27
6 2 4

Sample Output

388 468 649
1283
109 258 321 553

Author

奚政

一个很简单的模拟,注意一下时间的换算就好

#include<stdio.h>
//#include<bits/stdc++.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<sstream>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include<algorithm>
#include<limits.h>
#define inf 0x3fffffff
#define INF 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
#define ULL unsigned long long
using namespace std;
struct P
{
    // string s;
    int sum;
} L[100000];
int i,j;
int n,m;
int k;
int M,s;
int FA;
bool cmd(P x,P y)
{
    return x.sum<y.sum;
}
int main ()
{
    while(cin>>n>>k)
    {
        for(j=0;j<n;j++)
        {
            int num=0;
            for(i=0; i<k; i++)
            {
                scanf("%d:%d",&M,&s);
                num+=M*60+s;
            }
            for(i=0; i<k; i++)
            {
                cin>>FA;
                num+=(FA-1)*20;
            }
            L[j].sum=num;
           // cout<<L[j].sum<<endl;
        }
        sort(L,L+n,cmd);
        for(i=0;i<n;i++)
        {
            if(i!=n-1)
            {
                printf("%d ",L[i].sum);
            }
            else
            {
               printf("%d\n",L[i].sum);
            }
        }
    }
    return 0;
}

  

高能数学题

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 92   Accepted Submission(s) : 38

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

给定一个正整数n,判断该数是不是3的倍数

Input

输入数据有多组(约300组)。每行一个正整数n(0<n<=10^10000)

Output

对于每组输入数据,输出一行"Yes"或"No"(不包括引号),表示n是不是3的倍数

Sample Input

1
123456789
2333333333333333333333333333333333333333

Sample Output

No
Yes
No

Author

高可攀

每位数相加求和,看是否整除3即可

#include<stdio.h>
//#include<bits/stdc++.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<sstream>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include<algorithm>
#include<limits.h>
#define inf 0x3fffffff
#define INF 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
#define ULL unsigned long long
using namespace std;
string s;
int main()
{
    while(cin>>s)
    {
        int sum=0;
        for(int i=0;i<s.length();i++)
        {
            sum+=s[i]-‘0‘;
        }
      // cout<<sum<<endl;
      if(sum%3==0)
      {
          puts("Yes");
      }
      else
      {
          puts("No");
      }
    }
    return 0;
}

  

时间: 2024-10-29 19:09:01

2015苏州大学ACM-ICPC集训队选拔赛(2) 1001 1010的相关文章

(并查集)Travel -- hdu -- 5441(2015 ACM/ICPC Asia Regional Changchun Online )

http://acm.hdu.edu.cn/showproblem.php?pid=5441 Travel Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 2061    Accepted Submission(s): 711 Problem Description Jack likes to travel around the wo

2015 ACM/ICPC Asia Regional Changchun Online HDU 5444 Elven Postman【二叉排序树的建树和遍历查找】

Elven Postman Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 591    Accepted Submission(s): 329 Problem Description Elves are very peculiar creatures. As we all know, they can live for a very

【题解】 2015 ACM/ICPC Asia Regional Shenyang Online

[1006] FangFang (暴力枚举) Fang Fang Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 871    Accepted Submission(s): 364 Problem Description Fang Fang says she wants to be remembered. I promise her.

hdu 5868 2016 ACM/ICPC Asia Regional Dalian Online 1001 (burnside引理 polya定理)

Different Circle Permutation Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 208    Accepted Submission(s): 101 Problem Description You may not know this but it's a fact that Xinghai Square is

2016 ACM/ICPC Asia Regional Qingdao Online 1001/HDU5878 打表二分

I Count Two Three Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 782    Accepted Submission(s): 406 Problem Description I will show you the most popular board game in the Shanghai Ingress Resis

《ACM/ICPC 算法训练教程》读书笔记一之数据结构(堆)

书籍简评:<ACM/ICPC 算法训练教程>这本书是余立功主编的,代码来自南京理工大学ACM集训队代码库,所以小编看过之后发现确实很实用,适合集训的时候刷题啊~~,当时是听了集训队final的意见买的,感觉还是不错滴. 相对于其他ACM书籍来说,当然如书名所言,这是一本算法训练书,有着大量的算法实战题目和代码,尽管小编还是发现了些许错误= =,有部分注释的语序习惯也有点不太合我的胃口.实战题目较多是比较水的题,但也正因此才能帮助不少新手入门,个人认为还是一本不错的算法书,当然自学还是需要下不少

【转】ACM/ICPC生涯总结暨退役宣言—alpc55

转自:http://hi.baidu.com/accplaystation/item/ca4c2ec565fa0b7fced4f811 ACM/ICPC生涯总结暨退役宣言—alpc55 前言 早就该写这篇文章了,但是也很不想去写.毕竟是为之奋斗了两年的目标,不是说舍得就舍得的.然而,自己毕竟是到了该退的时候了,与其扭扭捏捏,不如挥一挥衣袖,尚落得一份潇洒.回首这两年来,有很多是需要总结的.在这里不分巨细的记录下来,或许有点像流水账,但是更多的,是一份对过去的难忘. 童年 我的ACM/ICPC的生

hdu5353||2015多校联合第六场1001 贪心

http://acm.hdu.edu.cn/showproblem.php?pid=5353 Problem Description There are n soda sitting around a round table. soda are numbered from 1 to n and i-th soda is adjacent to (i+1)-th soda, 1-st soda is adjacent to n-th soda. Each soda has some candies

2014 ACM/ICPC Asia Regional Guangzhou Online Wang Xifeng&#39;s Little Plot HDU5024

一道好枚举+模拟题目.转换思维视角 这道题是我做的,规模不大N<=100,以为正常DFS搜索,于是傻乎乎的写了起来.各种条件限制模拟过程 但仔细一分析发现对每个点进行全部八个方向的遍历100X100X100^8 .100X100个点,每个点在走的时候8中选择,TLE 于是改为另一个角度: 以符合要求的点为拐弯点,朝两个垂直的方向走,求出最远的距离.这样只要对每个点各个方向的长度知道,组合一下对应的就OK. 避免了每个点深搜. PS:搜索的时候x,y写反了,导致构图出现问题,以后用[dy][dx]

HDU 5014 Number Sequence(2014 ACM/ICPC Asia Regional Xi&#39;an Online) 题解

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5014 Number Sequence Problem Description There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules: ● ai ∈ [0,n] ● ai ≠ aj( i ≠ j ) For sequence a and sequ