PAT 1088 1089. Insert or Merge (25)(排序啊)

题目链接:http://www.patest.cn/contests/pat-a-practise/1089

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist
remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed
that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

题意:

给出两个序列,第一个是初始序列,第二个是用某种排序来排序的过程中的一个序列!

让我们判断第二个序列是用的哪一种方法排序的,并且输出第二个序列用这种排序来排序的下一个序列!

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int a[147], b[147];
int n;
int isequal(int x)
{
	for(int i = x+1; i <= n; i++)
	{
		if(a[i] != b[i])
		{
			return 0;
		}
	}
	return 1;
}

int SORT(int len)
{
	for(int i = 1; i <= n; i+=len)
	{
		for(int j = i; j < n && j < i+len-1; j++)
		{
			if(b[j] > b[j+1])
			{
				return 0;
			}
		}
	}
	return 1;
}

int main()
{
	while(~scanf("%d",&n))
	{
		int i;
		for(i = 1; i <= n; i++)
		{
			scanf("%d",&a[i]);
		}
		for(i = 1; i <= n; i++)
		{
			scanf("%d",&b[i]);
		}
		for(i = 1; i < n; i++)
		{
			if(b[i] > b[i+1])
			{
				break;
			}
		}
		if(isequal(i+1))//后面的都相等
		{
			printf("Insertion Sort\n");
			sort(b+1,b+i+1 +1);
			printf("%d",b[1]);
			for(i = 2; i <= n; i++)
			{
				printf(" %d",b[i]);
			}
			printf("\n");
		}
		else
		{
			printf("Merge Sort\n");
			int len = 2;
			while(SORT(len))//寻找归并排序当前的子区间长度
			{
				len *=2;
			}
			for(i = 1; i <= n; i+=len)
			{
				if(i+len <= n)
				{
					sort(b+i,b+i+len);
				}
				else
				{
					sort(b+i,b+n+1);
				}
			}
			printf("%d",b[1]);
			for(i = 2; i <= n; i++)
			{
				printf(" %d",b[i]);
			}
			printf("\n");
		}
	}
	return 0;
}
/*
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 7 5 9 4 0 6
*/
时间: 2024-11-05 03:09:51

PAT 1088 1089. Insert or Merge (25)(排序啊)的相关文章

1089. Insert or Merge (25)【排序】——PAT (Advanced Level) Practise

题目信息 1089. Insert or Merge (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, find

1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

PAT 1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

PAT (Advanced Level) 1089. Insert or Merge (25)

简单题.模拟一下即可. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; const int maxn=200; int a[maxn],b[maxn],

pat1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

07-2. Insert or Merge (25)

07-2. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion so

PTA 09-排序2 Insert or Merge (25分)

题目地址 https://pta.patest.cn/pta/test/16/exam/4/question/675 5-13 Insert or Merge   (25分) According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort rem

1089 Insert or Merge (25 分)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

A1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li